Alfa Romeo Giulia Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
68 Posts
Discussion Starter · #1 ·
Hi,

I'm going on three months with my Giulia and loving it! What a beautiful, fun to drive car. It has had almost no problems except for this noise that has take me a while to track down.

- The rattle sounds metalic as if a fan had bad bearings or something
- It only happens if I have the heater on. If I have the heater off or the AC on I don't hear it.
- It does not happen immediately when turning on the heater, but starts a few minutes later
- It gets louder when I accelerate and stops when I am braking
- It seems to come from the center console, but it could be the dash.

Has anybody experienced something like this? Any fixes? The dealer is far away from me and I am also afraid that they might take apart my dash trying to fix it and make problems worse.

Thanks!
 

·
Registered
Joined
·
27 Posts
Mine had that noise, coming from behind the glove box, louder when box is open. That would make sense as the heater fan is probably right there. It was at low to mid fan speeds, sounded kind of like a zipper on a backpack dangling and would do it over certain bumps. Fan off, no noise. I ran it on highest setting for about 5 minutes, haven't heard is since.
 

·
Registered
Joined
·
68 Posts
Discussion Starter · #3 ·
Mine had that noise, coming from behind the glove box, louder when box is open. That would make sense as the heater fan is probably right there. It was at low to mid fan speeds, sounded kind of like a zipper on a backpack dangling and would do it over certain bumps. Fan off, no noise. I ran it on highest setting for about 5 minutes, haven't heard is since.
Thanks I'll try that. Also good to know where it is coming from.
 

·
Registered
Joined
·
443 Posts
Thanks I'll try that. Also good to know where it is coming from.
I've been also hearing some went related noise from somewhere around the direction of the glove box or the passenger door, but the noise to me almost sounded like "chirping" or a "cricket" sound. Not loud just a faint noise in the background. I also thought it was related to the heat fan, because when I shut down the fan the noise has stopped. Interestingly I only hear it when the car moves, when I stopped the car to investigate the noise also stopped. As the weather is getting warmer and the car now blows cooler air I no longer hear it. Next time I will also try the 5 minute full blown fan trick.
 

·
Registered
Joined
·
3 Posts
Following this as I have noticed the same thing. Chirping cricket is a good representation of what it sounds like! Only with the heater on. With the AC it is never an issue. Also, only while moving. I'll try running the fan on high as well to see if it works. Thanks!
 

·
Registered
Joined
·
68 Posts
Discussion Starter · #6 ·
yes, exactly Chirping cricket is what this is and only happens when it is moving.
 

·
Registered
Joined
·
19 Posts
My car is at the dealership now for this cricket sound when the fan is on speed 1-3. I'll report back when I pickup the car Monday.
 

·
Vendor
Joined
·
1,325 Posts
Following this as I have noticed the same thing. Chirping cricket is a good representation of what it sounds like! Only with the heater on. With the AC it is never an issue. Also, only while moving. I'll try running the fan on high as well to see if it works. Thanks!
yes, exactly Chirping cricket is what this is and only happens when it is moving.
My car is at the dealership now for this cricket sound when the fan is on speed 1-3. I'll report back when I pickup the car Monday.
Hi everyone,
We are glad you've reached out with this concerns. Anyone working with there dealers right now, we would like to be sure to assist further and get this documented within our systems. Please send us a private message with your VIN, phone number, current mileage and servicing dealer.
Julie
Alfa Romeo Social Care Specialist
 

·
Registered
Joined
·
68 Posts
Discussion Starter · #9 ·
My car is at the dealership now for this cricket sound when the fan is on speed 1-3. I'll report back when I pickup the car Monday.
Did they fix it? Any insight as to what the problem was? Thanks!

Sent from my Nexus 6P using Tapatalk
 
1 - 9 of 9 Posts
Top