Alfa Romeo Giulia Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
271 Posts
Discussion Starter · #1 ·
Hello does anyone here on this forum ever had their giulia replaced? What was the experience? Any info would be great to know
 

·
Registered
2018 Alfa Romeo Giulia TI Sport Q2
Joined
·
498 Posts
In the middle of it now......
 

·
Registered
Joined
·
5,027 Posts
I almost had it done until the QV was brought to a competent dealer for the fix.
My regional rep (Star Case Rep) set up the whole thing, you are going to be dealing with a 3rd party company (don't recall the name now) Once you have an agreement with Alfa for the buy-back. (in my case as the car was two months old full purchase price and sales tax as they could not get me another car in a reasonable time)
Whole process would take 10 days to 2 weeks from start to finish. I received a call from the 3rd party. They said they would come and pick up my car at my home.
Never got to that as the car was fixed and I have not had an issue since.
 

·
Registered
Joined
·
271 Posts
Discussion Starter · #6 ·
Lucky you!! this car cannot be fixed and all work stopped on this vehicle.
 

·
Registered
Joined
·
5,027 Posts
Lucky you!! this car cannot be fixed and all work stopped on this vehicle.
Sorry to hear!!...basically that was where I was at with the selling/servicing dealer. FIRST they tried to get me another car, none to be had would have to order one and wait and I was not going to do that again. So thats when they said we will buy the car back etc.
When I told my son, he suggested I go to another dealer (Ferrari/Maserati/Alfa) and they effected the fix as I mentioned.

So are you looking for a replacement car OR do you just want them to buy it back??
 

·
Registered
Joined
·
3,600 Posts
Serpente, I would second what MDriver has said and encourage you to contact Miller in CT. The Stamford/Westport shop?
 

·
Registered
Joined
·
271 Posts
Discussion Starter · #10 ·
This far beyond a mechanic fixing it. There were components included in this build that were told to me as being a “miss build” some sensors are not present some are and as a result certain features are not working properly
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top