Alfa Romeo Giulia Forum banner

121 - 133 of 133 Posts

·
Registered
Joined
·
197 Posts
Got my T57 update done today while in for 10K mile service. Only discernible difference is slightly smoother transition from off-throttle to on-throttle while underway. Not sure yet whether auto stop/start feature has been restored. Nonfunctional auto stop/start has been the one and only "defect" in my car, but I probably would turn it off anyway.
 

·
Registered
Joined
·
197 Posts
Got my T57 update done today while in for 10K mile service. Only discernible difference is slightly smoother transition from off-throttle to on-throttle while underway. Not sure yet whether auto stop/start feature has been restored. Nonfunctional auto stop/start has been the one and only "defect" in my car, but I probably would turn it off anyway.
Well, it appears auto stop/start still is not functional. Not sure if that's a bug or a feature.

I did notice one other change, which is the oil temperature gauge has been recalibrated to read 4 bars (half way) when the motor is warmed up where it never went above 3 bars before.
 

·
Super Moderator
Joined
·
2,991 Posts
Got my T57 update done today while in for 10K mile service. Only discernible difference is slightly smoother transition from off-throttle to on-throttle while underway. Not sure yet whether auto stop/start feature has been restored. Nonfunctional auto stop/start has been the one and only "defect" in my car, but I probably would turn it off anyway.
Well, it appears auto stop/start still is not functional. Not sure if that's a bug or a feature.

I did notice one other change, which is the oil temperature gauge has been recalibrated to read 4 bars (half way) when the motor is warmed up where it never went above 3 bars before.
It's an issue of some sort. The dealer installed a new battery and the T57 in our Ti at the same time. The auto start/stop hadn't worked for six months, now works all the time.
 

·
Registered
Joined
·
10 Posts
California Registration renewal and T57

Has anyone tried to renew their CA registration yet? I am being blocked from online and phone renewal...so I pulled my the car's dmv record. Says I need to show proof of T57 being complete before I can renew. T57 was completed a few months back.
 

·
Registered
Joined
·
241 Posts
Proof should show on the alfa app if you have it.
 

·
Registered
Joined
·
60 Posts
Just had the 1st year service completed on my Ti Sport. When I picked it up, the dealer informed me the T57 update was completed. I always drive in the D position (of DNA) and it seems now that the acceleration is even more responsive, and it seems to stay in gear a little longer before shifting up. I was experiencing a rough 1st-->2nd shift in the morning, and today I noticed it didn't happen. Could be coincidence, perhaps.
 

·
Registered
Joined
·
1,142 Posts
Just had the 1st year service completed on my Ti Sport. When I picked it up, the dealer informed me the T57 update was completed. I always drive in the D position (of DNA) and it seems now that the acceleration is even more responsive, and it seems to stay in gear a little longer before shifting up. I was experiencing a rough 1st-->2nd shift in the morning, and today I noticed it didn't happen. Could be coincidence, perhaps.
unfortunately, the T57 update did nothing to the jerkisness from 1st to 2nd.
 

·
Super Moderator
Joined
·
2,991 Posts
Just had the 1st year service completed on my Ti Sport. When I picked it up, the dealer informed me the T57 update was completed. I always drive in the D position (of DNA) and it seems now that the acceleration is even more responsive, and it seems to stay in gear a little longer before shifting up. I was experiencing a rough 1st-->2nd shift in the morning, and today I noticed it didn't happen. Could be coincidence, perhaps.
unfortunately, the T57 update did nothing to the jerkisness from 1st to 2nd.
Did you let the car warm up fully?
 

·
Registered
Joined
·
60 Posts
I can most certainly tell you the jerkiness is gone in my car. All three cold startups today yielded a smooth shift from 1st to 2nd. Same for yesterday. I am very routine and follow the same structure / routine each day. Also, driving in manual mode with paddle shifting, the shifts aren't as jerky/snappy as before.
 

·
Registered
Joined
·
60 Posts
Follow up to my previous comment,. the jerkiness is still there. Suppose it was a coincidence that the update was done and I didn't have the jerkiness, but it reared it's head again today!
 

·
Super Moderator
Joined
·
2,991 Posts
Yes I did for about 1-2 minutes.

The dealer said that the jerkiness is normal.

I have come to the conclusion just to accept it now.

Thanks
The jerkiness does seem to be normal. I've had different updates done since I bought my Ti (my wife's Ti) 1.5 years ago. Each update seems to smooth out the jerkiness. Once the car warms up, it smooths out. It takes more than two minutes to warm up and smooth out though. Perhaps five minutes of driving. I drive in Dynamic mode, but N or A is smoother when she's cold. I simply keep my foot out of it for a few blocks until she starts feeling smoother.

All cars are subject to this actually. Most have more, hmm, padding between the driver and the car and it's just hidden. This is one of the compromises that good performance cars have. Once she's warmed up and at speed, she's such a love in the canyons.
 
121 - 133 of 133 Posts
Top