Alfa Romeo Giulia Forum banner
1 - 20 of 62 Posts

·
Registered
Joined
·
83 Posts
Discussion Starter · #1 ·
So this started about 2 weeks ago where out of the 5 function buttons on the sunroof only one was working all of a sudden. The only button that works is the passenger side sunroof button that opens it completely, but you actually had to hold it down and wait for a second or two,and after an audible click, then let go and then hold it down completely to open the sunroof screen and the sunroof itself, it also seems it did not open the sunroof completely.
Dealer said they were aware when I dropped off this morning and I explained the issue. Will update once I pick up the car later tonight and receive the paperwork.
Link for video of issue.
https://1drv.ms/v/s!AmmAaHnWEvh2hKJSMhA-i_GwcxdIXw

Side Note: The dealer staff loved the car on the Eibach's, and seemed stoked that I had 5600 miles on the car and have been truly enjoying the car as it is meant to.
 

·
Registered
Joined
·
112 Posts
That's miserable. If the dealer is trying to fix - any thoughts on what may have caused it initially or was it totally random?
 

·
Registered
Joined
·
32 Posts
UPDATE

I just returned from the dealer not too long ago.
It was basically calibration issue and took literally 1 minute to fix.

In case it happens to your sunroof, just press and hold the passenger side sunroof button(mentioned by the OP) for 1 minute straight.
Shortly sunroof will go into crazy mode opening and closing back and forth.
Once it stops moving then the calibration is complete and everything should work fine again.

I just hope it doesn't keep happening again and again because it would be quite annoying even though it's a simple fix.
 

·
Registered
Joined
·
83 Posts
Discussion Starter · #6 ·
UPDATE

I just returned from the dealer not too long ago.
It was basically calibration issue and took literally 1 minute to fix.

In case it happens to your sunroof, just press and hold the passenger side sunroof button(mentioned by the OP) for 1 minute straight.
Shortly sunroof will go into crazy mode opening and closing back and forth.
Once it stops moving then the calibration is complete and everything should work fine again.

I just hope it doesn't keep happening again and again because it would be quite annoying even though it's a simple fix.
Thanks for that... I found the same info in the manual after the fact of course. Hopefully it is not a recurring issue.
 

·
Registered
Joined
·
56 Posts
Seems to me the this issue should have been identified and corrected at the dealership during PDI.

I'm always amazed by how much I each time I read the owners manual AGAIN and again.....

Paul
 

·
Registered
Joined
·
66 Posts
Not to resurrect an old thread... but I feel the need to vent and say the sunroof mechanism on the Giulia is... tooo tooo safe. It seems to malfunction quite easily. In my instance, yesterday I had the sunroof already opened to the utmost position slid back. I happened to press the vent button and I can hear the motor try to work then it stops then it started to behave all weird. I was able to close the sunroof, but was not able to open it. Only after reading the manual I found that there's something called the "pinch" feature. The sunroof somehow detected something was "obstructing" it from functioning correctly. If the sunroof ever gets into this state you have to reinitialize it. Not that big of a deal... but there's so much safety precaution on this thing that makes it frustrating at times
 

·
Registered
2020 Alfa Romeo Giulia Sport Ti AWD
Joined
·
7,383 Posts
My nightmare is that it will go berserk in the rain.
 

·
Registered
Joined
·
138 Posts
The same thing happened to me , I contacted the dealer and they had the problem fixed in 10 minuets, I didn't even finish my espresso, common problem, the tech didn't understand why they put three buttons to operate the sunroof?
 

·
Registered
2017 Vesuvio Grey Giulia Ti Q2
Joined
·
413 Posts
UPDATE

I just returned from the dealer not too long ago.
It was basically calibration issue and took literally 1 minute to fix.

In case it happens to your sunroof, just press and hold the passenger side sunroof button(mentioned by the OP) for 1 minute straight.
Shortly sunroof will go into crazy mode opening and closing back and forth.
Once it stops moving then the calibration is complete and everything should work fine again.

I just hope it doesn't keep happening again and again because it would be quite annoying even though it's a simple fix.
Thanks for this also! This is my second day of ownership and I had the same problem. Saved me a trip to the dealership .
 

·
Registered
Joined
·
5 Posts
Same issue with mine, sunroof using any of the 5 buttons refused to move. However, there was a click on the shut roof button (passenger side). That meant the fuse was OK. Since my manual is for a car without the sunroof or just an earlier version, no help there! Fortunately we have these forums as I've had the "Service Electronic Throttle/limp mode" issue also. In that case, since I'd read about it ahead of time in the car mags, I was carrying an OBDII to reset the codes (in the middle of no where, New Mexico). I need to get the three software updates to hopefully remedy that which the dealer says takes 3 hours and they couldn't do it at the time I was there for my first $170 oil change--I went 5000 miles not 10000 per the car maintenance program. Don't use adaptive cruise control in "d" or sport mode--I believe it will cause the throttle error.

I was able to "calibrate" the sunroof per the blog and an online copy of the manual. Not totally sure which button did it--meaning I believe I pushed the close roof button on the passenger side, get the click, and then release and push and hold same button. Question is--what little issue is next? And, do little issues mean bigger ones are on the way. If it wasn't such a wonderful car to drive (turbo lag excluded), this freshman level quality control would really be annoying. Dealer personnel are only coming up to speed, and that's being nice.
 

·
Registered
Joined
·
547 Posts
Same issue with mine, sunroof using any of the 5 buttons refused to move. However, there was a click on the shut roof button (passenger side). That meant the fuse was OK. Since my manual is for a car without the sunroof or just an earlier version, no help there! Fortunately we have these forums as I've had the "Service Electronic Throttle/limp mode" issue also. In that case, since I'd read about it ahead of time in the car mags, I was carrying an OBDII to reset the codes (in the middle of no where, New Mexico). I need to get the three software updates to hopefully remedy that which the dealer says takes 3 hours and they couldn't do it at the time I was there for my first $170 oil change--I went 5000 miles not 10000 per the car maintenance program. Don't use adaptive cruise control in "d" or sport mode--I believe it will cause the throttle error.

I was able to "calibrate" the sunroof per the blog and an online copy of the manual. Not totally sure which button did it--meaning I believe I pushed the close roof button on the passenger side, get the click, and then release and push and hold same button. Question is--what little issue is next? And, do little issues mean bigger ones are on the way. If it wasn't such a wonderful car to drive (turbo lag excluded), this freshman level quality control would really be annoying. Dealer personnel are only coming up to speed, and that's being nice.
Just asking why did you pay for the oil change? The first year's maintenance is included and paid for by Alfa. So they should not have charged you. Also here is a link for all the updated manuals (as you can see the owners manual is in it's 4th revision) and users guide that you can download for free, hope maybe this will help;

https://www.alfaromeousa.com/owners/owners-service-manual
 

·
Registered
2017 Ti Q2
Joined
·
213 Posts
I had this issue too. I opened the sunroof last week and today I couldn't. How and why it need calibration is a mystery to me. But the reset procedure did work so all is well now.
 

·
Registered
Joined
·
20 Posts
Anybody else got any insight on this?

I held the passenger side sunroof button down for 1 minute and didn't even budge. Just the clicking noise that it makes.
Curently the sunroof is in vent position and i'm trying to close but can't get it to calibrate.
Any other advice?
 

·
Registered
Joined
·
3,600 Posts
Disconnect negative terminal on battery and reconnect.
 

·
Registered
Joined
·
3,600 Posts
If it's any consolation, the micro switches on my 360 Spider top get freaky when they get hot. Sometimes the top won't go up right away, especially after a car show. If you put it back down and cycle it a few times it will work fine. Hydraulic fluid is fine, system is fine, motors are fine. It's just 13 years old and microelectronics, logic switches, and moving parts. Like when your computer locks up. Cntrl alt del or reboot. My Galaxy S5 Android phone choked on FB messenger AND Youtube at the same time today. Yeah it's old but we push electronics too hard all the time. Hopefully there is a good fix.
 

·
Registered
2017 Ti Q2
Joined
·
213 Posts
Did you follow the reset procedure as described in the manual? I printed a copy of it and placed it in the glove compartment.
 
1 - 20 of 62 Posts
Top