Alfa Romeo Giulia Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
189 Posts
Discussion Starter · #1 ·
Anyone else experienced really strong chemical smell coming from air vents into the interior ?
This was noticeable during the first few days and drives especially (with A/C and heater off) I can still smell it but very faintly now after 300 miles driving and 2 weeks. Tried to burn it off by running the heater and the A/C at different times and fan on high. Was not able to detect it in the engine bay.
 

·
Registered
Joined
·
189 Posts
Discussion Starter · #3 ·
After 300 miles and actually trying to burn it off, that's really weird. Have you spoken to the dealer perhaps?
It was only strong on first 30 miles or so, it seems gone now but not 100%, i guess i need to go see the dealer...
 

·
Registered
Joined
·
104 Posts
I also had a weird smell. Like leaves burning is the best way I can describe it.
I was concerned but all the instruments were fine and no "idiot light" came on at any time.
I have 4,000 miles and the smell has resolved.


My guess it was some pizza left on the engine from the factory workers in Italy...:smile2:
 

·
Registered
Joined
·
3,600 Posts
It may be a finish treatment on the heat shields and turbo. As you've run the car, it has burned off or broken it. That's the best way I could explain a burning leaves smell.
 

·
Registered
Joined
·
31 Posts
I have the same problem. I can't seem to discern whats causing the smell other then whenever I'm making any adjustments to the air sometimes a very strong chemical smell starts to come from the vents. I was in the dealership today to address a recall that the alfa tech said mentioned something about an odor, but it didn't resolve the problem. Sometimes the smell will occur if I'm driving then stop park, and come back to car, and turn on ac. It will emit a smell thats so strong I have to lower the windows almost immediately because you cannot breathe in the cabin.
 

·
Registered
Joined
·
372 Posts
I have the same problem. I can't seem to discern whats causing the smell other then whenever I'm making any adjustments to the air sometimes a very strong chemical smell starts to come from the vents. I was in the dealership today to address a recall that the alfa tech said mentioned something about an odor, but it didn't resolve the problem. Sometimes the smell will occur if I'm driving then stop park, and come back to car, and turn on ac. It will emit a smell thats so strong I have to lower the windows almost immediately because you cannot breathe in the cabin.
Yep, same problem here... I complained and the dealer sprayed some stuff into the vents - didn't help much. The only thing I can say is that it's only there when I'm using the AC. When it's not in use, there's no smell...
 

·
Registered
Joined
·
5,013 Posts
Nope..nuthin....10 months of ownership no bad smells...never have had any a/c issues as well and have been a a few road trips during the summer with the a/c blasting...
is this a model related issue?? or are Quadrifoglio owners experiencing this??
 

·
Registered
Joined
·
422 Posts
Our F-Pace smelled funky after driving for the first 3,000 miles or so. Dealer said the exhaust system was coated with something to minimize corrosion while being shipped over sea. It did smell bad, but not just in cabin. I could smell the car in garage when hot. All gone now.
 

·
Registered
2018 Q4 with Fiamenghi Ti exhaust, Race Mod, and Tecnico wheels.
Joined
·
7,671 Posts
Yep, same problem here... I complained and the dealer sprayed some stuff into the vents - didn't help much. The only thing I can say is that it's only there when I'm using the AC. When it's not in use, there's no smell...
Could the dealer have poured disinfectant into the A/C box as a pre-emptive move against mold? My pickup truck developed a mold problem when it was new so the dealer dumped disinfectant into the system. I had to run full heat with all of the windows down for a week after the disinfectant was put in. No more moldy smell, but 17 years later I still get whiffs of that disinfectant crap...

I guess it is too hard to remove the box and clean it properly, at least for my pickup. The entire dashboard has to be removed to do so.

The real fix on the pickup was to install a simple drain hose on the front of the A/C box. As-was the unit had an forward facing open drain pipe in the engine compartment and my guess is that wind was blowing in and splashing the drain water all over the inside of the box, preventing proper drainage and increasing the potential for mold growth. Hopefully Giulia is designed better.
 
1 - 11 of 11 Posts
Top