Alfa Romeo Giulia Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Twice it has ocurred. I deactivate the stop/start feature. I approach an intersection at around 25 mph and start braking but as I brake the motor self accelerates. I react by braking harder and for a moment the car continues to self accelerate in competition with my braking. Then the self accelaration ends.

I have been in both iccasions to the dealer. The first time the said the car needed a computer update. The did it and told me it was fixed. It happened again this week and I went back to dealer where the car is now. The head technitian and I went for a ride together and I explained what had occured. The ride when without a problem, but he would check the car. I hope he can find what is wrong because it was scary.

Has anyone had the same experience?
 

·
Registered
Joined
·
1,307 Posts
Absolutely not have I had this experience, this is an issue I have never heard of before ... This sounds all too familiar ... I would take it to another dealer to be honest with you!
 

·
Vendor
Joined
·
1,328 Posts
Twice it has ocurred. I deactivate the stop/start feature. I approach an intersection at around 25 mph and start braking but as I brake the motor self accelerates. I react by braking harder and for a moment the car continues to self accelerate in competition with my braking. Then the self accelaration ends.

I have been in both iccasions to the dealer. The first time the said the car needed a computer update. The did it and told me it was fixed. It happened again this week and I went back to dealer where the car is now. The head technitian and I went for a ride together and I explained what had occured. The ride when without a problem, but he would check the car. I hope he can find what is wrong because it was scary.

Has anyone had the same experience?
We certainly understand why this is stressful, Daliot. Keep us updated on what you hear from the dealership. We're available via direct message and would be happy to get this over to a Case Specialist to provide an additional layer of assistance.

Jasmine
Alfa Romeo Social Care Specialist
 

·
Registered
Joined
·
2 Posts
Twice it has ocurred. I deactivate the stop/start feature. I approach an intersection at around 25 mph and start braking but as I brake the motor self accelerates. I react by braking harder and for a moment the car continues to self accelerate in competition with my braking. Then the self accelaration ends.

I have been in both iccasions to the dealer. The first time the said the car needed a computer update. The did it and told me it was fixed. It happened again this week and I went back to dealer where the car is now. The head technitian and I went for a ride together and I explained what had occured. The ride when without a problem, but he would check the car. I hope he can find what is wrong because it was scary.

Has anyone had the same experience?
Hi, I’ve just received my Guilia Super back from the dealers having had software update and have experienced the same thing.
However my start/stop appears not to be functioning either. I’m going back to dealership tomorrow.
 
1 - 4 of 4 Posts
Top