Alfa Romeo Giulia Forum banner
1 - 20 of 33 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Had my QV in for service (bad amp) today and they performed the following four software updates...

RRT 17-070 - ECM and ECM2 and TCM

RRT 17-022 - Body Control Module

Reprogrammed CDCM module with new software update

Reprogrammed RFHB module with new software per service bulletin TSB #08-027-17
 

·
Registered
Joined
·
5,698 Posts
Had my QV in for service (bad amp) today and they performed the following four software updates...

RRT 17-070 - ECM and ECM2 and TCM

RRT 17-022 - Body Control Module

Reprogrammed CDCM module with new software update

Reprogrammed RFHB module with new software per service bulletin TSB #08-027-17
THANKS! I will be showing this to the Service Manager when my car goes up on Monday for service...much appreciated!
 

·
Super Moderator
Joined
·
1,091 Posts
Had my QV in for service (bad amp) today and they performed the following four software updates...

RRT 17-070 - ECM and ECM2 and TCM

RRT 17-022 - Body Control Module

Reprogrammed CDCM module with new software update

Reprogrammed RFHB module with new software per service bulletin TSB #08-027-17
Any noticeable driveabiltiy differences?
 

·
Registered
Joined
·
3,610 Posts
Remote start it sounds like. Either way, awesome! Thanks. :D
 

·
Registered
Joined
·
7 Posts
Are there any updates for poor throttle response or breaking at slow speeds? My car seems like it is going to stall when idling. Gives me an error to get throttle adjusted. Also, slow speeds is very touchy on breaks. Any news on updates? Thanks for the information. I will be bringing mine in this week!
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #12 · (Edited)
I've never had any issues with poor throttle response - apart from when driving in A - but that's to be expected.

Slow speed breaking is an issue I hope they will address with future software updates - it's not in these updates I got.
 

·
Registered
Joined
·
576 Posts
Are there any updates for poor throttle response or breaking at slow speeds? My car seems like it is going to stall when idling. Gives me an error to get throttle adjusted. Also, slow speeds is very touchy on breaks. Any news on updates? Thanks for the information. I will be bringing mine in this week!
I suspect that is normal. I believe there might be two things causing that sensation: decoupling driveshaft to reduce strain/increase gas mileage while at a stop, and possible cylinder deactivation. It feels like a slight misfire, but don't think it is.
 
  • Like
Reactions: John_K_348

·
Registered
Joined
·
3,610 Posts
Anyone do any laps in a parking lot to pin down these symptoms? I'm pretty sure the brake by wire issues will follow what I've found with throttle by wire. You have to "crack" the sensors open or work them a bit like rheostats and HAL sensors to get the voltage or resistance change you need for the ecu to see the movement. The software is digital and not analog so the jerkiness is equivalent to "clipping" or "aliasing" in the digital world. Like you have to cross the digital threshold for the ecu to apply the brakes. You have to learn this with your foot. Does this make any sense? Ferrari/Maserati throttle by wire needs a little more generous movement to get the f1 clutch to engage more aggressively and make a better launch. I think the same issue is happening with the brakes.
 
1 - 20 of 33 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top