Alfa Romeo Giulia Forum banner
1 - 20 of 27 Posts

·
Registered
Joined
·
196 Posts
Discussion Starter · #1 ·
When my QV is at idle on cold start or after the engine is warm, its like a heart beat skipping a beat almost. My shop pointed this out to me… Anybody have a similar experience?
 

·
Registered
Joined
·
656 Posts
Yeah, she's very lumpy on start up.

Cold like now, or normal balmy, she farts and seemingly mis- fires, but only for the 1st minute or so.

Once warm, she purrs on idle consistently 🐱.

All our Alfas have behaved this way so I wouldn't stress too much..(y)
 

·
Registered
Joined
·
1,051 Posts
A cold start on my QV is pretty "shaky" until I am out of my driveway. Not sure that is a "misfire" or just some sort of uneven fuel injection or offset crank journals, or whatever, but is just like a dragon clearing its throat upon awakening from a slumber. Just give your engine a few seconds to pump oil to where it needs to be, and then ease on out. NV
 

·
Registered
Joined
·
196 Posts
Discussion Starter · #7 ·
Take it to the dealer, If you still have warranty. Im knee deep into fixing mine, after having a Cylinder 3 misfire.
I actually just bought it from an Alfa Romeo dealer. I took it back and they had a tech do an inspection. Couldnt find anything… I should add that it is does this even after Ive had the engine running for awhile.
 

·
Registered
Joined
·
3,723 Posts
Perfectly normal. This 505hp beast engine is noisy, shaky, lumpy, feeling-like-misfiring-but-not, showing-false-P0303-error-codes all the time and all that interesting stuff. The technicians cannot find anything because there is nothing to find. Enjoy that Dream Car!
 

·
Registered
Joined
·
170 Posts
My 2.0t does this also, and I swear it reared its head after I had the 30k spark plugs swap... Doesn't seem to be an issue other than druing cold start.
 

·
Registered
Joined
·
196 Posts
Discussion Starter · #10 ·
Perfectly normal. This 505hp beast engine is noisy, shaky, lumpy, feeling-like-misfiring-but-not, showing-false-P0303-error-codes all the time and all that interesting stuff. The technicians cannot find anything because there is nothing to find. Enjoy that Dream Car!
Good to hear. My previous QV had P0303 all the time… Just clear em and move on!
 
  • Like
Reactions: Giuliano

·
Registered
Joined
·
50 Posts
Yeah, she's very lumpy on start up.

Cold like now, or normal balmy, she farts and seemingly mis- fires, but only for the 1st minute or so.

Once warm, she purrs on idle consistently 🐱.

All our Alfas have behaved this way so I wouldn't stress too much..(y)
My 2018 Q4 TI sport does the same thing and it got more noticeable when I put in an updated rear exhaust to give it a nicer sound do you have an ECU unit attached to it I noticed it seemed to become more noticeable with the ECU I put on the madness Pro I think it is it’s the higher end madness unit and that unit doesn’t turn on until after the car is warm so that could have something to do with it if you have something like that installed if you don’t it’s well worth the 600 bucks to put it in and you can put it in yourself if you’ve got enough coordination to put sugar in your coffee not that you would want to do that ……
 

·
Registered
Joined
·
290 Posts
When my QV is at idle on cold start or after the engine is warm, its like a heart beat skipping a beat almost. My shop pointed this out to me… Anybody have a similar experience?
Probably nothing to worry about:
 

·
Registered
Joined
·
656 Posts
My 2018 Q4 TI sport does the same thing and it got more noticeable when I put in an updated rear exhaust to give it a nicer sound do you have an ECU unit attached to it I noticed it seemed to become more noticeable with the ECU I put on the madness Pro I think it is it’s the higher end madness unit and that unit doesn’t turn on until after the car is warm so that could have something to do with it if you have something like that installed if you don’t it’s well worth the 600 bucks to put it in and you can put it in yourself if you’ve got enough coordination to put sugar in your coffee not that you would want to do that ……
My Giulia was a 200hp Super and was quite smooth on start up.

In April last year and now out of warranty, I had a piggyback chip installed, cat removed, and wider diameter custom exhaust fitted. Now twin on exit.

The entire characteristics of the car changed. 40% more hp and over 30% more torque. The sound is now wonderful and seemingly way more powerful. Very throaty and deep now. I won't say it's much quicker at top end, but acceleration is noticeably quicker.

A consequence of these mods, however, is the lumpy sounds on start up when cold. Reminds me of a slightly better behaved Funny car on a drag strip 🤣 . Love it...

In saying that, the missus's Giulietta Squadra Corse (280hp) is even more outrageously loud and lumpy on start up as well as when warm. Basically, it had the same treatment as my Giulia but bought new with conversion done by Alfa South Africa.
 
1 - 20 of 27 Posts
Top