Alfa Romeo Giulia Forum banner
1 - 5 of 5 Posts

·
Registered
2020 gulia
Joined
·
156 Posts
Discussion Starter · #1 · (Edited)
I've been trying to sign on to the site via my cell phone and a tablet it keeps telling me to put in my username and password however it doesn't accept it. keeps shutting me down say my information is incorrect it's not incorrect I know who I am! A few times now I can get in on the tablet sometimes not I'm trying to do a posting and that's not coming up either it is driving me crazy. Typical technology always screwing with us making it our fault instead of Technology fault. I'm trying to sign into my phone and it's telling me my sign information is incorrect. Really???
 

·
Registered
2020 gulia
Joined
·
156 Posts
Discussion Starter · #2 ·
Okay now it's telling me to sign in if I want to continue. Ok I am signed in both on my tablet and my phone. So I'm guessing this whole signing process is just as temperamental as the car
 

·
Registered
2020 gulia
Joined
·
156 Posts
Discussion Starter · #3 ·
Okay you all are making me crazy now you just blocked me because you said "someone" was trying to sign in too many times and send me a very nice email yeah I know I'm the one who was trying to sign in. Hope you enjoy reading the one I sent you back.
 

·
Registered
Joined
·
151 Posts
FWIW, I was unable to register due to the captcha not working in Firefox Quantum. I completed the registration using Chrome and otherwise the site seems to work ok in Firefox Quantum (much faster and smaller footprint than Chrome).
 

·
Registered
2020 gulia
Joined
·
156 Posts
Discussion Starter · #5 ·
Sign in issues again

OK I'll let it go this time cuz Mercury is in retrograde but I have to laugh now every time I try to sign in on my tablet even though my information is stored I have to remove my password and type it in again in order to sign in. Yet not from my cell.
 
1 - 5 of 5 Posts
Top