Alfa Romeo Giulia Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
263 Posts
Discussion Starter · #1 ·
2017 Giulia Ti. Just last week I got a new battery since the original battery was now 5 years old (this was at an exotic car garage and they work on Alfas).
I have never had a problem in 5 years of ownership. This Thursday (9 days after new battery install) I was driving and the big Service Electronic Throttle Control light came on. It defaulted to N, but I kept driving to my destination. When I restarted I had a check engine light. I drove to two more locations and then went home (check engine light again when each time I started the car).
I didn't drive Friday. Saturday morning, I had the same check engine light and drove to my destination. When I started the car to leave, all was normal again!! Should I just think of it as a fluke or should I take it in to have the garage look at it? Thanks.
 

·
Registered
Joined
·
4,044 Posts
There are, at least, two options when talking these sudden CELs for no apparent issue. For me, and again, it's just my own experience, the keys are: 1) the famous and showing all the time Service Electronic Throttle Control light and 2) the car performs perfectly, there car is normal, there is zero apparent consequences, everything is now OK. Under those two key assumptions, I conclude that it is just another electronic glitch, similar to the dozen of times that I have unplugged/plugged my PC and turned off/on my cell phone. Exactly the same. The other approach, which I respect and I have no problem at all, is: this is unacceptable, not normal, the CEL happens for a reason and the car must be brought immediately into the dealer for a complete evaluation, assessment and fix. On this other approach, please be aware that the majority (not all) of the dealers have no clue on what is going on with any CEL and that you will go throw a trial and error approach, changing parts (hopefully you are under warranty) for probably no reason and the CEL may show up again, as soon as you leave the dealer. But, you will be contributing to the technicians training processes and the reporting process, assuming that the dealer is reporting to corporate this stuff.
 

·
Administrator
2018 Giulia Ti Sport Q4
Joined
·
5,947 Posts
Had the serpentine belt been replaced? Of the belt is stretched you will get cel errors.

picture of my belt showing that the arrow is outside of the mark.
One thing to also do is check the idler and tensioner pulleys for noise/play when you remove the belt. O'reilly's Auto has Gates replacement pullies, and they are the same part for idler and tensioner, but obviously the tensioner part has more to it, but same pulley. So even if they say it's a different part, you can get two of them.
 

·
Registered
Joined
·
263 Posts
Discussion Starter · #6 ·
Update:
A week after this issue, the Service Electronic Throttle came back, mode defaulted to N, then my Coolant Temp Warning light came on. Temp was rising; it got as high as 3/4 on the gauge. Check engine light came on. I proceeded home immediately, parked it, and made an appointment (first available was four days later). I did not drive it until I started it to drive to the garage. No lights at all! They kept it all day, said there were no codes stored, and could not reproduce the issue.

Two weeks later, this past Thursday, same sequence of events. Service Electronic Throttle, Temp Coolant Warning, CEL. But this time it went into limp mode. I couldn't drive above 24 MPH. Luckily I was in a small town on uncrowded roads. Made it to my destination and called for a tow. They weren't able to look at it on Friday, so I await the diagnosis. Anyone have this experience? I'm thinking thermostat but I have no idea.

As an aside, limp mode is really dangerous. What if you were on the side of the highway, limp mode kicked in, you have no idea, and you try to accelerate on to the highway? Terrible design, there should be a light for that (other than CEL).
 

·
Registered
Joined
·
263 Posts
Discussion Starter · #7 ·
Engine coolant flow control valve was stuck closed. They say it's fixed and it did not repeat. Since it's already happened at least twice, maybe three times, I'm asking for an estimate on how much to replace that part.
 
1 - 7 of 7 Posts
Top