Alfa Romeo Giulia Forum banner
1 - 20 of 25 Posts

·
Registered
Joined
·
1,506 Posts
Discussion Starter · #1 ·
Had some heavy rain yesterday that i drove in. When I got in the car today a warning came up saying right side daytime running light out along with the turn signal. The whole unit had a lot of moisture in it. Went to Alfa and they opened up a case and are ordering a replacement unit.
 

·
Registered
Joined
·
271 Posts
Thankfully it’s covered

Had some heavy rain yesterday that i drove in. When I got in the car today a warning came up saying right side daytime running light out along with the turn signal. The whole unit had a lot of moisture in it. Went to Alfa and they opened up a case and are ordering a replacement unit.
 

·
Registered
Joined
·
76 Posts
This exact same thing happened to me, did you find out what the actual fault was? I will probably have to fix mine on my own so they don't see my modifications
Please lmk if you have any info at all
 

·
Registered
Joined
·
4 Posts
Just came across this thread. I have the same problem which happened after driving through a very intense thunder storm. Did anyone have any luck in taking apart the assembly and drying it out?

Cheers
--Neil
2018 Giulia Lusso
 

·
Banned
Joined
·
219 Posts
Not related. But, my wife had a Cadillac SRX that had a turn signal burn out. Looked up the bulb in the book and went to the auto parts and picked up a new bulb for a few bucks. After three hours of trying to figure out how to get to the bulb. I went online. Caddy said the whole front fascia had to be removed and it was $500US to change a stinking turn signal. When, owners balked at this. They said, "it was to deter theft"! Yeah right, there is a huge black market for stolen turn signal bulbs. Found an independent mechanic. But, it was still $175US. At least, Alfa is doing something for you.
 
  • Like
Reactions: RyanC883

·
Registered
Joined
·
6 Posts
Guila ti sport 1 week old. I got error message saying parking light is out.
Checked headlight and it has condensation inside lens, just a matter of time before the headlight burns out.
 

·
Registered
Joined
·
2,988 Posts
Guila ti sport 1 week old. I got error message saying parking light is out.
Checked headlight and it has condensation inside lens, just a matter of time before the headlight burns out.
Have you considered going back to your dealer so they can fix the problem?
 

·
Registered
'20 Ti-Sport Carbon Q4 Rosso Comp
Joined
·
625 Posts
guess i wasn't the only one with the issue.
I posted it on general section with 'parking light out' message.
at first it was just the message, then right side turn signal doesn't work. cornering light doesn't work
then right side mirror housing is flickering and is dimmer than the left side.
few hours pass by, says my rear camera is unavailable + rear parking sensors not working.
few more hours pass by, rear sensor + camera is back but still no DRL/turn signal in headlight.
the car is barely 2 weeks old now.

waiting impatiently for tomorrow to talk to dealer to get the car towed and get a loaner
 

·
Registered
'20 Ti-Sport Carbon Q4 Rosso Comp
Joined
·
625 Posts
Yeah I'm bringing it in Wednesday for them to look and order new parts

Sent from my SM-G950U1 using Tapatalk
i'm also booked for wednesday for drop off to get a loaner.
won't know how long it's going to take tho
 

·
Registered
'20 Ti-Sport Carbon Q4 Rosso Comp
Joined
·
625 Posts
Service manager on phone told me moisture inside headlights is common.
I told him no way. It's two weeks old

Sent from my SM-G950U1 using Tapatalk
are you only having issue with headlight?
i'm having multiple issues
'Parking Light Out'
'Daytime Running Light Out'
'Turn Signal Light Out'
'Rear Camera unavailable' while in reverse, comes on & off
Rear parking sensors function intermittently only inner 2. outer 2 do not work at all.
passenger side mirror housing turn signal is dimmer than left & flickers.
cornering light functions intermittently as well.

my car is also now 2 weeks old.
 

·
Registered
Joined
·
6 Posts
are you only having issue with headlight?
i'm having multiple issues
'Parking Light Out'
'Daytime Running Light Out'
'Turn Signal Light Out'
'Rear Camera unavailable' while in reverse, comes on & off
Rear parking sensors function intermittently only inner 2. outer 2 do not work at all.
passenger side mirror housing turn signal is dimmer than left & flickers.
cornering light functions intermittently as well.

my car is also now 2 weeks old.
To be honest i leased the car for my daughter who wont have her license for another month, so the car just sits in driveway for now. The only other complaint other than light out is that in stop and go around town, the car is not very smooth, tranny seems to jump. On highway great.

Sent from my SM-G950U1 using Tapatalk
 

·
Registered
'20 Ti-Sport Carbon Q4 Rosso Comp
Joined
·
625 Posts
To be honest i leased the car for my daughter who wont have her license for another month, so the car just sits in driveway for now. The only other complaint other than light out is that in stop and go around town, the car is not very smooth, tranny seems to jump. On highway great.

Sent from my SM-G950U1 using Tapatalk
oh wow.
i need to get my girl away from boards like this so she doesn't demand Giulia when she gets her license.

first thing i do when i get in is disable stop/start. tranny takes few min to warm up but after than no big issue.
hard to do stop & go traffic tho, better in manual mode in that situation.

thought something was wrong w/ car when car made thumping sound when turning with steering wheel at max lock.
it's normal and called 'alfa-link' that gives unique suspension setting for the handling.
 

·
Registered
Joined
·
6 Posts
oh wow.
i need to get my girl away from boards like this so she doesn't demand Giulia when she gets her license.

first thing i do when i get in is disable stop/start. tranny takes few min to warm up but after than no big issue.
hard to do stop & go traffic tho, better in manual mode in that situation.

thought something was wrong w/ car when car made thumping sound when turning with steering wheel at max lock.
it's normal and called 'alfa-link' that gives unique suspension setting for the handling.
Its crazy that your having so many problems with a new car. Let alone 2 weeks. I,m wondering if there service techs are even capable of fixing these problems. Prior to the guila i was leasing c300 benz,s for last 7 years and i never had any issues whatsoever with them, the only reason i switched was because the lease went way up from the last time. Guila is great looking and nobody in my area even has one, but i,m starting to think i made a mistake when i read all these problems others are having


Sent from my SM-G950U1 using Tapatalk
 

·
Registered
'20 Ti-Sport Carbon Q4 Rosso Comp
Joined
·
625 Posts
Its crazy that your having so many problems with a new car. Let alone 2 weeks. I,m wondering if there service techs are even capable of fixing these problems. Prior to the guila i was leasing c300 benz,s for last 7 years and i never had any issues whatsoever with them, the only reason i switched was because the lease went way up from the last time. Guila is great looking and nobody in my area even has one, but i,m starting to think i made a mistake when i read all these problems others are having


Sent from my SM-G950U1 using Tapatalk
the car is blast to drive, like you said, very few on road. gets good amount of attention.
it's great looking car.
i parked next to brand new A4 as comparison shot. no comparison.

I'm hoping that it would be easy fix with body control module & headlight fix but we'll see.
i'm just happy that this is lease and not a purchase. would be devastated if i had to live with these problems year after year.

this happened after driving thru heavy rain. this car does not like rain i guess as others that are reporting right side light issue went thru rain.
also, hold yourself from going to automatic car wash as i heard it will f**k up your parking sensors & radar cruise control.
 

·
Registered
Joined
·
2,988 Posts
Service manager on phone told me moisture inside headlights is common.
I told him no way. It's two weeks old
I certainly hope it's not a common thing. If it is, AR will need to redesign the headlamp or something and issue either a wide recall, or knowing how AR works, wait for each individual to complain about moisture then replace things.

We haven't experienced this, yet. We've driven in some horrendous downpours. But I always wash the car myself without high pressure. Hopefully, only a very small percentage will experience this.


To be honest i leased the car for my daughter who wont have her license for another month, so the car just sits in driveway for now. The only other complaint other than light out is that in stop and go around town, the car is not very smooth, tranny seems to jump. On highway great.
The jerking sensation goes away rather quickly when the transmission and/or engine start to warm up. AR has issued several TSBs addressing this. It's not perfected yet though. One solution is to go to your dealer and complain, they might be able to update the software in the TCM. The other option is to drive in N or A mode the first few blocks until things warm up. I never do though, I drive in D mode and try to be easy on the throttle until she warms up.
 

·
Registered
Joined
·
2,988 Posts
Its crazy that your having so many problems with a new car. Let alone 2 weeks. I,m wondering if there service techs are even capable of fixing these problems. Prior to the guila i was leasing c300 benz,s for last 7 years and i never had any issues whatsoever with them, the only reason i switched was because the lease went way up from the last time. Guila is great looking and nobody in my area even has one, but i,m starting to think i made a mistake when i read all these problems others are having
The complaints are being exaggerated. Most of the complaints are based around the 2017 which is the first run of an all new design and build. Regardless of manufacturer, there will always be teething issues on the first run.

There are some who go out of their way to ruin Alfa Romeo by posting erroneous reports. It near impossible to spot the actual car owner with a legitimate issue or a troll with false claims. The only possible tell-tail is the total amount of posts from that user. If they created a log-in and car complaint at the same time, they possibly could be a troll. But that's not a guarantee. If they never come back for a follow up report, that sort of confirms the troll assumption, but still no guarantee.

The reality is that there are plenty more Giulia owners without issues than with issues. I'm one of them. We've owned our 2017 Giulia about 1.5 years now and have 15,000 miles. 10,000 of that we put on in the first four months. The only issues we've had was a failed battery, twice, and that didn't happen until after the car was one year old.

You might skim through this thread -> https://www.giuliaforums.com/forum/289-alfa-romeo-giulia-general-discussion/34778-anyone-not-having-problems.html
 

·
Registered
Joined
·
6 Posts
The complaints are being exaggerated. Most of the complaints are based around the 2017 which is the first run of an all new design and build. Regardless of manufacturer, there will always be teething issues on the first run.

There are some who go out of their way to ruin Alfa Romeo by posting erroneous reports. It near impossible to spot the actual car owner with a legitimate issue or a troll with false claims. The only possible tell-tail is the total amount of posts from that user. If they created a log-in and car complaint at the same time, they possibly could be a troll. But that's not a guarantee. If they never come back for a follow up report, that sort of confirms the troll assumption, but still no guarantee.

The reality is that there are plenty more Giulia owners without issues than with issues. I'm one of them. We've owned our 2017 Giulia about 1.5 years now and have 15,000 miles. 10,000 of that we put on in the first four months. The only issues we've had was a failed battery, twice, and that didn't happen until after the car was one year old.

You might skim through this thread -> https://www.giuliaforums.com/forum/...cussion/34778-anyone-not-having-problems.html
Good to know
Thank you for info.


Sent from my SM-G950U1 using Tapatalk
 

·
Registered
'20 Ti-Sport Carbon Q4 Rosso Comp
Joined
·
625 Posts
forgot to post comparison shot i took
here


RE-11s are on the car which makes even more fun to drive
 
1 - 20 of 25 Posts
Top