Alfa Romeo Giulia Forum banner
1 - 20 of 36 Posts

·
Registered
Joined
·
76 Posts
Discussion Starter · #1 ·
RESOLVED:
Squeak is gone.
brought in the car to another dealership and they were already aware of the issue.
Replaced Rubber shaft seal on the firewall.
Allthough it sounds that the noise comes from the clockspring, it is not the case.
Part number replaced:
68311654AA
 

·
Registered
Joined
·
256 Posts
This has been driving me INSANE!!! How long did the repair take?
 

·
Registered
Joined
·
76 Posts
Discussion Starter · #4 ·
about 3 hours.
I drove in the car at 11am and they called me at 2:30pm, car was ready.
They also performed updated/reprogrammed 3 modules within that appointment:
shifter (slow response when shifting from R to D).
HVAC, (inconsistant température and fogging windows during winter).
Remote module (remote starter intermittent malfunction).

Needless to say; they also washed the car!
 

·
Registered
Joined
·
256 Posts
about 3 hours.
I drove in the car at 11am and they called me at 2:30pm, car was ready.
They also performed updated/reprogrammed 3 modules within that appointment:
shifter (slow response when shifting from R to D).
HVAC, (inconsistant température and jogging windows during winter).
Remote module (remote starter intermittent malfunction).

Needless to say, they also washed the car!
Thanks for the info! Did they already have the part in or did they have to order it before hand?

How did they know to do the updates? I’m also experiencing these exact issues.. seems I have to run my defrost constantly or the inside immediately fogs up.
 

·
Registered
Joined
·
76 Posts
Discussion Starter · #6 · (Edited)
They ordered the part, it took a week to get it from the national parts distribution (USA) -I'm in Quebec, Canada.
The tech was really knowledgeable and was aware of the issues, he diagnosed the shift delay when he drove the car into the shop.
I brought the fogging and remote start issues to his attention.
 

·
Registered
Joined
·
1,576 Posts
I guess it is sound to assume that changing that shaft seal is a minor work since they did all that stuff plus washing in 3 hours, probably van be replaced without any major disassembly
 

·
Registered
Joined
·
79 Posts
I wonder if the new seal is a new or revised part number. Otherwise one might expect it to have the same problem sooner or later.

I’ll be bringing it up with my dealer soon.
 

·
Super Moderator
Joined
·
1,086 Posts
Many thanks for the feedback on this!
 

·
Registered
Joined
·
76 Posts
Discussion Starter · #11 ·
my car had the sterling squeak since the first day with 21km (13mi) on the odomètere.
Yesterday the part was replaced and I didn't hear a squeak, I drove 60km today.
Maybe it was a bad batch in early production cars or even improper installation, perhaps by the same technician on the production line....who knows....
 

·
Registered
Joined
·
256 Posts
They ordered the part, it took a week to get it from the national parts distribution (USA) -I'm in Quebec, Canada.
The tech was really knowledgeable and was aware of the issues, he diagnosed the shift delay when he drove the car into the shop.
I brought the fogging and remote start issues to his attention.
Sorry to bug you again. I’ve called my dealership and they don’t seem to know what I’m talking about in regards to the HVAC issues. Do you happen to have the print out after your appointment? Hoping to give my dealership more info and am thinking maybe your paperwork can explain it to them.
 

·
Registered
Joined
·
103 Posts
RESOLVED:
Squeak is gone.
brought in the car to another dealership and they were already aware of the issue.
Replaced Rubber shaft seal on the firewall.
Allthough it sounds that the noise comes from the clockspring, it is not the case.
Part number replaced:
68311654AA
Good to know. I just asked my dealer to fix it and they said they were aware but did not have a fix.
 

·
Registered
Joined
·
76 Posts
Discussion Starter · #14 ·
Sorry to bug you again. I’ve called my dealership and they don’t seem to know what I’m talking about in regards to the HVAC issues. Do you happen to have the print out after your appointment? Hoping to give my dealership more info and am thinking maybe your paperwork can explain it to them.
Alfa1: sorry for the delays, The only thing on the printout is HVAC software update, nothing more specific.
 

·
Vendor
Joined
·
1,337 Posts
Good to know. I just asked my dealer to fix it and they said they were aware but did not have a fix.
Hi WheelHaus,
We regret to hear that your dealer was unable to assist you with this. Please feel free to send us a private message with your VIN so that we can look into this further for you.
Julie
Alfa Romeo Social Care Specialist
 

·
Registered
Joined
·
6 Posts
Was this covered under warranty? Because the shop gave me a quote and they cannot guarantee if this will be a warranty coverage since I am the first one to call about it.
 

·
Registered
Joined
·
76 Posts
Discussion Starter · #19 · (Edited)
Sorry to bug you again. I’ve called my dealership and they don’t seem to know what I’m talking about in regards to the HVAC issues. Do you happen to have the print out after your appointment? Hoping to give my dealership more info and am thinking maybe your paperwork can explain it to them.
Alfa1: here is the revision you need to do, if not already done....
24-002-18
Cheers!
 

·
Registered
Joined
·
91 Posts
RESOLVED:
Squeak is gone.
brought in the car to another dealership and they were already aware of the issue.
Replaced Rubber shaft seal on the firewall.
Allthough it sounds that the noise comes from the clockspring, it is not the case.
Part number replaced:
68311654AA

@appolon

I have a similar issue. My dealer in the Netherlands isn't aware of this issue, and a search of the part number doesn't turn up any results. They did say that the part number looked like a US one, and that their search database was a worldwide one.

Thoughts?

-krish
 
1 - 20 of 36 Posts
Top