Alfa Romeo Giulia Forum banner

101 - 117 of 117 Posts

·
Registered
Joined
·
2,347 Posts
So, maybe it's me... but I can't be the only one...
first I’ve seen....maybe just predestined to have crappy experiences with this car? Sorry the experience has not been better.
 

·
Registered
Joined
·
284 Posts
So far it has been fine. Minor speed bump.
Their support was willing to answer emails after hours, but to me some of the processes aren’t clear and there are a few IT issues that need to be fixed.

but water under the bridge now, tomorrow I can actually try the product. :)
 

·
Registered
Joined
·
284 Posts
So first drive with it, I started with Sport mode. In D mode, I actually broke the tires loose just making a right rolling turn, so I toned it down a bit.
It definitely is more linear and there's less lag, but it's still there, I can feel it mostly with a rolling start at about 10 mph and then going to say 40MPH.
 

·
Registered
Joined
·
687 Posts
Lag is the intrinsic nature of any turbo engine. Hoping that adding a device to the gas pedal will remove the initial lag is just silly. Marketing such device is dishonest and possibly criminal.
 

·
Super Moderator
Joined
·
2,205 Posts
Lag is the intrinsic nature of any turbo engine. Hoping that adding a device to the gas pedal will remove the initial lag is just silly. Marketing such device is dishonest and possibly criminal.
It's not turbo lag that is the target of the product. Some people have a real lag in the throttle input that can be minimized by using a device like this. It's not criminal.
 

·
Registered
Joined
·
284 Posts
I get the point of it, they're just over-compensating the throttle mapping to push the engine harder during periods when lag is expected producing a more linear response. In theory, a well trained human can do the same thing, but it's obviously not second nature to most of us.

I can say that the feeling of lag is removed a bit coming from a NA E90 M3, whereas previously it was pretty noticable. It's not gone, and I think others have mentioned this too. Nothing new there.

I was a bit disappointed in how much trouble I had getting it setup with BT. Lots of IT issues and nonsensical error messages, hopefully they can fix that stuff to make it smoother for others. I really doubt, in that list of issues, I am the only one would get a bit stuck on some of those.
 

·
Registered
Joined
·
1,317 Posts
Lag is the intrinsic nature of any turbo engine. Hoping that adding a device to the gas pedal will remove the initial lag is just silly. Marketing such device is dishonest and possibly criminal.
We have covered this many times. There is an artificial lag on the pedal introduced by the electronics, and you can test that easily by verifying how quickly the engine reacts to a small tap of the accelerator in A, N and D mode. A reacts in over half second, D manual in much less.
That said, this mod does not eliminate that "electronics lag" at all, but just reduces it by tricking the system in thinking the pedal is more depressed than it is.
 

·
Vendor
Joined
·
931 Posts
Discussion Starter #108
So far it has been fine. Minor speed bump.
Their support was willing to answer emails after hours, but to me some of the processes aren’t clear and there are a few IT issues that need to be fixed.

but water under the bridge now, tomorrow I can actually try the product. :)
mikoz,

Glad you were able to get everything working!

We were unfortunately closed during your initial e-mail communication and this post being replied to, however, I believe one of our team members did their best to assist during off hours.

To recap on your concerns:

1. website does not work with firefox: cannot login... chrome does work

Our IT Department will be replying to your e-mail one more time to figure out exactly what login you are referring to.

2. apparently your login on the website is NOT the same login as the app.
3. trying to use my website login on your app produces an error which makes no sense, it reports "failed for other reasons". Apparently you have to make a NEW login just for this. This was not at all obvious to me.
4. trying to reset my password from the app causes an error

You are correct.

We try to clearly list this in our instructions on the description.

Registering / logging in to your account:
With the new MADNESS GOPedal, you will be required to register an account. This allows us to send you remote updates directly to your GOPedal if needed and allows for a more detailed report if you experience any issues with your GOPedal.

Registering:
You will be greeted with a prompt to login or register an account when you open the MADNESS GOPedal App.
If you are registering a new account, click the "Register" button on the app. You will be sent a confirmation e-mail. Please confirm your account prior to continuing the pairing process.
Once your e-mail is confirmed, open the GOPedal App again and you will be able to login.

Logging in:
When opening the GOPedal App, you will be able to click the "Login" button.
Enter your e-mail address and password to login.
We will work with our team here to see how we can make that a bit clearer.



5. trying to submit a web inquiry does not work, email does

We did receive your e-mail inquiry from our website. We will work with our IT Department to see how we can make sure you receive proper confirmation that your e-mail went through.

6. the webpage discusses two completely different apps and products on the SAME page, it's unclear which is to be used (there's a GoPedal and GoPedal Plus app and BOTH are discussed on the same webpage in the details of the product I purchased).

We will review the descriptions and double check this for you to make it a little more clear. We are phasing out the GOPedal Plus so this will not be an issue moving forward.

7. the PIN code shipped with the piece of paper in the box is not correct

We apologize if the PIN code was incorrect on the piece of paper. Perhaps our shipping department sent the wrong paper with your order. We will make sure that our team double checks this moving forward so this is not an issue.
 

·
Registered
Joined
·
284 Posts
mikoz,

Glad you were able to get everything working!

We were unfortunately closed during your initial e-mail communication and this post being replied to, however, I believe one of our team members did their best to assist during off hours.

To recap on your concerns:

1. website does not work with firefox: cannot login... chrome does work

Our IT Department will be replying to your e-mail one more time to figure out exactly what login you are referring to.

2. apparently your login on the website is NOT the same login as the app.
3. trying to use my website login on your app produces an error which makes no sense, it reports "failed for other reasons". Apparently you have to make a NEW login just for this. This was not at all obvious to me.
4. trying to reset my password from the app causes an error

You are correct.

We try to clearly list this in our instructions on the description.



We will work with our team here to see how we can make that a bit clearer.



5. trying to submit a web inquiry does not work, email does

We did receive your e-mail inquiry from our website. We will work with our IT Department to see how we can make sure you receive proper confirmation that your e-mail went through.

6. the webpage discusses two completely different apps and products on the SAME page, it's unclear which is to be used (there's a GoPedal and GoPedal Plus app and BOTH are discussed on the same webpage in the details of the product I purchased).

We will review the descriptions and double check this for you to make it a little more clear. We are phasing out the GOPedal Plus so this will not be an issue moving forward.

7. the PIN code shipped with the piece of paper in the box is not correct

We apologize if the PIN code was incorrect on the piece of paper. Perhaps our shipping department sent the wrong paper with your order. We will make sure that our team double checks this moving forward so this is not an issue.

Yes, I appreciated the after-hour email reply.

Some replies below:
1. goto MADNESS Autoworks - MADNESS Autoworks - Auto Parts and Accessories using Firefox/Win10, click login, enter your password. You do not show up as logged in. Repeat with Chrmoe... works

2. It wasn't obvious to me that the password required for the gopedal is different than the password i use on the website. Maybe it is to others, but even reading your text it's still not obvious.. to me. Even if that were the case, the app throws weird and non helpful error messages that don't help the situation.



In addition, I found anpother issue:
+ My previous order is not showing up in the orders list, once logged in via Chrmoe.
 

·
Vendor
Joined
·
931 Posts
Discussion Starter #110
Yes, I appreciated the after-hour email reply.

Some replies below:
1. goto MADNESS Autoworks - MADNESS Autoworks - Auto Parts and Accessories using Firefox/Win10, click login, enter your password. You do not show up as logged in. Repeat with Chrmoe... works

2. It wasn't obvious to me that the password required for the gopedal is different than the password i use on the website. Maybe it is to others, but even reading your text it's still not obvious.. to me. Even if that were the case, the app throws weird and non helpful error messages that don't help the situation.



In addition, I found anpother issue:
+ My previous order is not showing up in the orders list, once logged in via Chrmoe.

Hi Mike,

Thank you for that information. We will look into it.


Regarding your previous order, it appears that when you placed your initial order, you were not logged in so your order is not linked to your profile.

I have manually linked your order to your account. You should be able to access it through your account now!

Please let me know if you have any other questions! :)
 

·
Registered
Joined
·
284 Posts
Hi Mike,

Thank you for that information. We will look into it.


Regarding your previous order, it appears that when you placed your initial order, you were not logged in so your order is not linked to your profile.

I have manually linked your order to your account. You should be able to access it through your account now!

Please let me know if you have any other questions! :)

well, I thought I was logged in... see problem #1 :)
I didn't discover that it doesn't actually log in you with firefox until yesterday.
 

·
Registered
Joined
·
284 Posts
Did another drive and I can say, without a doubt, that it enhances the experience overall, for me. I drove with D and N modes with the unit set in Sport with 1 tick down. Obviously, it's not causing the car to make more power, it just makes the experience more linear, more reactive, and fun. In R mode, for me, around town (with some fun highway ramps) I found that I liked the car better with the unit Off. Even going down 2 ticks of Sport mode with R mode (around town) it felt too artificial to me. Obviously, as has been discussed, R is the best experience for so many reasons (even braking around town is smoother) but I won't be driving in R around town very often, so this is a good solution for me at this time. I won't have the chance to try the pedal with R mode in a spirited situation for some time, maybe I'll give it another shot then.
 

·
Vendor
Joined
·
931 Posts
Discussion Starter #113
well, I thought I was logged in... see problem #1 :)
I didn't discover that it doesn't actually log in you with firefox until yesterday.
Mike,

I just paired up with our IT Department, we went through with Chrome, Firefox and Safari and we were able to successfully log in through the header.

We went through the process on both macOS and Windows.



They have advised to attempt to clear your cache and cookies on Firefox as perhaps there is something cached in the system that is not allowing you to login properly.

Here is an article on how to clear your cache on Firefox: How to clear the Firefox cache | Firefox Help

Please let us know if that works for you!
 

·
Registered
Joined
·
284 Posts
Same exact procedure on same laptop using same browser works today. I didn't even shut down the browser or clear anything.
 

·
Registered
Joined
·
74 Posts
Late to the party...but couldn't be happier with Madness GOPedal!!!!!

Just had exhaust valve control module and GOPedal installed yesterday at Madness Autoworks.

Verdict: Now this is what OEM QV should sound and feel like directly from the factory.

Exhaust Valve Control: Car sounded good from the beginning none the less but with the valve control I now have the ability to make it always sound awesome in all driving modes.

GOPedal: This is the game changer. In Sport +2 setting on GOPedal (with drive-mode selector in N) car feels like it's in Dynamic mode prior to GOPedal. But most of all, that horrible lag at throttle tip-in is now GONE. I briefly tried Sport +2 (with DNA in D) and car is now a beast to drive. I'm not ashamed to admit that I'm just too chicken to put the DNA selector in Race just yet....because that's how strong and quick the car responds to throttle input now. I can't imagine how the car would be like in Race +3 and with DNA also in Race!

With this GOPedal I feel this is how the QV should be in the first place and finally deserving the Alfa Romeo name and clover-leaf badge.

Thank you Madness Autoworks for having a such wonderful product that allows me to enjoy my QV the way it should be experienced in the first place.
 

·
Vendor
Joined
·
931 Posts
Discussion Starter #116
Late to the party...but couldn't be happier with Madness GOPedal!!!!!

Just had exhaust valve control module and GOPedal installed yesterday at Madness Autoworks.

Verdict: Now this is what OEM QV should sound and feel like directly from the factory.

Exhaust Valve Control: Car sounded good from the beginning none the less but with the valve control I now have the ability to make it always sound awesome in all driving modes.

GOPedal: This is the game changer. In Sport +2 setting on GOPedal (with drive-mode selector in N) car feels like it's in Dynamic mode prior to GOPedal. But most of all, that horrible lag at throttle tip-in is now GONE. I briefly tried Sport +2 (with DNA in D) and car is now a beast to drive. I'm not ashamed to admit that I'm just too chicken to put the DNA selector in Race just yet....because that's how strong and quick the car responds to throttle input now. I can't imagine how the car would be like in Race +3 and with DNA also in Race!

With this GOPedal I feel this is how the QV should be in the first place and finally deserving the Alfa Romeo name and clover-leaf badge.

Thank you Madness Autoworks for having a such wonderful product that allows me to enjoy my QV the way it should be experienced in the first place.
PK_GiulaQuad,

Thank you for the feedback.

We're always happy to hear our supporters and enjoying their GOPedals!
 

·
Vendor
Joined
·
931 Posts
Discussion Starter #117
The GOPedal puts the control in your hands! With four different modes and 8 settings, there is an adjustment to suit your needs.

The newly updated MADNESS GOPedal is designed to reduce initial lag felt in todays drive by wire vehicles by allowing you to advance your throttle’s timing to give you a more direct response for a much-improved feel.

Thousands of satisfied Alfa Owners from all over the world have purchased and use the MADNESS GOPedal! Try it out our newest version and find out why this is one of the best selling and best-reviewed products available for the Alfa Romeo Giulia.





To find the MADNESS GOPedal that is a perfect fit for your Alfa Romeo Giulia please visit the link below:
Search - giulia gopedal - MADNESS Autoworks - Auto Parts and Accessories
 
101 - 117 of 117 Posts
Top