Alfa Romeo Giulia Forum banner
1 - 20 of 22 Posts

·
Registered
Joined
·
271 Posts
Discussion Starter · #1 ·
I do not know what the situation is with this car but during my lunch break I figured I tried to redline the car. The car wouldn't do it. N Mode or A Mode the car doesn't run up to spec. Next week I have a visit to the dealer because I have been having some issues with acceleration stumbling, I was reading on the forum here that some had problems with injectors. If an injector is faulty, will it throw a code? Because right now I do not have any CEL.
 

·
Registered
Joined
·
1,507 Posts
I had no trouble red lining mine. I can't believe you are having so much trouble. Hope it all works out.
 

·
Registered
Joined
·
271 Posts
Discussion Starter · #3 ·
Thanks hopefully it will work out, I have a visit to the dealer and it may even happen by Friday. Last week, you should have seen the engine trying to gain speed but being dragged down as it was stumbling into 70-80mph. Something is not running right.
 

·
Vendor
Joined
·
1,341 Posts
I do not know what the situation is with this car but during my lunch break I figured I tried to redline the car. The car wouldn't do it. N Mode or A Mode the car doesn't run up to spec. Next week I have a visit to the dealer because I have been having some issues with acceleration stumbling, I was reading on the forum here that some had problems with injectors. If an injector is faulty, will it throw a code? Because right now I do not have any CEL.
Hi SerpenteRosso,

Sorry to hear about this! Please don't hesitate to send us a PM with any questions or concerns that may arise during your dealership appointment, we're happy to assist if needed.

Andrea
Alfa Romeo Social Care Specialist
 

·
Registered
Joined
·
271 Posts
Discussion Starter · #5 ·
I already have a case # for over a month and a half, I'm not happy at all.


Hi SerpenteRosso,

Sorry to hear about this! Please don't hesitate to send us a PM with any questions or concerns that may arise during your dealership appointment, we're happy to assist if needed.

Andrea
Alfa Romeo Social Care Specialist
 

·
Vendor
Joined
·
1,341 Posts
I already have a case # for over a month and a half, I'm not happy at all.
Hi SerpenteRosso,

Sorry to hear this! I was able to locate your VIN in our private messages and have further documented your concerns in your case and alerted your Case Specialist to reach out to you as soon as possible.

Andrea
Alfa Romeo Social Care Specialist
 

·
Registered
Joined
·
1,507 Posts
Don't put your faith in ARC. I had a case number and dealer appointment and never heard from them again. They must have a heavy case load. You've had nothing but trouble from the beginning.
 

·
Registered
Joined
·
271 Posts
Discussion Starter · #8 ·
Me neither I think the problems could be the following: coil packs, a possible vacuum leak, spark plug or plugs, or injectors. The car doesn't run the way it was engineered to do.
 

·
Registered
Joined
·
1,507 Posts
Is this a new issue on top of your other ones or is it on going? You should start a case for them to buy it back.
 

·
Registered
Joined
·
271 Posts
Discussion Starter · #11 ·
The car is in the shop may be fuel delivery related. Hopefully it's figured out.
 

·
Registered
Joined
·
271 Posts
Discussion Starter · #12 ·
Next week the engineer is going to look over the car they can't figure it out
 

·
Registered
Joined
·
2,344 Posts
I do not know what the situation is with this car but during my lunch break I figured I tried to redline the car. The car wouldn't do it. N Mode or A Mode the car doesn't run up to spec. Next week I have a visit to the dealer because I have been having some issues with acceleration stumbling, I was reading on the forum here that some had problems with injectors. If an injector is faulty, will it throw a code? Because right now I do not have any CEL.
You tried to redline the car in N or A mode. Were you in auto mode or manual?
 

·
Registered
Joined
·
271 Posts
Discussion Starter · #14 ·
Both the car is not running as designed. Tried the D mode and N in both auto and manual mode no difference. The car has a misfire which they cannot seem to solve.
 

·
Registered
Joined
·
2,344 Posts
Wow, sorry to hear.....
 

·
Registered
Joined
·
271 Posts
Discussion Starter · #17 ·
Monday the engineer is taking a look at this car hopefully they can figure out the performance issues. All concerns verified by the tech...keep ya'll posted
 

·
Registered
Joined
·
2,134 Posts
Monday the engineer is taking a look at this car hopefully they can figure out the performance issues. All concerns verified by the tech...keep ya'll posted
Please post which model Giulia that you own.
You could include this information in a signature line, so that you don't have to type it every time. :)
 

·
Registered
Joined
·
1,507 Posts
For your sake I hope it gets resolved. Through all the problems with your car you have never said anything bad about Alfa. You are a true Alfista. Good luck Monday and can't wait to shake your hand at a Sunday breakfast.
 
1 - 20 of 22 Posts
Top