Alfa Romeo Giulia Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter · #1 ·
Initially the QV would go into race mode whenever I wanted (still within break-in period, so only for the exhaust note really). Yesterday and today at about 500 miles on the odometer, it will not go into race mode. Does anyone have knowledge of any conditions that block out race mode? My version of the manual does not have anything about race mode.

Of course the 4c automatically proscribed it until some certain mileage, but that did not seem to be the case with the QV.

Thanks...
 

·
Registered
Joined
·
418 Posts
Initially the QV would go into race mode whenever I wanted (still within break-in period, so only for the exhaust note really). Yesterday and today at about 500 miles on the odometer, it will not go into race mode. Does anyone have knowledge of any conditions that block out race mode? My version of the manual does not have anything about race mode.

Of course the 4c automatically proscribed it until some certain mileage, but that did not seem to be the case with the QV.

Thanks...
Engine temperature perhaps? I'll look into it. Not sure.
 

·
Super Moderator
Joined
·
1,088 Posts
No issues here. When showing the car to people the car is always warmed up and lit clicks into Race mode with no problem. 300 miles on the car so far!
 

·
Registered
Joined
·
72 Posts
Discussion Starter · #6 ·
Cleared

Mine cleared up about one week after my posting. I do not think I did anything to special -- one day it just started working again and has been fine since.
 

·
Registered
Joined
·
2,988 Posts
Initially the QV would go into race mode whenever I wanted (still within break-in period, so only for the exhaust note really). Yesterday and today at about 500 miles on the odometer, it will not go into race mode. Does anyone have knowledge of any conditions that block out race mode? My version of the manual does not have anything about race mode.

Of course the 4c automatically proscribed it until some certain mileage, but that did not seem to be the case with the QV.

Thanks...
The 4C has about 180 mile break-in period where the ECU won't all Dynamic and Race modes.

I test drove a Quad with no mileage and it was in Race mode, and we put in Race first thing when cold.. You said you had been able to go into Race, but now you can't, so this doesn't sound like a break-in thing. I'd suggest reading the owner's manual first.
 

·
Registered
Joined
·
38 Posts
Hey Chanosh, I had the same thing happen on mine, at around the same mileage as yours.

I'm not sure if it was locked-out, or if I wasn't rotating the knob with enough pressure, because the ability to switch into race mode returned shortly thereafter (like the next day).

Make sure you are rotating the knob clockwise "against spring resistance". In my case, I'm still not sure if it was pilot error or a software glitch.
 

·
Registered
2020 Alfa Romeo Giulia Sport Ti AWD
Joined
·
8,776 Posts
I like a story with twists.
 
  • Like
Reactions: Chanosh

·
Registered
Joined
·
3,608 Posts
You were just being careful! It's plastic knob right? Imagine the tears if it broke off in your hand, knock on carbon fiber ;)
 
  • Like
Reactions: Chanosh
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top