Alfa Romeo Giulia Forum banner

1 - 19 of 19 Posts

·
Registered
2017 Giulia Ti Q4
Joined
·
11 Posts
Discussion Starter #1
I was hoping, once I get used Alfa- all brand new car quirks will not be an issue, I was wrong. My former Infiniti dealer said once- if you really want to drive Alfa- lease it. Now I see why it did make sense. After driving car for about 6 month with no or minor issues, I had to schedule appt for service. Yesterday, while driving on local street, out of nowhere- center instrument console turned off and now its just black- no life, though, it blinks once in a while. Called service center- advisor gave me a nonsense explanation- because i do not drive a lot (weekends only)- car conservers battery power and once I drive for a while it will come back on again. Driving second day- long enough for battery to kick in, but console is the same- blank. Gauges are fine, just middle screen has nothing on it. To me it is a driving hazard . Making an appointment is also a big deal,as they do not have anything available until Jan 29 (due to covid). I was also given warning ahead of time- "we do not have loaners to provide". Currently car has 19400 miles. Has anyone heard of this issue? Picture attached. Any advises, hints will be greatly appreciated.


106955
 

·
Registered
Joined
·
577 Posts
Common issue. There was an update for the instrument cluster.

Go to another dealer. That's the real issue here.
 

·
Registered
Joined
·
53 Posts
I had a 2017 that had the same problem. Westbury Alfa Romeo did an update and I had no more problems with it. My 2020, btw, has had no problems in the 5 months I have had it. The 2017 got flooded in a storm.
 

·
Registered
2017 Giulia Ti Q4
Joined
·
11 Posts
Discussion Starter #5
I had a 2017 that had the same problem. Westbury Alfa Romeo did an update and I had no more problems with it. My 2020, btw, has had no problems in the 5 months I have had it. The 2017 got flooded in a storm.
I am glad your 2020 is hiding on. Good to know. Wonder how long ago this update came out?. Reason I asked is - when I bought the car about 6 months ago, I specifically asked to apply all needed updates prior to delivery. They said- they did. If they lied, which is now very possible, I will go to different dealer.
 

·
Registered
2017 Giulia Ti Q4
Joined
·
11 Posts
Discussion Starter #6
I am glad your 2020 is hiding on. Good to know. Wonder how long ago this update came out?. Reason I asked is - when I bought the car about 6 months ago, I specifically asked to apply all needed updates prior to delivery. They said- they did. If they lied, which is now very possible, I will go to different dealer.
“holding on”
 

·
Registered
Joined
·
51 Posts
I had the same problem happen to me in August last year on my 2017 Q4. Ended up making an appointment with my local alfa dealer for an IC replacement. Parts availability was scarce and it took them 4+ weeks to get the part and replace the cluster. All is well since then. My advice... Call up the dealer in advance to secure a loaner and drop off the car. Pack patience.
 

·
Registered
2017 Giulia Ti Q4
Joined
·
11 Posts
Discussion Starter #8
I had the same problem happen to me in August last year on my 2017 Q4. Ended up making an appointment with my local alfa dealer for an IC replacement. Parts availability was scarce and it took them 4+ weeks to get the part and replace the cluster. All is well since then. My advice... Call up the dealer in advance to secure a loaner and drop off the car. Pack patience.
Good advice. Thank you. Only 2 more dealers near by. One I bought car from- only for Jan 29. Way too long. And they don’t have loaners, already told me. Will try other two tomorrow.
 

·
Registered
2017 Giulia Ti Q4
Joined
·
11 Posts
Discussion Starter #10
Got appt for 1/20. This is the best I could get. They will provide loaner. Will update on their findings then. Thank you guys for help and advise!
 

·
Registered
Joined
·
289 Posts
Ok, this is always a weird repair. Does the screen ever come back on? If it is off and stays off, I have noticed the reprogram never works and fails halfway through. This means that they will have to order a new cluster assembly. These can take a while to get to the dealer as the mileage must be programmed by the speedometer supplier before shipment. If the condition is intermittent and they can perform the reprogram while the center screen is illuminated, the flash will work and your problem will be solved. Count on being out of the car for a few weeks though, as when the program fails it takes out the analogue gauges also.
 

·
Registered
2017 Giulia Ti Q4
Joined
·
11 Posts
Discussion Starter #12
Ok, this is always a weird repair. Does the screen ever come back on? If it is off and stays off, I have noticed the reprogram never works and fails halfway through. This means that they will have to order a new cluster assembly. These can take a while to get to the dealer as the mileage must be programmed by the speedometer supplier before shipment. If the condition is intermittent and they can perform the reprogram while the center screen is illuminated, the flash will work and your problem will be solved. Count on being out of the car for a few weeks though, as when the program fails it takes out the analogue gauges also.
Thank you, great info! So far after 3 days it didn’t come back. What I noticed- screen flashes/lights up for a second once in a while. But nothing comes up. This really sucks. Since It is a known issue- how come they never issued recall/fix... Weird it is.
Thanks again Beta Romeo.
 

·
Registered
2017 Giulia Ti Q4
Joined
·
11 Posts
Discussion Starter #14
They wound up replacing the cluster in my '17.
Here guys are saying it takes quite a long time to get the part. I am not sure why car should be sitting at the dealer, somewhere outside ( considering winter weather) waiting for a part to arrive when it can be sitting in my warm garage. It’s is pretty drivable. Just can’t see anything on display.
 

·
Registered
2020 Alfa Romeo Giulia TI Q4
Joined
·
9 Posts
I was hoping, once I get used Alfa- all brand new car quirks will not be an issue, I was wrong. My former Infiniti dealer said once- if you really want to drive Alfa- lease it. Now I see why it did make sense. After driving car for about 6 month with no or minor issues, I had to schedule appt for service. Yesterday, while driving on local street, out of nowhere- center instrument console turned off and now its just black- no life, though, it blinks once in a while. Called service center- advisor gave me a nonsense explanation- because i do not drive a lot (weekends only)- car conservers battery power and once I drive for a while it will come back on again. Driving second day- long enough for battery to kick in, but console is the same- blank. Gauges are fine, just middle screen has nothing on it. To me it is a driving hazard . Making an appointment is also a big deal,as they do not have anything available until Jan 29 (due to covid). I was also given warning ahead of time- "we do not have loaners to provide". Currently car has 19400 miles. Has anyone heard of this issue? Picture attached. Any advises, hints will be greatly appreciated.


View attachment 106955
Hey, I leased a beautiful black on black Guilia TI Q4. I recommend taking it to Gold Coast Alfa Romeo & Maserati Of Great Neck. Everyone there is great and I can guarantee you they can help you. They are great when I bring my car in for services etc.. Westbury isn't that great I walked out of there after talking to the Westbury sales department over how rude the sales people were.
 

·
Registered
Joined
·
2,285 Posts
Here guys are saying it takes quite a long time to get the part. I am not sure why car should be sitting at the dealer, somewhere outside ( considering winter weather) waiting for a part to arrive when it can be sitting in my warm garage. It’s is pretty drivable. Just can’t see anything on display.
Except in your initial post you said it was "a driving hazard". Which is it?
 

·
Registered
2017 Giulia Ti Q4
Joined
·
11 Posts
Discussion Starter #17
Hey, I leased a beautiful black on black Guilia TI Q4. I recommend taking it to Gold Coast Alfa Romeo & Maserati Of Great Neck. Everyone there is great and I can guarantee you they can help you. They are great when I bring my car in for services etc.. Westbury isn't that great I walked out of there after talking to the Westbury sales department over how rude the sales people were.
Thanks very much for the info. I didn’t like Westbury myself, but since no one else had that particular car I bought it from them. And, yes, I made appt with Gold Coast for next Wednesday. I like the way they got back to me next day after I had chat session. Thanks again
 

·
Registered
2017 Giulia Ti Q4
Joined
·
11 Posts
Discussion Starter #18
Morning guys. I know Italian chicks are moody (been to Italy more than once), and apparently , cars too. This morning cluster magically turned on after two weeks being off, and a couple of blinks. Drove about 4 miles. Will go out a little later too. At first it had message "Start /Stop Unavailable and according to circled "A" it refers to remote start as the the symbol is on the remote- see Pic1. on Pic2- it's gone. Surely, I am still taking it to service next Wednesday. Will update later after second drive. Smh..
107130
107131
 

·
Registered
2017 Giulia Ti Q4
Joined
·
11 Posts
Discussion Starter #19
Update: drove again, circled "A!" is back on the bottom. According to writeup- it should go away after restart. It didn't.
 
1 - 19 of 19 Posts
Top