Alfa Romeo Giulia Forum banner
1 - 20 of 35 Posts

·
Registered
Joined
·
254 Posts
Discussion Starter · #1 ·
Has anybody had this issue...
I have the stock seats for my car, and the electric motors to move them forward, backward, etc., have worked fine until this morning. After my drive to work, I tried moving the front passenger seat backwards with the motor button on the side of the seat, and the seat wouldn't move in any direction. Driver's seat worked fine, just not the passenger seat.
Ultimately turned the car off and on again, and it worked just fine. Thoughts??
 

·
Registered
Joined
·
202 Posts
Has anybody had this issue...
I have the stock seats for my car, and the electric motors to move them forward, backward, etc., have worked fine until this morning. After my drive to work, I tried moving the front passenger seat backwards with the motor button on the side of the seat, and the seat wouldn't move in any direction. Driver's seat worked fine, just not the passenger seat.
Ultimately turned the car off and on again, and it worked just fine. Thoughts??
That's annoying. I hope it does not happen again. Let the dealer have a look at it.
Never heard of something like that on any car.
 

·
Vendor
Joined
·
1,328 Posts
Has anybody had this issue...
I have the stock seats for my car, and the electric motors to move them forward, backward, etc., have worked fine until this morning. After my drive to work, I tried moving the front passenger seat backwards with the motor button on the side of the seat, and the seat wouldn't move in any direction. Driver's seat worked fine, just not the passenger seat.
Ultimately turned the car off and on again, and it worked just fine. Thoughts??
Hi Speeddoc,

Sorry to hear about this! If you decide to visit your local dealership for further diagnosis I'd be happy to offer assistance if needed. Just send us a PM with your VIN and let me know.

Andrea
Alfa Romeo Social Care Specialist
 

·
Registered
Joined
·
254 Posts
Discussion Starter · #8 ·
Thank you! I appreciate the offer and will let you know if I end up addressing it at local dealership.
 

·
Registered
Joined
·
7 Posts
This actually happened to my car as well :( Kinda embarrassing cause I showed the car to one of my cousins and then the passenger seat wouldn't move as I was driving. I restarted the car and it was working again.
 

·
Registered
Joined
·
1,807 Posts
Could be an issue if you live in England...
 

·
Registered
Joined
·
3 Posts
I have the same issue. Start the car and after a brief delay, it doesn't move. But if I shut the engine off, it moves again (after a brief delay from engine shutoff).
 

·
Registered
Joined
·
38 Posts
So my passenger seat started working sporadically about a month ago, but the slide forward/backward function is now inoperable. Height and recline still work just fine. I'll have to head back to the dealership for the third time in four months. I love the car but not the trips to the dealership, it's always there for at least five days, 2-3 days for diagnosis and 2-3 for the fix.
 

·
Vendor
Joined
·
1,328 Posts
So my passenger seat started working sporadically about a month ago, but the slide forward/backward function is now inoperable. Height and recline still work just fine. I'll have to head back to the dealership for the third time in four months. I love the car but not the trips to the dealership, it's always there for at least five days, 2-3 days for diagnosis and 2-3 for the fix.
Hi JRinNJ,

Sorry to hear about this! If you decide to visit your local dealership for further diagnosis I'd be happy to offer assistance if needed. Just send us a PM with your VIN and let me know.

Andrea
Alfa Romeo Social Care Specialist
 

·
Registered
Joined
·
25 Posts
New Guilia (less than two weeks), same intermittent issue with passenger seat except restarting engine does not seem to have any effect. Took to dealer and they say they need to replace motor and module on both seats...? Here’s the good part, they say parts not available until December. Seriously?
 

·
Registered
Joined
·
407 Posts
Had the same issue on mine since day one. Dealer ordered the part for me early March and I'm taking it in on Wednesday to get everything taken care of. Apparently, it's a super common problem on earlier Giulia's and Alfa now has to take care of it, but they simply can't make the parts needed quick enough.

@GrinchF16 I'd either visit another dealer or just speak to a different service advisor. Doesn't make sense that they'd make you wait that long when it only took mine a month or so to come in. Maybe they meant it's been on backorder since last December? idk good luck
 

·
Registered
Joined
·
25 Posts
The dealer tells me there are none of the parts available anywhere in the US. His theory is that Alfa is diverting the parts to production.... Sounds a little hokey-pokey to me. Hoping AlfaRomeoCares (Andrea above) might have some thoughts. Other than the seat and the color of the nav display, love the car!
 

·
Registered
Joined
·
2,988 Posts
The dealer tells me there are none of the parts available anywhere in the US. His theory is that Alfa is diverting the parts to production.... Sounds a little hokey-pokey to me. Hoping AlfaRomeoCares (Andrea above) might have some thoughts. Other than the seat and the color of the nav display, love the car!
This seems about par for the course actually. Not what anybody wants to hear and it certainly makes Alfa look bad. If you haven't sent a PM to AlfaRomeoCares yet, you should do so. You can also call FCA (844-253-2872) and file a formal complaint which will get you a case number and an 'escalated' case. Not sure how this differs from contacting AlfaRomeoCares.

The good news is, you can drive your new Giulia while waiting on seat parts, assuming the seat is adjusted close enough.
 
1 - 20 of 35 Posts
Top