Alfa Romeo Giulia Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
1,507 Posts
Discussion Starter · #1 ·
After 4 weeks of ownership for some reason I get in the car and the parking assist is lit. I push in the button and it flashes for several seconds then stays on. This happened all day. Once I even had an amber warning light on the cluster come on. I guess it's a trip to the dealer.
 

·
Registered
Joined
·
1,922 Posts
I have had it once. Turned out be the Left Side parking sensor which is fitted into the plastic grille had come loose when the hexagonal holder had come off. Not sure if it was debris impact or something else. Once I refitted the sensor using zipties to its position the warning went away. Dealer later replaced the whole sensor assembly. All ok since. Occasionally you might get it if the sensors are covered with dirt or soon after washing. Since dealer applied some software updates I have't had any false warnings. Check all your front sensors first of all.
 

·
Registered
Joined
·
1,507 Posts
Discussion Starter · #3 ·
I did and all seems okay. I did have a clear bra put on and the car was ceramic coated. I spoke to the shop that did the work and they said the coating was not sprayed on. I think it is more than just a coincidence it happened right after I picked the car up.
 
  • Like
Reactions: Alfaholico

·
Registered
Joined
·
1,999 Posts
Yea, if the sensors can be confused by dirt, then a coating on them would be bad.
 

·
Registered
Joined
·
1,507 Posts
Discussion Starter · #5 ·
They did not apply anything in that area, or so they say.
 

·
Registered
Joined
·
1,507 Posts
Discussion Starter · #6 ·
Funny thing, it started working again but it is very sensitive. If I come to a stop the audible warning goes on. I will bring it to the dealer and let them check it out when they install my exhaust.
 

·
Vendor
Joined
·
1,334 Posts
After 4 weeks of ownership for some reason I get in the car and the parking assist is lit. I push in the button and it flashes for several seconds then stays on. This happened all day. Once I even had an amber warning light on the cluster come on. I guess it's a trip to the dealer.
Hi alfa55,

Sorry to hear about this! Please don't hesitate to send us a PM with any questions or concerns that may arise during your dealership appointment, we're happy to assist if needed.

Andrea
Alfa Romeo Social Care Specialist
 

·
Registered
Joined
·
75 Posts
My 2020 Giulia Ti came with the bump sensors but honestly they are only problems and it is like that with any other car manufacturers because they all use the same systems for years so Alfisti just disable it completely if you keep having problems they are nice safety toys but safety starts when we are behind the wheel always sensor or no sensors.
.As far the front license plate mount well that is poor design from Alfa Romeo engineerings when you think about it...screw holes on such beautiful front bumper? On such great looking automobile? And here is the kicker it does interfere with the sensors?Madonna Alfa Romeo,dai per favore.......but anyway i do love my Giulia and i hope at Alfa they take serious consideration what Alfa owners have to say.Thank you.
 
1 - 8 of 8 Posts
Top