Alfa Romeo Giulia Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I've a few error codes that have just made an appearance, last week Check engine notification with orange CEL and the loss of DNA. Reset the codes using the engine on/off technique but it happened again today.

Below is a copy of the codes from 'CarScanner' iOS app, the obvious thing to do is to get this checked out however I'm interested if anyone has seen these codes before or could recommend another scan app for iPhone (I can't get Multieuscan to work with the Bluetooth scanner).

I drive a 2017 Giulia QF, the car wasn't under any aggressive driving before the codes came up, if anything more like start stop traffic.

I'd love to know if anyone has had a similar experience.

Thanks.



============1==============

P026A

Raw code: 026A

ECU: 10[Archive (inactive)]

Status: Permanent

OBDII: Intercooler - efficiency below threshold


============2==============

U0001

Raw code: C001

ECU: 18

Status: Confirmed

OBDII: Controller area network (CAN) data bus, high speed bus


============3==============

U0401

Raw code: C401

ECU: 18

Status: Confirmed

OBDII: Invalid data received - engine control module (ECM)


============4==============

U0121

Raw code: C121

ECU: 17

Status: Confirmed

OBDII: Data bus, anti-lock brake system (ABS) control module - no communication


============5==============

U0121

Raw code: C121

ECU: 10

Status: Confirmed

OBDII: Data bus, anti-lock brake system (ABS) control module - no communication


============6==============

P026A

Raw code: 026A

ECU: 10

Status: Confirmed

OBDII: Intercooler - efficiency below threshold
 

·
Premium Member
Joined
·
2,488 Posts
I would check the coolant level in the intercooler cooling system... I would guess it's either low or you have an issue with the water pump for that system.... the other codes I would ignore for now
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
I would check the coolant level in the intercooler cooling system... I would guess it's either low or you have an issue with the water pump for that system.... the other codes I would ignore for now
wow I just checked and the front was almost empty and the rear had dropped in the last month.

would you think it’s better to clear the code and the CEL light or leave it be to see if topping up the tanks with coolant resolves the error?
 

·
Registered
Joined
·
872 Posts
wow I just checked and the front was almost empty and the rear had dropped in the last month.

would you think it’s better to clear the code and the CEL light or leave it be to see if topping up the tanks with coolant resolves the error?
At this point I would drop the aero cover and look for the leaks. Main Radiators are a problem if you haven't replaced your's yet. I would look at the intercoolers to make sure a rock did puncture one and finally not sure if the turbos are water cooled but I would check those lines as well.
 

·
Premium Member
Joined
·
2,488 Posts
I would clear the codes, top off the cooling systems then do what @The_Dude said ..you have a leak somewhere, you just need to find it... it's likely a small leak, so you may need to pressure test the system to locate it , but coolant leaves a trail where its leaking so look for a sign of orange looking crust around the radiator edges and on the belly pans
 

·
Registered
Joined
·
872 Posts
I would clear the codes, top off the cooling systems then do what @The_Dude said ..you have a leak somewhere, you just need to find it... it's likely a small leak, so you may need to pressure test the system to locate it , but coolant leaves a trail where its leaking so look for a sign of orange looking crust around the radiator edges and on the belly pans
I would also add it will also leave dry white patches/dots too when it dries.
 
1 - 7 of 7 Posts
Top