Alfa Romeo Giulia Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hey y'all. Former '06 Acura TL owner here. It was a great car - can't say enough good things about it - but it was time to move on. Test drove the Lexus IS 300, Acura TLX, Infiniti Q50, and the Giulia. Loved the Giulia, but couldn't find the right one for me, so I custom built mine at the end of February. Volcano black Ti with Red interior, and some other great features.

I picked up my Giulia Ti AWD yesterday at 8pm. Stepped into it again at 7am this morning and already having engine issues ("Service Engine," stuck on natural mode, check engine light is on), but other than that, it's a beaut. I'm really looking forward to getting these hiccups fixed and hitting the road hard. Excited to be one of the first Alfa owners in the states.

It seems like an awesome community here and I'm glad to be a part of it!
 

·
Registered
Joined
·
658 Posts
Welcome, congratulations on the Ti and really hope you get the issues fixed quickly but it would be frustrating if it's code updates the dealer should have done before giving you the car.
 

·
Super Moderator
Joined
·
1,086 Posts
Welcome! Sorry the car is acting up within the first 24 hours.

We're within an hour of each other. One other member here (Alan) is fairly near as well.

Which dealer did you purchase through? They should be able to get it squared away pronto. There are known ECU flash updates available to cure the issue.
 

·
Premium Member
Joined
·
2,086 Posts
Welcome Alex - be prepared to get a lot more attention than all of those tested cars combined! It's very enjoyable. Hope your gremlins are resolved soon
 

·
Registered
Joined
·
2,988 Posts
Welcome :)
Congrats :grin2:

You're issue could be as simple as the gas cap loose. Hopefully the dealer will fix it quickly.

We have a blue Ti with cream Lusso interior on order, and some other nice options. Ordered the end of January. Should be here end of this month, maybe beginning of June.
 

·
Registered
Joined
·
249 Posts
Welcome to the wonderful world of Alfa. Mine is on order too. Will post details soon.
 

·
Registered
Joined
·
180 Posts
Welcome, I hope your issues are resolved by now, please update us as to cause and remedy. I also have a Ti, no problems in 1700 miles.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #9 ·
Thanks everyone - appreciate the love! Apparently it was just a software update, nothing major. The Giulia is doing great! Loved my time with it this far. I've noticed a lot of Philly folks on here. Happy to see y'all.
 

·
Registered
Joined
·
16 Posts
Hey y'all. Former '06 Acura TL owner here. It was a great car - can't say enough good things about it - but it was time to move on. Test drove the Lexus IS 300, Acura TLX, Infiniti Q50, and the Giulia. Loved the Giulia, but couldn't find the right one for me, so I custom built mine at the end of February. Volcano black Ti with Red interior, and some other great features.

I picked up my Giulia Ti AWD yesterday at 8pm. Stepped into it again at 7am this morning and already having engine issues ("Service Engine," stuck on natural mode, check engine light is on), but other than that, it's a beaut. I'm really looking forward to getting these hiccups fixed and hitting the road hard. Excited to be one of the first Alfa owners in the states.

It seems like an awesome community here and I'm glad to be a part of it!
Hi, when i got my TI, I took a trip from Wisconsin to California and back around 5000 mi including driving around CA, not a single problem. I did have a problem around 20,000 mi a module had to be replaced but that's about it. Love the car. I'm sure you will love it too.
 
1 - 10 of 10 Posts
Top