Alfa Romeo Giulia Forum banner
21 - 30 of 30 Posts

Administrator
2018 Giulia Ti Sport Q4
Joined
5,857 Posts
But for sure I was parked with nose a bit down / tilted let's say even on that right side ... And rain was heavy..... Connectors all soaked completely..... I will start her tomorrow after dessicant treatment and never park like that and check the screen frequently.....


What are your thoughts for that o-ring.... Maybe better tube or any upgrade about o-ring? Or maybe I can try and find same dimensions o-ring that is MS or aircraft grade... They can sustain much greater temperatures....

Seems like that should be it....

This is first forum so far with care taken to help guys with Giulias...

U guys rock;););):cool::cool::cool:
Show us a photo of where it is leaking.
 

Registered
Veloce 2.0T blackvolcano + 166 2.4 20v jtd
Joined
19 Posts
Discussion Starter · #24 ·
Show us a photo of where it is leaking.
Couldn't do better, but is from lower two ... I think .. thi upper is oil.... It is wet around but I think not from oil.... Below is all red.... Didn't touch to feel it if I have water drop
 

Attachments

Administrator
2018 Giulia Ti Sport Q4
Joined
5,857 Posts
Couldn't do better, but is from lower two ... I think .. thi upper is oil.... It is wet around but I think not from oil.... Below is all red.... Didn't touch to feel it if I have water drop
Yep, turbo o-rings. This was a TSB, and maybe a recall? I don't know for sure.
 
  • Like
Reactions: jocker

Registered
Veloce 2.0T blackvolcano + 166 2.4 20v jtd
Joined
19 Posts
Discussion Starter · #26 ·
these ar my thoughts as well.... should be covered by sb, but i also know who touched turbo some 3 months ago... also official dealer...
 

Registered
Veloce 2.0T blackvolcano + 166 2.4 20v jtd
Joined
19 Posts
Discussion Starter · #28 ·
Not good guys .. is on top one.... So it is oil... And bcm retarded, lights not working bla bla bla all the same.... I hope are cb's.... I cannot check anymore is dark now, i have disconnected battery.... Also on other hand I am a bit scared of Wednesday honestly.... I hope 馃馃馃馃馃馃馃.... It is leaking decently.... Is a major failure, it can catch fire easily.... So now with towing included I am generally fckd to be excused.....

Do you guys think I should call previous garage to ask for what they think? 99% is their fault they were working on her, and as I know everything has to. E updated.... And is also a water leak .... Something is deadly wrong with that turbo I think...
 

Attachments

Registered
2018 Q4 with Fiamenghi Ti exhaust, Race Mod, and Tecnico wheels.
Joined
9,071 Posts
Not good guys .. is on top one.... So it is oil... And bcm retarded, lights not working bla bla bla all the same.... I hope are cb's.... I cannot check anymore is dark now, i have disconnected battery.... Also on other hand I am a bit scared of Wednesday honestly.... I hope 馃馃馃馃馃馃馃.... It is leaking decently.... Is a major failure, it can catch fire easily.... So now with towing included I am generally fckd to be excused.....

Do you guys think I should call previous garage to ask for what they think? 99% is their fault they were working on her, and as I know everything has to. E updated.... And is also a water leak .... Something is deadly wrong with that turbo I think...
Although there is a lot of circuitry in the BCM, it is not hideously expensive. You might need a dealer to install and configure it though.
As with any electronics, recovery from being wet is a crap shoot. Maybe something got permanently damaged, maybe it did not. Did you try removing, opening, and drying out the interior of the BCM?

Clearly Alfa did not take enough care to ensure that water cannot get where it should not go. There is also the HK amplifier flooding problem, headlight flooding problems and reports of problems with the EPS having water intrusion.

IMO, the turbo seal issue is related to inadequate cool down of the turbo charger and aggravated by auto start-stop. Later model cars have a longer cool down sequence and (most?) earlier cars can have the software updated with the longer cool down.
 

Registered
Veloce 2.0T blackvolcano + 166 2.4 20v jtd
Joined
19 Posts
Discussion Starter · #30 ·
Thanks for reply.... Point is previous owner had something done on turbo at official dealer mid June.... Car is sold to me bit later, but till I got it to Croatia it took 1.5 months due to leasing approvals and sh*t, customs etc.... I drove 1500 miles till then.... Is installation issue I am pretty much convinced... I am so sad to look at her like this....:cry:

I hope with labor hours and everything that they will be normal and honest here ...
 
21 - 30 of 30 Posts
Top