Alfa Romeo Giulia Forum banner
61 - 71 of 71 Posts

·
Registered
2018 Vulcano Black Giulia Quadrifoglio
Joined
·
4,003 Posts
No, OSX is NOT the culprit. Alfa incorrectly states on the FCA nav download site the the flash drive must be formatted either NTFS or exFAT for Alfa Romeos, which is ABSOLUTELY NOT TRUE!!

On a flash drive formatted for OSX journaled, load only these two files: USA_Canada_and_Mexico-102913.meta.dct and MAP50231.bin and nothing else. Wingler took a screen shot of this not too ago, but that's all you need to do.

I tried unsuccessfully to upload the new maps by unzipping the files and doing the NTFS/ex FAT formatting, and it wouldn't work. Unfortunately, I'd deleted my previous map update "file" before downloading the latest, forgetting how to do it in the process. FCA's wording describing the process is ridiculously incorrect and complex, whereas the actual process is bog-simple!
Oh that's good to know
 

·
Registered
Joined
·
19 Posts
Followed @hownowcb 's instructions, but still getting this error. Have tried reformatting flash drive several times. Anyone else have a similar problem?
'19 Giulia Ti Sport / Mac OS / Flash drive OSX journaled.

thx!

110714
110715
 

·
Registered
Joined
·
80 Posts
Followed @hownowcb 's instructions, but still getting this error. Have tried reformatting flash drive several times. Anyone else have a similar problem?
'19 Giulia Ti Sport / Mac OS / Flash drive OSX journaled.

thx!

View attachment 110714

Your first, upper photo explains (granted, not very explicitly) that you should try to reinstall the two files onto a flash drive. If you're not already, I'd recommend using a 32gb drive. USB version doesn't matter. It's really important that you use Disk Utility to erase the drive; don't just drag files or folders already on it into the Trash. Choose "erase" and reformat the disk Mac OS Journaled. Then only drag the two files: USA_Canada_and_Mexico-102913.meta.dct and MAP50231.bin onto the drive and nothing else. Your drive should look exactly like this:

110747


Your problem could have been as simple as a single bit read error, so just try again, by reinstalling the files onto a fresh drive. At least your car recognizes what you're trying to do!

FYI: I named my flash drive "AR MAPS", but name doesn't matter. Just don't drag the files inside a folder, and don't create a folder on the flash drive. I put my iPhone into "Airplane" mode just to be sure a call wouldn't in any way interrupt the update process!
 

Attachments

·
Registered
Joined
·
19 Posts
Thx! Definitely followed your directions to a T previously, with multiple Disk Utility reformats of the drive (I have a background in tech so no issues there). The drive I'm using is a 256GB SanDisk- you think that could be the issue?


Your first, upper photo explains (granted, not very explicitly) that you should try to reinstall the two files onto a flash drive. If you're not already, I'd recommend using a 32gb drive. USB version doesn't matter. It's really important that you use Disk Utility to erase the drive; don't just drag files or folders already on it into the Trash. Choose "erase" and reformat the disk Mac OS Journaled. Then only drag the two files: USA_Canada_and_Mexico-102913.meta.dct and MAP50231.bin onto the drive and nothing else. Your drive should look exactly like this:

View attachment 110747

Your problem could have been as simple as a single bit read error, so just try again, by reinstalling the files onto a fresh drive. At least your car recognizes what you're trying to do!

FYI: I named my flash drive "AR MAPS", but name doesn't matter. Just don't drag the files inside a folder, and don't create a folder on the flash drive. I put my iPhone into "Airplane" mode just to be sure a call wouldn't in any way interrupt the update process!
 

·
Registered
Joined
·
4,070 Posts
Thx! Definitely followed your directions to a T previously, with multiple Disk Utility reformats of the drive (I have a background in tech so no issues there). The drive I'm using is a 256GB SanDisk- you think that could be the issue?
Definitely could be. Drive that capacity not supported, use a 32gb drive.
 

·
Registered
Joined
·
451 Posts
Thx! Definitely followed your directions to a T previously, with multiple Disk Utility reformats of the drive (I have a background in tech so no issues there). The drive I'm using is a 256GB SanDisk- you think that could be the issue?
Quite possible that's the issue. I believe the system doesn't officially support anything over 64GB. Anything over that could be hit and miss.
 

·
Registered
Joined
·
19 Posts
Quite possible that's the issue. I believe the system doesn't officially support anything over 64GB. Anything over that could be hit and miss.
good to know, thank you. Here I am flexing with a massive flash drive only to find out that's probably the culprit. lol
 

·
Registered
Joined
·
2 Posts
Yeah I think I am running into the same issue. Which you know ... annoying
Just picked up a 2017 Giulia TI Q4 yesterday, and I am also running into the same issue. Updated the firmware without issue, but when trying to update the maps, I get the same error as BK-GTV6 posted. Will update if I get it to work. Anyone else having this issue?
 
61 - 71 of 71 Posts
Top