Alfa Romeo Giulia Forum banner
461 - 480 of 507 Posts

·
Registered
Joined
·
2 Posts
So I have a NA 2017 Giulia that I just updated the firmware from 001.011.020 to 002.010.043 but I dont see any "Map Update" under System...
 

·
Registered
Joined
·
37 Posts
New to the forum. I checked the FCA site and a V1071 is available for the Giulia. I have a 2019 QV. There's 3 versions of the Connect Nav. Which is applicable? Thanks.
 

·
Registered
Joined
·
4,676 Posts
Updated mine today. No drama, took about 50mins with a USB 3.1 drive.
 

·
Registered
Joined
·
8 Posts
Hello

can anyone help me with 1052 version (europe) for 8.8”. My 3 years expired and my dealer doesn’t know how to extend.

thank you
 

·
Registered
Joined
·
1,820 Posts
Hello

can anyone help me with 1052 version (europe) for 8.8”. My 3 years expired and my dealer doesn’t know how to extend.

thank you
Any Alfa dealer should be able to do this, it's just a computer entry ;)
It will cost something though, around E 100,- to 120 for additional 3 years
 

·
Registered
Joined
·
8 Posts
They say they don’t have acces. I am from Romania and i see the country is not listed on mapcare. If anyone with acces is willing to help also with subscription i am willing to pay.
 

·
Registered
2022 Giulia Veloce and also a 2019 Stelvio Ti
Joined
·
1 Posts

·
Premium Member
2018 Giulia Ti Sport Q4
Joined
·
39 Posts
I also had the issue with 1081 failing for bad license and downloading the correct one did allow the update to go through. Now my system reboots over and over within 30 seconds of power up. Unit is a 2nd Gen in an MY18 Ti Q4 and firmware was at the latest version already, only the maps were out of date at 1010.

Any ideas? I can't even get to the reset all in the menu before it restarts.
 

·
Registered
Joined
·
4,676 Posts
I also had the issue with 1081 failing for bad license and downloading the correct one did allow the update to go through. Now my system reboots over and over within 30 seconds of power up. Unit is a 2nd Gen in an MY18 Ti Q4 and firmware was at the latest version already, only the maps were out of date at 1010.

Any ideas? I can't even get to the reset all in the menu before it restarts.
Pop the negative battery cable for a few mins?
 
  • Like
Reactions: Avnyc11

·
Premium Member
2018 Giulia Ti Sport Q4
Joined
·
39 Posts
Pop the negative battery cable for a few mins?
That didn't fix it. I am wondering if it is past the 3 year mark and needs a subscription update to load the newest maps. It had 1010 on it and that is Fall of 17 about the time the car was built according to the TomTom chart. Just really sucks that a map load kills the entire system and not just the Nav.
 
461 - 480 of 507 Posts
Top