Alfa Romeo Giulia Forum banner
41 - 59 of 59 Posts

·
Registered
Joined
·
34 Posts
Hi
Byte 126 00->A0


Enviado do meu iPhone usando o Tapatalk Pro
Uhm, it didn't work... Put A0 on byte 126 and I've got no results, pressing panic button didn't do anything after that (yes of course I switched off the electronics and back on after the proxy alignment)
Then I've reverted to 00

Note: my car is Emea, if this make some difference.
 

·
Registered
Joined
·
34 Posts
80 should do the trick. A0 enables panic but disables front wipers after-wipe function.

0xxxxxxx - panic disabled
1xxxxxxx - panic enabled

xx0xxxxx - after-wipe enabled
xx1xxxxx - after wipe disabled
We're still speaking about byte 126, right? So you say to try from 00 to 80?
Actually A0 is 1010000 so in theory it should work too (regardless the after wipe disabling). Is there maybe some other requirement to have on the car in order to have Panic function working? Something like having the Alfa Romeo anti-theft official alarm (I don't think so but nevertheless...)
Note: the key works, the remote start is working as like as the opening/closing of the doors and boot.
 

·
Registered
Joined
·
34 Posts
@ratix and @shpuncik so, I got back ad the car, put 126 byte at 80: nothing.
Someone in MES forum told to 1st try with byte 126 to 80 and, if not working, also to change 59 byte from 59 to 5A: again no luck...
By the way, what is the 59 byte setting about?

Current proxy is:
30 34 36 32 30 30 35 31 34 33 31 4F 55 54 50 55 54 2D 53 49 54 20 16 09 22 4F 0C 40 45 10 00 00 02 02 00 00 00 80 00 00 00 4B 0C 00 45 10 00 00 02 02 00 00 00 80 00 00 00 43 5A 2F 01 A8 01 07 F3 40 31 A1 07 40 10 10 0A A3 1E 04 52 00 35 73 14 01 4F 03 34 1D 03 AC 24 0E 23 05 00 80 00 0C C6 00 00 19 04 00 09 00 5B 9D 64 07 E5 05 21 00 01 70 12 3D 89 10 01 00 CA 00 B3 00 10 80 3D 49 01 03 12 F8 57 80 00 00 01 00 00 F0 20 04 22 81 0A 00 00 00 00 00 0C 1C 00 00 00 00 00

EDIT1: actually just noticed that the guy in MES forum is you shpuncik :)
EDIT2: now I've reverted to last good known conf, with 59 on 59 and 00 on 126
EDIT3: it's not that you have to enable it within the settings of the central car infotainment screen, right?
 

·
Registered
Joined
·
131 Posts
80 should do the trick. A0 enables panic but disables front wipers after-wipe function.

0xxxxxxx - panic disabled
1xxxxxxx - panic enabled

xx0xxxxx - after-wipe enabled
xx1xxxxx - after wipe disabled
Hello shpuncik

what do you mean with after wipe?

i had original 00 and modified to A0 to activate panic.
 

·
Registered
Joined
·
34 Posts
By the way, got the reason it doesn't work: my key is an used one, "reset" so that it can be associated to another car. On those ones (as like as on the chinese ones), the Panic doesn't work. You need a new key "virgin" from Alfa to make it work, other than the byte 126 from 00 to 80 in the proxy
Thanks, all for the help!
 

·
Registered
Joined
·
34 Posts
Hello shpuncik

what do you mean with after wipe?

i had original 00 and modified to A0 to activate panic.
When you pull the wiper to spray detergent on your windscreen, normally it sprays detergent, wipes like 3 times, wait a couple of seconds and then gives another single wipe. This last single wipe is (as far as I understood) the "after wipe".
 

·
Registered
Joined
·
131 Posts
By the way, got the reason it doesn't work: my key is an used one, "reset" so that it can be associated to another car. On those ones (as like as on the chinese ones), the Panic doesn't work. You need a new key "virgin" from Alfa to make it work, other than the byte 126 from 00 to 80 in the proxy
Thanks, all for the help!
It is not possible to use an used key fob. You have to buy a new and learn to the car
 

·
Registered
Joined
·
34 Posts
It is not possible to use an used key fob. You have to buy a new and learn to the car
It's not possible if the keyfob hasn't been unlocked. If it is (like this: Alfa Romeo Giulia Stelvio 5 Button Smart Key Remote Fob OEM UNLOCKED KR5ALFA434 | eBay ) it has only to be learnt by the car and it will work (except for the Panic key). Mine is exactly like that (that ebay link is the one I got it from): an used one that has been "erased/unlocked" and it works in all ways except for the Panic key :)
 

·
Registered
Joined
·
1,224 Posts
@fiatpanda Alex_GenTLe described after-wipe correctly. EMEA by default has it enabled, NAFTA - disabled. heaven knows why NAFTA once again has it turned off :LOL:

@Alex_GenTLe I've used original virginized keys many times. but to be honest I've never cared much about Panic function so I'll have to test it next time. but then again when programming used keys to car I use special equipment for that - not MES or Witech.
 

·
Registered
Joined
·
131 Posts
@Alex_GenTLe @shpuncik
I tested it
I wash the windshield and it only wash’s 4 times without a brake of a couple of seconds.

original my byte was 00
So it had to be :

0 0 0 0 0 0 0 0

so it was enabled

and now with A0 it is disabled

1 0 1 0 0 0 0 0

so I have to put it to

1 0 0 0 0 0 0 0 = 80 (hex)

To enable again, true ?
 

·
Registered
Joined
·
14 Posts
Can someone help me? I have a Stelvio 2017 and also want after wipe (i'm from Europe, but it doesnt work)
Byte 126 default was set to 00, i changed it to 80, but still doesn't work.
Can I leave the setting on 80?

Why does after wipe not work? I really miss it, because after 3 wipes, the detergent is still on my window. Really annoying.
 

·
Registered
Joined
·
1,224 Posts
Can someone help me? I have a Stelvio 2017 and also want after wipe (i'm from Europe, but it doesnt work)
Byte 126 default was set to 00, i changed it to 80, but still doesn't work.
Can I leave the setting on 80?

Why does after wipe not work? I really miss it, because after 3 wipes, the detergent is still on my window. Really annoying.
should be 00. maybe it depends on body ECU software version too.
 
41 - 59 of 59 Posts
Top