Alfa Romeo Giulia Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
Seems that the car isn’t making full boost when I push it in first and second but as soon as it shifts into third the boost/torque is noticeably greater. In dynamic mode. Any ideas what could be causing this?
 

·
Registered
Joined
·
49 Posts
To be honest i have felt a few times that car holds back a bit in 1st and 2nd to control the traction. Is this potentially whats happening here?

If your careful you could try giving it the beans in race mode, as this switches off any traction control interference

Might be a bit irrelevant as it might not apply to our cars but it certainly happens in other cars as to control the torque going into the gearbox.
 

·
Vendor
Joined
·
619 Posts
Multiple things at hand here.

Max torque limitations in lower gears - less engine load - traction control ---> will result in lower boost pressure/less power.
 

·
Registered
Joined
·
526 Posts
Does it do it all the time? I know on my car it won't perform to max when the engine is cold.
 

·
Registered
Joined
·
580 Posts
Does it do it all the time? I know on my car it won't perform to max when the engine is cold.
It concerns me a little that you know that ;) Please don't run these cars hard until they warm up, they will last a lot longer that way.

As for the original question on this thread, I think the comments Chris made and those about traction control pretty well cover it.

Greg
 

·
Registered
Joined
·
51 Posts
The Quad is a typical turbocharged car, and suffers some noticeable turbo lag. What you describe is typical if you mash the pedal when traveling at low speeds, to experience maximum acceleration in first you'll need to hold the brake from a stop and get the rpm's up prior to releasing the pedal, otherwise your going to get the response you describe. The reason you don't notice it as much in third is that the motor is already under load and producing more boost.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #7 ·
The Quad is a typical turbocharged car, and suffers some noticeable turbo lag. What you describe is typical if you mash the pedal when traveling at low speeds, to experience maximum acceleration in first you'll need to hold the brake from a stop and get the rpm's up prior to releasing the pedal, otherwise your going to get the response you describe. The reason you don't notice it as much in third is that the motor is already under load and producing more boost.
Appreciate all of the responses. Def more of a cut in timing and or boost vs turbo lag. Strange that if I downshift into 2nd, acceleration is slower to redline through 2nd and then picks up when I shift into 3rd. Not seeing any traction control lights coming on. Will try in Race mode and report back.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #8 ·
Multiple things at hand here.

Max torque limitations in lower gears - less engine load - traction control ---> will result in lower boost pressure/less power.
Appreciate it - just seems strange compared to any other car I’ve owened (mostly BMW and Porsche), this is the only one I’ve noticed it being so obvious. Is this normal for the Q.V.?
 

·
Registered
Joined
·
170 Posts
It's deliberate and only unadulterated in race mode. Try going full throttle in first and second in race mode, particularly with cold tyres. You'll then know exactly why they've done this. They can't also assume the skill of the driver.
 

·
Registered
Joined
·
765 Posts
Maybe the dealer or someone in your area on here that can let you take another car around the block to compare. It sounds what you are describing is unusual. I have a QV and haven’t noticed any lack of power or turbo lag like you seem to be experiencing. I have a manual transmaission car. Don’t know if that would make a difference.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #11 ·
Just following up to close the loop on this. Issue goes away in Race mode. See why they cut it in other drive modes...back end gets pretty loose in 1st & 2nd at full power.
 

·
Registered
Joined
·
3,600 Posts
And confirm at high rpm ;)
 
1 - 12 of 12 Posts
Top