Alfa Romeo Giulia Forum banner
1 - 20 of 29 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
ok...joining the club of gremlins in the quad.......out of the blue today engine light came on with message .....service electronic throttle control...
dealer cant get to it for a few days...
same as some others...mode knob is disabled so stuck in normal mode.
only has 2100 miles...2021 quad....kinda disappointed.....esp after the brake recall experience with dealer.
ah well....hopefully this is an isolated deal...
 

·
Vendor
Joined
·
1,325 Posts
ok...joining the club of gremlins in the quad.......out of the blue today engine light came on with message .....service electronic throttle control...
dealer cant get to it for a few days...
same as some others...mode knob is disabled so stuck in normal mode.
only has 2100 miles...2021 quad....kinda disappointed.....esp after the brake recall experience with dealer.
ah well....hopefully this is an isolated deal...
Hi fyrcapn,
If you'd like additional assistance alongside your dealer, feel free to send us a PM. We'd be happy to help.

Sarah
Alfa Romeo Cares
 

·
Registered
2019 Giulia Q4 Ti Sport, Misano Blue / Tan
Joined
·
260 Posts
ok...joining the club of gremlins in the quad.......out of the blue today engine light came on with message .....service electronic throttle control...
dealer cant get to it for a few days...
same as some others...mode knob is disabled so stuck in normal mode.
only has 2100 miles...2021 quad....kinda disappointed.....esp after the brake recall experience with dealer.
ah well....hopefully this is an isolated deal...
obligatory replace the battery comment
 

·
Registered
Joined
·
224 Posts
ok...joining the club of gremlins in the quad.......out of the blue today engine light came on with message .....service electronic throttle control...
dealer cant get to it for a few days...
same as some others...mode knob is disabled so stuck in normal mode.
only has 2100 miles...2021 quad....kinda disappointed.....esp after the brake recall experience with dealer.
ah well....hopefully this is an isolated deal...
It could be as little as your fuel level was a little too low and you made a sharp left turn.. Don't get all discouraged. These things can be touchy sometimes.
Have you tested the battery voltage level? If you can, probably do that first to make sure it's not the charge level of your battery.
After disconnecting and reconnecting your battery, you will get a few other error codes on the dash, don't panic. Reset the steering wheel. (While the car is running, lock the steering wheel all the way to the left wait for a second or two, then all the way to the right wait for a second or two, and then bring it to center wait for a few secs. Turn the car off ) After a few seconds, restart the car. and cycle the restart about four to six time. Drive the car a few miles if all the codes doesn't clear.. If nothing is fixed then call your dealeship.

Let me know how that works.
Erdem
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #5 ·
It could be as little as your fuel level was a little too low and you made a sharp left turn.. Don't get all discouraged. These things can be touchy sometimes.
Have you tested the battery voltage level? If you can, probably do that first to make sure it's not the charge level of your battery.
After disconnecting and reconnecting your battery, you will get a few other error codes on the dash, don't panic. Reset the steering wheel. (While the car is running, lock the steering wheel all the way to the left wait for a second or two, then all the way to the right wait for a second or two, and then bring it to center wait for a few secs. Turn the car off ) After a few seconds, restart the car. and cycle the restart about four to six time. Drive the car a few miles if all the codes doesn't clear.. If nothing is fixed then call your dealeship.

Let me know how that works.
Erdem
thanks for the encouragement Erdem……... tank is full… i had driven the car about 15 miles before it happened…but i will ck it running ,voltage that is….when i did ck the battery it was at 12.5…….i put the charger on it anyway…cars been fine up to now. thx for the reminder about the reset. the sales mgr here in south carolina told me about that and the touchy voltage issue. i would rather try some things…i hate taking it in to the dealer….they have no fenced lot.
 

·
Registered
Joined
·
833 Posts
Check all of the electrical connectors on the front of the motor. If you're inclined remove them carefully and reseat them.
 

·
Registered
Joined
·
224 Posts
thanks for the encouragement Erdem……... tank is full… i had driven the car about 15 miles before it happened…but i will ck it running ,voltage that is….when i did ck the battery it was at 12.5…….i put the charger on it anyway…cars been fine up to now. thx for the reminder about the reset. the sales mgr here in south carolina told me about that and the touchy voltage issue. i would rather try some things…i hate taking it in to the dealer….they have no fenced lot.
No worries.. I wouldn't want to go to the dealer for something that you might be able to reset yourself. Just give it a try and see how it works. Make sure to check the condition of the fuses on the battery block, there are four or them. Look for any obvious signs like decolorization etc. Those are some of the common causes of these types of issues.

Erdem
 

·
Registered
Joined
·
2,358 Posts
Both "N" Mode and no auto stop/start are by default there because of the CEL on. More probably, there is no reason for the CEL and almost for sure, at 2,100 miles, your Electronic Throttle Control needs no service at all. So, turn off and on the engine 4 or 5 times in a row. That will clear the CEL and you will have your RDNA back as well as the stop/start available. Forget about all this and continue enjoying your extraordinary and exclusive QV.
 

·
Registered
2018 Giulia QV
Joined
·
80 Posts
You need to read the codes to see what is really going on. I had this error and it end up being a loose connection to the diverter valve. The error would happen randomly when letting off the gas. Go away after several restarts. The code was "P00C0-00 Turbo vacuum valve" .
 

·
Registered
Joined
·
386 Posts
ok...joining the club of gremlins in the quad.......out of the blue today engine light came on with message .....service electronic throttle control...
dealer cant get to it for a few days...
same as some others...mode knob is disabled so stuck in normal mode.
only has 2100 miles...2021 quad....kinda disappointed.....esp after the brake recall experience with dealer.
ah well....hopefully this is an isolated deal...
The guy in the video works at a dealership, he says they do this with every new Alfa that comes in and almost all of them have corrosion off the truck, after doing the cleaning they pretty much stopped most of these kind of problems on new vehicles.
 

·
Registered
Joined
·
415 Posts
I agree with others here.

Go to a store and buy a basic code reader and see what it says. Then reset it if its not major. 99% chance you are fine and the car just had a electrical hiccup or something.

Also ensure you are driving it in at least Dynamic mode and giving it a good couple pulls to keep her breathing. If you used it as a 505HP grocery getter and drive in A/N mode all the time you are going to have a bad time in my OPINION.
 

·
Administrator
2018 Giulia Ti Sport Q4
Joined
·
4,215 Posts
Check all of the electrical connectors on the front of the motor. If you're inclined remove them carefully and reseat them.
I would also check the actual battery terminals. Make sure they're clamped down well.
 
  • Like
Reactions: The_Dude

·
Registered
Joined
·
21 Posts
Discussion Starter · #13 ·
thx for all of your suggestions….really appreciate it…..i have an appointment at the dealer this thursday but i will try all of your suggestions in hopes of cancelling the appt.
battery is fully charged…i will ck voltage with it running…..
i will for sure post back with results…..
 

·
Registered
Joined
·
833 Posts
I agree with others here.

Go to a store and buy a basic code reader and see what it says. Then reset it if its not major. 99% chance you are fine and the car just had a electrical hiccup or something.

Also ensure you are driving it in at least Dynamic mode and giving it a good couple pulls to keep her breathing. If you used it as a 505HP grocery getter and drive in A/N mode all the time you are going to have a bad time in my OPINION.
I typically drive my QV in N mode, and have no issues but then I drive it 70 Miles a day in mixed conditions. D mode is jerky and R mode is ideal but not practical as I like the idea of traction control keeping me out of trouble if I goose it too hard. I agree you do need to drive it hard from time to time safely to keep her breathing well. My remedy is to take to the track and drive the crap out of it.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #15 ·
The guy in the video works at a dealership, he says they do this with every new Alfa that comes in and almost all of them have corrosion off the truck, after doing the cleaning they pretty much stopped most of these kind of problems on new vehicles.
funny…….john is the sales manager for fiat…alfa at benson dodge ,it’s who i bought my car from…i’m going to check terminals but i’m sure he did my car.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #16 ·
I typically drive my QV in N mode, and have no issues but then I drive it 70 Miles a day in mixed conditions. D mode is jerky and R mode is ideal but not practical as I like the idea of traction control keeping me out of trouble if I goose it too hard. I agree you do need to drive it hard from time to time safely to keep her breathing well. My remedy is to take to the track and drive the crap out of it.
mine get driven hard….on occasion…i don’t use eco mode at all……mostly d and n….i was just at tail of the dragon and drove the snot out of it. awesome car.
 

·
Registered
Joined
·
44 Posts
happened to me two days ago and I just couldn’t figure out why since everything worked fine before; until I saw some forum members mention that driving with two feet could cause it & I remembered I might have done it on accident by pressing the brake and throttle together at some point or maybe not but either way, I have the EC tuner that allows diagnosis & clears DTC codes and that fixed it for me. no issue since.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #18 ·
ok…for anyone interested……i did all of the procedures you folks said……no dice……
got a bunch of codes and they all cleared except……the one…….it doesn’t say elec throttle control anymore…..now it just says service engine…with the engine icon lit…..so i guess it’s off to the dealer on thursday…
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #19 ·
happened to me two days ago and I just couldn’t figure out why since everything worked fine before; until I saw some forum members mention that driving with two feet could cause it & I remembered I might have done it on accident by pressing the brake and throttle together at some point or maybe not but either way, I have the EC tuner that allows diagnosis & clears DTC codes and that fixed it for me. no issue since.
what is an ec tuner?
 

·
Registered
2020 Giulia Quattroformaggio, 2020 Stelvio TI Sport
Joined
·
932 Posts
I agree with others here.

Go to a store and buy a basic code reader and see what it says. Then reset it if its not major. 99% chance you are fine and the car just had a electrical hiccup or something.

Also ensure you are driving it in at least Dynamic mode and giving it a good couple pulls to keep her breathing. If you used it as a 505HP grocery getter and drive in A/N mode all the time you are going to have a bad time in my OPINION.
I hear this a lot, but I don't think it's an issue. I commute in my now second QF in A mode, have thousands of miles now of driving in A mode. Car has had zero issues. Neither did my last one. Neither does my wife's Stelvio that is only in D mode when I drive it once a month. Going on 4 years of daily driving Giorgio's without issues. Am I the lucky one? Don't think so. In my opinion and based on my experience, A/N are not there to break your car...
 
1 - 20 of 29 Posts
Top