Alfa Romeo Giulia Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
226 Posts
Discussion Starter · #1 ·
Hey All, appreciate your input.. My Ti Sport has 3500 miles on it.. First 2k I had a few stalls after fueling up, and the oil temp was running 1 above middle (5 bars total). At 2k took it in for an oil change and software update; no more stalls and oil temp went down to 4 bars.....until last week.

Since then it's back up to 5 bars - one above mid point. Took it in to the dealer today to have them check it and give the Nav and Infotainment upgrade. Service rep said, to quote, " this is normal, it's not the oil temp, it's the coolant temp, and the car will notify you if it's running hot.."

So two concerns: 1) service rep calling this a coolant gauge, and 2) no one else seems to be running above mid point, after the above mentioned software update.

I set up the appointment via Alfa Premium care, so I expect a follow up call from them tomorrow (that's how they handled the follow up with my software upgrade at 2k miles). I will mention my concerns but curious if anyone else is running at 5 bars. By the way outside temp is in the 60s and low 70s so that isn't an issue. And gauge goes to this level after about 8-10 minutes of operation.

Thanks for any insights,

Bruce
 

Attachments

·
Registered
Joined
·
2,988 Posts
We were driving around yesterday in our Ti. It was hot outside and the car dash said 100 F. We were stuck in bad traffic barely moving with the AC on. The oil temp showed 5 bars. When we were able to get up to speed, the gauge eventually dropped to 4 bars.

Next month the air temp will climb to 110. August sometime hits 120. Fortunately, we live in the cool near the ocean. We will be 90 when they are 110. Most likely I'll need to go visit the hot-house.
 

·
Registered
Joined
·
112 Posts
In about 2k miles, after warm-up, my Ti has been consistently at 5 bars - and it doesn't fluctuate based on temperature (~50 to ~100*F) or driving style. I contacted my dealer service department after reading about new service updates and a 4-bar standard that indicated it's completion. After running my VIN, the dealer states that my car is totally up-to-date. I suppose at this point, I can do nothing but assume the 5-bar standard is normal and inconsequential.
 

·
Registered
2020 Alfa Romeo Giulia Sport Ti AWD
Joined
·
7,463 Posts
I suppose I should be watching my car's temperature gauge more closely. It seems to live in the middle, maybe +1.
 

·
Registered
Joined
·
787 Posts
Hey All, appreciate your input.. My Ti Sport has 3500 miles on it.. First 2k I had a few stalls after fueling up, and the oil temp was running 1 above middle (5 bars total). At 2k took it in for an oil change and software update; no more stalls and oil temp went down to 4 bars.....until last week.

Since then it's back up to 5 bars - one above mid point. Took it in to the dealer today to have them check it and give the Nav and Infotainment upgrade. Service rep said, to quote, " this is normal, it's not the oil temp, it's the coolant temp, and the car will notify you if it's running hot.."

So two concerns: 1) service rep calling this a coolant gauge, and 2) no one else seems to be running above mid point, after the above mentioned software update.

I set up the appointment via Alfa Premium care, so I expect a follow up call from them tomorrow (that's how they handled the follow up with my software upgrade at 2k miles). I will mention my concerns but curious if anyone else is running at 5 bars. By the way outside temp is in the 60s and low 70s so that isn't an issue. And gauge goes to this level after about 8-10 minutes of operation.

Thanks for any insights,

Bruce
I had the engine software update, so far 4 bars, how did you get them to do a software upgrade to nav/infotainment? I asked about it a few days ago and was told no such upgrade.
 

·
Registered
Joined
·
343 Posts
I've been driving in what has been record breaking heat here in the southwest. It's often above 115-degrees while I'm out on the road. temp gauge has not gone above halfway at all, not even in stop and go surface street driving which is most of my day. And the A/C has also been doing a good job...I've shut of the auto and just use it with the fan instead. Set it on LO and crank the fan on full blast and it keeps the inside cool - more so than if it is set on LO in Auto mode. I also leave it parked with the sunroof vent open (although to do so, the shade must be open so the sun does shine down in to the car)
 

·
Registered
Joined
·
94 Posts
Quadrifoglio here. Mine runs 1 bar above middle once warmed up. It's at the dealer right now getting the amp replaced and an update done. We will see what it runs at after that. Speaking of the new amp, they can't seem to get it to work. They've had it for 11 days now. They keep telling me it's an update issue with their software. Makes me wounder if every dealer is getting the same updates...? Hence why some people get results and some don't.
 

·
Registered
Joined
·
372 Posts
I also have 5 bars - consistently. There is a software update that can be done per another member on here, as I was worried about this as well - see thread below... (You can see my original posted question if you go back to page 2 from the link)...

I currently have about 400 miles on the car, only 1 week old so was concerned as well. I'll be going in on Monday and will ask the dealership about the software update. On a side note, on our other car, the temperature is an analog gage (vs digital bar), and it's also consistently slightly above the halfway mark, so I think this should be fine.

http://www.giuliaforums.com/forum/7...ems/11193-total-engine-shutdown-survey-3.html
 

·
Registered
Joined
·
226 Posts
Discussion Starter · #9 ·
I had the engine software update, so far 4 bars, how did you get them to do a software upgrade to nav/infotainment? I asked about it a few days ago and was told no such upgrade.
RiParke: I didn't ask for the Nav/info upgrade - the dealer just did it...It took 90 minutes.. The infotainment menus are slightly different and a bit more robust than before. Haven't driven enough to see how the Nav has changed.
 

·
Registered
Joined
·
226 Posts
Discussion Starter · #10 ·
I also have 5 bars - consistently. There is a software update that can be done per another member on here, as I was worried about this as well - see thread below... (You can see my original posted question if you go back to page 2 from the link)...

I currently have about 400 miles on the car, only 1 week old so was concerned as well. I'll be going in on Monday and will ask the dealership about the software update. On a side note, on our other car, the temperature is an analog gage (vs digital bar), and it's also consistently slightly above the halfway mark, so I think this should be fine.

http://www.giuliaforums.com/forum/7...ems/11193-total-engine-shutdown-survey-3.html
Chicago: I also had the update done you reference.. It was done 6 weeks and 1500 miles ago and took the oil temp gauge down from 5 bars to 4... It stayed at 4 until a couple of days ago and now back up at 5.

I just get a little wary when the service manager tells me it's a coolant gauge and not an oil temp gauge. Either he's wrong or the owner's manual is wrong.
 

·
Registered
Joined
·
157 Posts
I had the engine software update, so far 4 bars, how did you get them to do a software upgrade to nav/infotainment? I asked about it a few days ago and was told no such upgrade.
RiParke: I didn't ask for the Nav/info upgrade - the dealer just did it...It took 90 minutes.. The infotainment menus are slightly different and a bit more robust than before. Haven't driven enough to see how the Nav has changed.
Would love to see a pic of the nav menus after the update.
 

·
Registered
Joined
·
14 Posts
I got one of the first Giulia's in Houston and am about to crack 9K miles. I've had oil change and software updates done and I have also been at 5 bars the entire time. I've had no issues with stalling, start/stop or any of the other gremlins reported on this forum, I guess i'm one of the lucky ones? All I've gotten are front row valet parking spots and lots of people stopping and staring at her constantly!!
 
1 - 13 of 13 Posts
Top