Alfa Romeo Giulia Forum banner

481 - 495 of 495 Posts

·
Registered
Joined
·
242 Posts
Well...I installed the RDNA selector and of course failed on the DTCM proxi. I have version 0401, so I'll need to get it updated. Oh well, going to dealer in a couple weeks to get a new radio and display installed, I'll get them to do it then. 2017 Q4 with 06/17 build date.
 

·
Registered
Joined
·
175 Posts
The proxi issue (for me at least) resulted in from the rear parking sensor picking up my garage wall. You can also get it if the garage is uneven. Try clearing things out of the way or moving the car.
 

·
Premium Member
Joined
·
495 Posts
I have previously bricked my car trying to do the proxy alignment and needed it to be completely reset by the dealer. Want to try this mod and have installed the switch. If the proxy alignment goes wrong, is there any way to salvage things so the car will run? Seems like it has failed for a few people. Have you all had to have the car towed?

THanks
 

·
Super Moderator
2018 Giulia Ti Sport Q4
Joined
·
3,241 Posts
Discussion Starter #484
I haven't heard of anyone getting into that situation. You can always get it back to stock config, as far as I know.
 
  • Like
Reactions: Alfissimo and Drew

·
Registered
Joined
·
242 Posts
I haven't heard of anyone getting into that situation. You can always get it back to stock config, as far as I know.
This happened to me the other week. I need my DTCM updated. I was able to go back to stock without issue.
 

·
Registered
Joined
·
248 Posts
I have previously bricked my car trying to do the proxy alignment and needed it to be completely reset by the dealer. Want to try this mod and have installed the switch. If the proxy alignment goes wrong, is there any way to salvage things so the car will run? Seems like it has failed for a few people. Have you all had to have the car towed?

THanks
I would copy the entire stock procsi table to notepad and save it as a backup. If you can only flash some of the modules and can't get others to flash you could have a mismatch, which you could just undo by reflashing the stock table to the modules you could get to in the first place.
 

·
Registered
Joined
·
6,435 Posts
I would copy the entire stock procsi table to notepad and save it as a backup. If you can only flash some of the modules and can't get others to flash you could have a mismatch, which you could just undo by reflashing the stock table to the modules you could get to in the first place.
MES saves the proxi for you. You just have to fish around a bit.

Don't forget to calibrate the ABS! If you do forget your car will be bricked until you remember (or somebody reminds you of the necessity). This applies to both applying race mod and removing race mod. Been there, done that...
 
  • Like
Reactions: Beta Romeo

·
Registered
Joined
·
380 Posts
I have previously bricked my car trying to do the proxy alignment and needed it to be completely reset by the dealer. Want to try this mod and have installed the switch. If the proxy alignment goes wrong, is there any way to salvage things so the car will run? Seems like it has failed for a few people. Have you all had to have the car towed?
Done proxi many times without even properly completing it or intentionaly canceling it on some modules and never had any issues like bricking it. Of course there are some interesting settings which change engine or fuel type, car type etc. - never tried to change engine from petrol to diesel or vice versa so maybe with right and unlucky conditions it can be done.
The scariest you can get is BCM won't respond to diagnostic for couple of ignition on/off cycles.
 

·
Super Moderator
2018 Giulia Ti Sport Q4
Joined
·
3,241 Posts
Discussion Starter #489
I have previously bricked my car trying to do the proxy alignment and needed it to be completely reset by the dealer. Want to try this mod and have installed the switch. If the proxy alignment goes wrong, is there any way to salvage things so the car will run? Seems like it has failed for a few people. Have you all had to have the car towed?

THanks
Rumi, if it wasn't a pandemic, I'd invite you over so we could do it in my garage. I'm done PROXi alignments a ton of times, and the race mode mod a handful. no issues. Sometimes it does have issues completing, but I just try again and it usually works the second time.
 
  • Like
Reactions: 313speed

·
Premium Member
Joined
·
495 Posts
Ok. I'm going to give it a go this coming weekend. Can I get a phone number from you? I'll PM you
 

·
Registered
Joined
·
22 Posts
New to the alfa/giulia - why would i want to do this? Just - as someone ignorant to the benifits of the Race mode selector in my Ti.
 

·
Registered
Joined
·
6,435 Posts
New to the alfa/giulia - why would i want to do this? Just - as someone ignorant to the benifits of the Race mode selector in my Ti.
Start from the beginning of the thread.

Quick summary:
Get traction control disable with ABS enable.
Get more responsive manual shifts.
Get harder, more linear brake pedal response.
If you have performance pack, get harder suspension settings.

If you have no use for any of those things, don't bother with race mod.
 

·
Registered
Joined
·
1 Posts
Good morning, I modified my DNA selector installing the switch and the resistance. Unfortunately while I was assembling the selector I broke the little plastic cam of "A" switch. So I tried to weld an other switch instead of the old broken.

As result R is now working but A not. Do you know if for the A switch I need to weld all the four lead? The original one had all 4 welded.

thanks a lot
 

·
Premium Member
Joined
·
495 Posts
I did the same and after a few false starts appear to have the race mode working. Odometer flashes, but everything else seems good and all error codes cleared. Really interested to hear if this might be affecting power transfer to the front wheels, as I am most interested in this for winter driving: if you get stuck in deep snow traction control will get all wheels to stop spinning. SOmetimes you nned to just spin all wheels to rock the car out. wanted to make sure however that I am not just riving a rear wheel drive car now...
 

·
Premium Member
Joined
·
495 Posts
Hey everyone, I just installed the race button on my 2018 Giulia 2.0 Q4. Everything went smoothly except at the end of the proxy alignment the DTCM failed. After I finished everything I was left with the flashing odometer. I have type 2 and honestly the car feels faster than ever. Lots of people saying type 2 makes the engine resort to N in all modes. Its weird for me because the car feels way faster than my phase 2 so I'm kind of confused with it. It could be because traction control is off but I doubt it makes that big of a difference. The transmission is also much more aggressive and quick. So I'm kind of debating if I should request EC to put the phase 2 map in N mode. But back to the DTCM, I read the forums on it but I would really appreciate some more clarification on the update I need for it? Also would I even need to update it, I have a flashing odometer but everything else seems to be working fine including Race mode. After race mode I received a 5 sec 0-60 and a 13.4 1/4 mile. Its all honestly weird because now I'm thinking phase 2 worsened the performance of my car. I would really appreciate everyones opinion and advice.
sorry, above note form me was supposed to qute HassMB28

Having some trouble installing my RDNA. I have all necessary equimoment.
After installing and going through proxi and after clearing dash codes. My (D) shows 2 of the traction things before going into race. But after selecting race it will not work. . .
I then go do a burnout and the (D) no longer shows the 2 traction symbols... As if it clears them. What do i need?
 
481 - 495 of 495 Posts
Top