Alfa Romeo Giulia Forum banner
1 - 4 of 4 Posts

·
Premium Member
Joined
·
2,086 Posts
Discussion Starter · #1 ·
Hey all,

Took my Q4 with 18" wheels into the dealer yesterday as I was getting a knocking sound on full lock only cold or warm. Wanted to check if there was any rubbing/damage going on but got the green light and this attached service note. Was assured there's no rubbing going on.

Just an FYI if you're finding similar

Andy
 

Attachments

·
Registered
Joined
·
166 Posts
This happens on the F430 which has a similar front geometry. It's disconcerting the first time you back out of the driveway on a cold day, but it is normal.
 

·
Premium Member
Joined
·
2,086 Posts
Discussion Starter · #3 ·
This happens on the F430 which has a similar front geometry. It's disconcerting the first time you back out of the driveway on a cold day, but it is normal.
Good to know! Yeah I was convinced it was clipping the trim as it has the feeling of sticking on something
 

·
Registered
Joined
·
5,211 Posts
This happens on the F430 which has a similar front geometry. It's disconcerting the first time you back out of the driveway on a cold day, but it is normal.
^^^^^^^^
what he said..my QV does the same on first start-up when cold...once you drive it around and up to normal temp....it does not do it anymore...
first time I thought they left the transport blocks in the suspension:surprise:...got out checked around and nada.
the guys at Miller told me it was as we say in Italy "Normale":grin2:
 
1 - 4 of 4 Posts
Top