Alfa Romeo Giulia Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
The front parking sensors on my 2017 Giulia Ti AWD are ringing intermittently while I am driving, for no apparent reason. The indicator on the dash flashes the red warning on the screen thereby overriding the radio, etc. Dealer advised me to clean the sensors which I did but problem persists. Anyone with similar issues and remedy suggestions?
 

·
Registered
Joined
·
734 Posts
The OE front plate holder causes trouble if you have a front plate mounted. I trimmed maybe 2 - 3 mm off the bottom edge using a Dremmel and it got better.

Keeping them very clean is another helpful tip.

If very annoying just disable, the button is above the start stop disable button to the left of steering wheel.
 

·
Registered
2019 Rosso Competizione Stelvio Ti Sport Nero Edizione
Joined
·
651 Posts
Agree with both of the comments above. I had the unfortunate experience of having this problem on my drive home from the dealer after picking it up.
It turned out to be the license plate frame that had a bottom lip slightly overhanging.
The dealer sent a tech to my house with his tool kit and a new, smaller frame to fix it for me so that I didn't have to bring the car back in for the repair. No problems since.
p.s. Just as an FYI, the front sensors absolutely hate going through drive-thrus. So prepare yourself for more beeping if you use drive-thru ATMs or enjoy fastfood.
 

·
Registered
Joined
·
402 Posts
If they can't or won't fix it, I'll save you the time of calling Alfa: ""We understand that this is not the answer you were hoping for and do wish we could provide you with a more positive response."
 

·
Vendor
Joined
·
1,328 Posts
The front parking sensors on my 2017 Giulia Ti AWD are ringing intermittently while I am driving, for no apparent reason. The indicator on the dash flashes the red warning on the screen thereby overriding the radio, etc. Dealer advised me to clean the sensors which I did but problem persists. Anyone with similar issues and remedy suggestions?
Hi kenalfa17,

We are sorry to hear that you have this concern with the front parking sensors on your Giulia. If this concern persists, we recommend returning to the dealer for a diagnosis. Please message us with your VIN and mileage for further assistance.

Darlene
Alfa Romeo Care Specialist
 

·
Registered
Joined
·
3 Posts
My Giulia front sensor bracket broke. The one in the grill. I did not hit anything and nothing hit the car. The bracket simply broke. The dealer is telling me this is not covered under warranty and I only have 19k on car. This is ridiculously because this is obviously a manufacturing defect.
This is making it a joy to drive having the sensor go off all of the time
 

·
Vendor
Joined
·
1,328 Posts
My Giulia front sensor bracket broke. The one in the grill. I did not hit anything and nothing hit the car. The bracket simply broke. The dealer is telling me this is not covered under warranty and I only have 19k on car. This is ridiculously because this is obviously a manufacturing defect.
This is making it a joy to drive having the sensor go off all of the time
Hi Chuck0065,

I just responded to your post on the thread you made, but wanted to touch base with you here as well. Please take a moment to review my post on your thread when you can, hope to hear from you soon.

Mark
Alfa Romeo Social Care Specialist
 

·
Registered
Joined
·
2 Posts
Hav
The front parking sensors on my 2017 Giulia Ti AWD are ringing intermittently while I am driving, for no apparent reason. The indicator on the dash flashes the red warning on the screen thereby overriding the radio, etc. Dealer advised me to clean the sensors which I did but problem persists. Anyone with similar issues and remedy suggestions?
Having the same problem on my 2019 Giulia Ti but I do not have a front plate and nothing is obstructing my front sensor. When this happens my info system goes hey wire and nothing is functional in my dash instrument.
 

·
Vendor
Joined
·
1,328 Posts
Hav

Having the same problem on my 2019 Giulia Ti but I do not have a front plate and nothing is obstructing my front sensor. When this happens my info system goes hey wire and nothing is functional in my dash instrument.
Hello edH,
I just responded to your most recent message on the other thread, but wanted to touch base with you here as well. Please take a moment to review our message when you can. Hope to hear from you soon.
Laura
AlfaRomeoCares
 

·
Registered
Joined
·
63 Posts
The OE front plate holder causes trouble if you have a front plate mounted. I trimmed maybe 2 - 3 mm off the bottom edge using a Dremmel and it got better.

Keeping them very clean is another helpful tip.

If very annoying just disable, the button is above the start stop disable button to the left of steering wheel.
The front parking sensors on my 2017 Giulia Ti AWD are ringing intermittently while I am driving, for no apparent reason. The indicator on the dash flashes the red warning on the screen thereby overriding the radio, etc. Dealer advised me to clean the sensors which I did but problem persists. Anyone with similar issues and remedy suggestions?
if the dealer told you to clean it then get a can of DW-40 spray on the sensor and wipe off with a cloth do this on all the sensors because moisture is inside the sensor and the DW-40 will isolate the moistures or little dirt that may be in there and don't wash you car ever with water spray jet at car wash.Good luck
 
1 - 13 of 13 Posts
Top