Alfa Romeo Giulia Forum banner
1 - 20 of 26 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
Hey everyone-- long time BMW lover that made the jump to the Giulia. I've been test driving cars for the last two months and just kept coming back to the Giulia. She's such a blast to drive and so **** beautiful that I was forced to overlook the first year production run and Italian reliability risks.

My first 24 hours with her sums that up perfectly. After a little over 300 miles of driving, I got my first warning light-- Auto Start/Stop system failure. Fortunately, I had so much fun tearing up the back road twisties laying down that 300 miles, that I just don't care. My early opinion is that the car is worth enduring the little hiccups that you should expect if you're going to jump on a first year production Italian car.

On a positive note, the dealership I bought the car from is primarily a Maserati dealership and doesn't have any Alfa loaners-- so they said I'll get a Maserati loaner for any warranty service. I'll take it!

Glad to be here. Looking forward to soaking up the knowledge and experience from the group.
 
  • Like
Reactions: lowlight

·
Registered
Joined
·
1,807 Posts
Trust me....the Maserati will be a downgrade....I own a 17 Quad and a 17 Ghibli S....the Ghibli (although it sounds great in Sport Mode) is heavy and lumbering.....just nowhere near as fun.....D
 
  • Like
Reactions: lowlight and mc3456

·
Registered
Joined
·
443 Posts
Just want to ensure you saw this video before you take it in.

There are certain conditions when stop/start won't activate and will show disabled in the cluster.

Example:
engine not at operating temp
brake pedal not pressed with sufficient pressure
high blower speed


That said I've just gotten in the habit of disabling it completely as part of my routine.

 

·
Registered
Joined
·
18 Posts
Discussion Starter · #4 ·
Just want to ensure you saw this video before you take it in.

There are certain conditions when stop/start won't activate and will show disabled in the cluster.

Example:
engine not at operating temp
brake pedal not pressed with sufficient pressure
high blower speed


That said I've just gotten in the habit of disabling it completely as part of my routine.

https://www.youtube.com/watch?v=_vG_mTJ574s
Good info-- thanks. I have the system failure icon they referenced in the video. Hoping it self-resolves after a few more engine startups. If not, I'll make the call on Tuesday.
 

·
Banned
Joined
·
264 Posts
Just want to ensure you saw this video before you take it in.

There are certain conditions when stop/start won't activate and will show disabled in the cluster.

Example:
engine not at operating temp
brake pedal not pressed with sufficient pressure
high blower speed


That said I've just gotten in the habit of disabling it completely as part of my routine.

https://www.youtube.com/watch?v=_vG_mTJ574s
none of those conditions would cause a failure to be displayed in the cluster...
 

·
Banned
Joined
·
264 Posts
It would show stop/start disabled icon as shown in the video, and I've experienced this myself. The service failure is different. I've seen a few threads on this so wanted to call it out.
Right the "failure" is different...that would not come on as a result of any of those scenarios...
 

·
Banned
Joined
·
264 Posts
I guess it's important to get the last word on this? No where did I say a failure is caused by any of those scenarios. I specifically said disabled...and it's important people are aware there is a difference.
You suggested it as a solution prior to taking the car in...you know this is a known issue...you also read the description by the OP...not sure why you would suggest it other than try and downplay problems with this car...and yes, if you keep misrepresenting what you said, I will make sure and get the last word in to bring truth to light.
 

·
Registered
Joined
·
91 Posts
Doesn't this happen when you press the brake and the throttle at the same time?
 

·
Registered
Joined
·
443 Posts
You suggested it as a solution prior to taking the car in...you know this is a known issue...you also read the description by the OP...not sure why you would suggest it other than try and downplay problems with this car...and yes, if you keep misrepresenting what you said, I will make sure and get the last word in to bring truth to light.
Let me correct you on what I know and don't know then.


I suggested to check out the video before taking the car in. It may not be apparent to most that stop/start may disable itself for an unknown reason.

Some people may perceive disable and failure as the same thing. They aren't and that's also called out in the video I shared above.

I know this a known issue? Not sure where you got that from.

What truth are you bringing to light?

Good luck man. You won't be seeing another response to whatever nonsense you reply with.
 

·
Banned
Joined
·
264 Posts
Let me correct you on what I know and don't know then.


I suggested to check out the video before taking the car in. It may not be apparent to most that stop/start may disable itself for an unknown reason.

Some people may perceive disable and failure as the same thing. They aren't and that's also called out in the video I shared above.

I know this a known issue? Not sure where you got that from.

What truth are you bringing to light?

Good luck man. You won't be seeing another response to whatever nonsense you reply with.
Right, so he interpreted a start stop icon in yell to mean failure rather than disable?? Why then not ask what the exact message on the console? He clearly said failure...please..Just admit that you either made a mistake or tried to downplay the issue.
 

·
Registered
Joined
·
1,807 Posts
Right, so he interpreted a start stop icon in yell to mean failure rather than disable?? Why then not ask what the exact message on the console? He clearly said failure...please..Just admit that you either made a mistake or tried to downplay the issue.
Which Giulia do you own ? I don't think an error message gets displayed....at least not on the Quad...I think the Yellow Icon is the only sign there is....
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #14 ·
Which Giulia do you own ? I don't think an error message gets displayed....at least not on the Quad...I think the Yellow Icon is the only sign there is....
Base Giulia Q4.

This is what I get:



It's not on when I start the car, but within the first minute of driving, it displays. Once you hit the button on the stalk to clear the message, the smaller yellow icon on the odometer line remains.
 

·
Registered
Joined
·
1,807 Posts
Base Giulia Q4.

This is what I get:



It's not on when I start the car, but within the first minute of driving, it displays. Once you hit the button on the stalk to clear the message, the smaller yellow icon on the odometer line remains.

If you ask me...that's not a fault....THAT'S A BLESSING !!!!
 

·
Registered
Joined
·
296 Posts
I had that issue on my QV - opening and closing the hood fixed it.
BOTH sides have to latch or you may get that error.
 
  • Like
Reactions: kayger12

·
Registered
'17 Ti Sport Q4 w/ Active Shocks & LSD
Joined
·
815 Posts
thanks for participating in this forum-possible holy Grail of failures

... not actually trying to be humorous, but unintentionally this may be a chuckle.


I know people on this forum that would kill for that failure, since they hate the auto stop/start feature.

I suggest, love the **** out of driving this car and have them clear it when you take it in for the first service. I'm absolutely nuts about this car. It's thrown a couple of CELs in the first 500 miles, but it's been totally worth it. The Giulia has been a tantalizing and exhilarating driving experience for every mile I've been behind the wheel!!:D

Haven't had a warning light in the last 5000 miles. This car has been absolute perfection since the infotainment upgrade.
 

·
Registered
'17 Ti Sport Q4 w/ Active Shocks & LSD
Joined
·
815 Posts
Alfaholico, for one might trade you

:grin2:
... not actually trying to be humorous, but unintentionally this may be a chuckle.


I know people on this forum that would kill for that failure, since they hate the auto stop/start feature.

I suggest, love the **** out of driving this car and have them clear it when you take it in for the first service. I'm absolutely nuts about this car. It's thrown a couple of CELs in the first 500 miles, but it's been totally worth it. The Giulia has been a tantalizing and exhilarating driving experience for every mile I've been behind the wheel!!:D

Haven't had a warning light in the last 5000 miles. This car has been absolute perfection since the infotainment upgrade.
 

·
Registered
Joined
·
646 Posts
Trust me....the Maserati will be a downgrade....I own a 17 Quad and a 17 Ghibli S....the Ghibli (although it sounds great in Sport Mode) is heavy and lumbering.....just nowhere near as fun.....D
LOL, I have same but '15Ghibli SQ4. I describe it with this sports analogy:

The Giulia Ti is like a Collegiate player from a top 5 Division I team.

The Ghibli is like a retired pro about 3 years out of the game.

And the QV is a 1st round draft pick.
 

·
Registered
Joined
·
3,602 Posts
Awsome, but let that Ghibli sing man. You got a Maser loaner like so many people wished for. Consider it a fat tenor with a gorgeous voice. :D
 
  • Like
Reactions: kayger12
1 - 20 of 26 Posts
Top