Alfa Romeo Giulia Forum banner
1 - 6 of 6 Posts

·
Registered
2018 Alfa Romeo Giulia TI Sport Q2
Joined
·
498 Posts
Discussion Starter · #1 · (Edited)
Here is what happened to me this morning.

I remote started the car, and after 30 seconds or so the engine turned off. I restart it inside the car (the remote would not let me restart), and although the car started just fine, the CEL came on with a notification that the auto start/stop was disabled.

Further more I noticed that the bluetooth connection to my phone was gone, the DNA switch was disabled, and that the gear gauge that I have set on the infotainment center (the gauges that appear while in fuel economy) didn't work.

I drove the car a few miles, stopped at a store, came back about 10 minutes, and the car started up just fine, no CEL, bluetooth was back on, DNA switch fine, etc.

I talked to someone at Alfa Care, and she mentioned this can come due to a battery issue when the outside temperature is very low. Now, it was about 35 degrees, but I doubt it is the battery. If this happens and every a CEL comes on, that cannot be right.

I am awaiting a call from the dealership to see if they have time to check it out. The car did get a software flash, which was the latest one released on 12/02

Anyone had similar issues? I figured it is software related.
 

·
Registered
Joined
·
1,307 Posts
I hope this response doesn't annoy you

But this sounds exactly like a post I would have seen 9 months ago on the earlier cars. There is an update that fixes this, I guess they might have forgotten to do that one? I am not the most knowledgeable when it comes to what dealers do, or how they do the updates, that being said
 

·
Registered
2018 Alfa Romeo Giulia TI Sport Q2
Joined
·
498 Posts
Discussion Starter · #3 ·
I hope this response doesn't annoy you

But this sounds exactly like a post I would have seen 9 months ago on the earlier cars. There is an update that fixes this, I guess they might have forgotten to do that one? I am not the most knowledgeable when it comes to what dealers do, or how they do the updates, that being said
No annoyance at all. My car was built in April, which is not really early, but still had some possibilities of issues (aka heater box). Awaiting a call from the dealership to bring it in (again) and maybe they can re-run the software flash. I just found it somewhat strange that they said it could be the battery, as that has happened with some, so they say.
 
  • Like
Reactions: Max

·
Registered
Joined
·
1,307 Posts
No annoyance at all. My car was built in April, which is not really early, but still had some possibilities of issues (aka heater box). Awaiting a call from the dealership to bring it in (again) and maybe they can re-run the software flash. I just found it somewhat strange that they said it could be the battery, as that has happened with some, so they say.
Best of luck. How many miles on the car? I have around 6k and mine was built in March, no software updates and no issues (knock on wood)
 

·
Registered
2018 Alfa Romeo Giulia TI Sport Q2
Joined
·
498 Posts
Discussion Starter · #5 ·
Best of luck. How many miles on the car? I have around 6k and mine was built in March, no software updates and no issues (knock on wood)
5,700 miles since August. Had a heater box replacement, but that was the only issue so far, beside today's issue
 
1 - 6 of 6 Posts
Top