Alfa Romeo Giulia Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Has anyone else had an issue with the center computer screen going blank This is the second electrical issue I have encountered The first was the stereo radio system just completely shut down It took a week at the dealership to fix I love to drive my Guilia ti but this worries me
 

·
Registered
Joined
·
1,820 Posts
Stereo radio system and center computer are basically the same thing.
Do you have pictures and more details of your Giulia?
 

·
Registered
Joined
·
4,345 Posts
Has anyone else had an issue with the center computer screen going blank This is the second electrical issue I have encountered The first was the stereo radio system just completely shut down It took a week at the dealership to fix I love to drive my Guilia ti but this worries me
What Infotainment s/w version do you have? This sounds like some of the conditions that update to the .055 level was supposed to address (for MY2017).

SYMPTOM/CONDITION:
Some customers may experience one or more of the following:
• Tweeter noise during audio streaming.
• Ipod Nano�� not recognized.
• Voice recognition does not work when setting an address in Spanish.
• Navigation takes too long to recover after losing satellite signal.
• Certain Android�� phones have reduced Bluetooth�� functionality.
Display is stuck on black screen.
• Display frozen on Alfa Romeo logo.

Radio intermittently reboots.
• Oil level displayed on the ETM is incorrect.
• Auto-play does not maintain “ON” status after the network goes to sleep.
• Park Assist Module (PAM) graphics stayed on screen even after dismissing via Rotary Pad.
• Loss of favorite contacts.
• Lane Departure menu option available in a vehicle without the lane departure warning option.
 

·
Vendor
Joined
·
1,328 Posts
Has anyone else had an issue with the center computer screen going blank This is the second electrical issue I have encountered The first was the stereo radio system just completely shut down It took a week at the dealership to fix I love to drive my Guilia ti but this worries me
Hello Csfelici,

We're sorry to hear you're experiencing these electrical concerns. Feel free to send us a direct message if you'd like to continue working with the dealership. We can get this over to a Case Specialist for further handling.

Jasmine
Alfa Romeo Social Care Specialist
 

·
Registered
Joined
·
9 Posts
I have a 2018 ti sport and unfortunately this happens to me about once a week. I brought it in once and they said my software was up to date. I’m going to try taking it back in, but it doesn’t seem like something a car dealer is going to fix, I’m guessing it will need Alfa to do a software update.
 

·
Registered
Joined
·
9 Posts
Mine will always eventually come back, but this is a very annoying issue. It’s really bad when I’m using apple maps for navigation and it crashes while giving directions.
 

·
Registered
Tipo 33 Stradale 1/18 scale
Joined
·
3,841 Posts
What Infotainment s/w version do you have? This sounds like some of the conditions that update to the .055 level was supposed to address (for MY2017).

SYMPTOM/CONDITION:
Some customers may experience one or more of the following:
• Tweeter noise during audio streaming.
• Ipod Nano�� not recognized.
• Voice recognition does not work when setting an address in Spanish.
• Navigation takes too long to recover after losing satellite signal.
• Certain Android�� phones have reduced Bluetooth�� functionality.
Display is stuck on black screen.
• Display frozen on Alfa Romeo logo.

Radio intermittently reboots.
• Oil level displayed on the ETM is incorrect.
• Auto-play does not maintain “ON” status after the network goes to sleep.
• Park Assist Module (PAM) graphics stayed on screen even after dismissing via Rotary Pad.
• Loss of favorite contacts.
• Lane Departure menu option available in a vehicle without the lane departure warning option.

i have .055 version on a 2016 build unit and i still lose phone favourites after the upgrade - am waiting for a new infotainment unit to roll back from .055 as it has introduced new bugs
 

·
Registered
Joined
·
6 Posts
My infotainment system and center screen just failed on my 2019 q4 base sport. Car has 238 mi. It’s a sad day, and I hope I don’t have to be without the car for to long when I bring it in, in a week for the appointment, because it is such a wonderful car to drive. Also this issue is causing the dtc’s to be unreadable when the dealer plugs into the OBD2 port.
 
1 - 10 of 10 Posts
Top