Alfa Romeo Giulia Forum banner

1 - 7 of 7 Posts

·
Premium Member
Joined
·
488 Posts
Discussion Starter #1
Wanted to get my DTCM module updated from ...04.01. To ...05.01 to be able to activate race mode. My dealer tells me that if it's not a listed update they can't do it and for my VIN ...04.01 is the current update. Any one know of any options to get this update done?
 

·
Registered
Joined
·
513 Posts
Unfortunately the only way that may work is to get a tech authority sub (crazy pricy, but you could buy a day or week long sub) and wi tech module.

alternativly you could try purchasing a new module via the dealer parts department. Theoretically, a new module should come with the latest software.

be cautioned though. Getting features in these cars to work can really be a bear. Ie: once you do get your software updated that module may not work with other modules in your car. Or maybe you need an ETM updated to take advantage of the new features.

it’s really is an uphill battle. And everything I’ve said to this point is applicable to 2017 - 2019 models. I’ve heard 2020 and later have “over the air updates” though I have heard nothing about if those owners are seeing updates introduce new features or not.
 

·
Registered
Joined
·
240 Posts
Man. I have a 2017 as well...I was planning on getting this done too. Has anyone here done the update on a 2017?
 

·
Premium Member
Joined
·
488 Posts
Discussion Starter #4
Hey - just used MES 4.7 and able to do the race mode and have it function! the odometer is still flashing, ut at least it works. Not sure if there are any issues with the flashing odometer as a harbinger of some underlying problem, but the car seems to run just fine.
 

·
Registered
Joined
·
1,579 Posts
Hey - just used MES 4.7 and able to do the race mode and have it function! the odometer is still flashing, ut at least it works. Not sure if there are any issues with the flashing odometer as a harbinger of some underlying problem, but the car seems to run just fine.
The flashing odometer means the car needs a proxy alignment....what that means is one of the modules is not properly configured..
 

·
Registered
Joined
·
379 Posts
...and that module is most likely DTCM :D
You were able to do proxi on Q4 after retrofiting Race knob even with previous MES versions - it just failed on DTCM and you had blinking odo
 

·
Premium Member
Joined
·
488 Posts
Discussion Starter #7
Actually this is the first time I got to where the car starts and runs. Beefier this thing crashed so bad I had to give up. In repeat retrospect it may have been that my car battery wasn't charged enough. Shpuncik, you suggested that to me when it would not recognize the steering position-thanks! This time did things with the car being constantly charged. Pretty excited about it. But did the DTCM failure mean its running as a rear wheel drive car? Not what I was aiming for.
 
1 - 7 of 7 Posts
Top