Alfa Romeo Giulia Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hi all,

Still loving my Giulia Ti Sport more and more every day. It’s got most options installed that were available in 2018, except for the Driver Assistance Package. The only feature from that package I feel I would like is the blind spot monitoring system. Is it possible to have that installed post purchase, or is it a factory installed option only?
 

·
Registered
Joined
·
877 Posts
Most likely it's possible to retrofit but you'll need to use new blind spot radar sensors - can't reuse from another car. Then you'll need either side view mirror left/right glass or whole mirrors, re-do wiring and coding.
 

·
Registered
Joined
·
9 Posts
Most likely it's possible to retrofit but you'll need to use new blind spot radar sensors - can't reuse from another car. Then you'll need either side view mirror left/right glass or whole mirrors, re-do wiring and coding.
okay, and do I need any new sensor in rear bumper?
 

·
Registered
Joined
·
877 Posts
okay, and do I need any new sensor in rear bumper?
blind spot sensors are installed in rear bumper on left and right. you cannot use sensors from another car as they are VIN locked to car. need to buy new sensors.

maybe witech can unlock used sensors but that needs to be tested. also maybe you can change VIN inside eeprom. still needs to be tested.
 

·
Registered
Joined
·
5 Posts
blind spot sensors are installed in rear bumper on left and right. you cannot use sensors from another car as they are VIN locked to car. need to buy new sensors.

maybe witech can unlock used sensors but that needs to be tested. also maybe you can change VIN inside eeprom. still needs to be tested.
I'm in the same boat as well.
I have already collected everything for it. Radar sensors (of course used ones from another car), frames for the sensors inside the bumpers, wires, mirrors, etc.
I installed all components did the proxy alignment and it is really not working. Hopefully, only currently!
I have the following error after proxi with MES which cannot be deleted:

108795


With MES I can not change the car configuration.
AlfaOBD is maybe able to do it I will try it soon.
Of course it can also not bring the solution but according to an Italian alfa forum somebody was successful with the same project and based on the limited information he also worked with used radars.
(sorry it is in Italian, google translator can do the job):

Blind Corner - ClubAlfa.it Forum

I contacted the guy in PM and asked him to tell the trick how he did the configuration which diagnostic tool he used (MES, Alfaobd, or Witech).
(I assume it was finally Witech because he mentioned in his post a helpful and very prepared guy at AR who supported him.)
Unfortunately, no feedback from this guy at all for a long time...
 

·
Registered
Joined
·
9 Posts
I'm in the same boat as well.
I have already collected everything for it. Radar sensors (of course used ones from another car), frames for the sensors inside the bumpers, wires, mirrors, etc.
I installed all components did the proxy alignment and it is really not working. Hopefully, only currently!
I have the following error after proxi with MES which cannot be deleted:

View attachment 108795

With MES I can not change the car configuration.
AlfaOBD is maybe able to do it I will try it soon.
Of course it can also not bring the solution but according to an Italian alfa forum somebody was successful with the same project and based on the limited information he also worked with used radars.
(sorry it is in Italian, google translator can do the job):

Blind Corner - ClubAlfa.it Forum

I contacted the guy in PM and asked him to tell the trick how he did the configuration which diagnostic tool he used (MES, Alfaobd, or Witech).
(I assume it was finally Witech because he mentioned in his post a helpful and very prepared guy at AR who supported him.)
Unfortunately, no feedback from this guy at all for a long time...
if you finally do it - send me any message
 

·
Registered
Joined
·
9 Posts
if you finally do it - send me any message
I'm in the same boat as well.
I have already collected everything for it. Radar sensors (of course used ones from another car), frames for the sensors inside the bumpers, wires, mirrors, etc.
I installed all components did the proxy alignment and it is really not working. Hopefully, only currently!
I have the following error after proxi with MES which cannot be deleted:

View attachment 108795

With MES I can not change the car configuration.
AlfaOBD is maybe able to do it I will try it soon.
Of course it can also not bring the solution but according to an Italian alfa forum somebody was successful with the same project and based on the limited information he also worked with used radars.
(sorry it is in Italian, google translator can do the job):

Blind Corner - ClubAlfa.it Forum

I contacted the guy in PM and asked him to tell the trick how he did the configuration which diagnostic tool he used (MES, Alfaobd, or Witech).
(I assume it was finally Witech because he mentioned in his post a helpful and very prepared guy at AR who supported him.)
Unfortunately, no feedback from this guy at all for a long time...
Get luck!
 

·
Registered
Joined
·
7 Posts
Hi there,
I am doing a Q4 to Quad rear bumper conversion too. I have a donor quad bumper (on a stelvio) with sensors and harness still there, are you guys saying that i need to use my existing sensors because they are VIN locked?
Also, any way to clear these codes or does a dealer need to do it?
 
1 - 9 of 9 Posts
Top