Alfa Romeo Giulia Forum banner
1 - 5 of 5 Posts

·
Premium Member
Joined
·
621 Posts
Discussion Starter · #1 ·
Hey, guys.

Was doing some routine maintenance on my QV yesterday and this stood out to me for some reason vs all the other times I've had the air-box off.

These exposed, unwrapped wires...

Motor vehicle Hood Automotive tire Vehicle Automotive exterior


Normal or some sort of service repair/adjustment?

I bought this CPO 2017 QV January of this year.

Thanks.
 

·
Vendor
Joined
·
3,718 Posts
Looks about normal. Mine looks nothing like that though. Could have been repaired or anti friction tape missing. But I do notice the O2 sensor out of its clip. Blue wire sheath. Should be connected to the clip that is open.
 

·
Premium Member
Joined
·
621 Posts
Discussion Starter · #3 ·
Looks about normal. Mine looks nothing like that though. Could have been repaired or anti friction tape missing. But I do notice the O2 sensor out of its clip. Blue wire sheath. Should be connected to the clip that is open.
Ah. Good catch.

Thanks!

Perhaps this area has been messed with.
 

·
Vendor
Joined
·
3,718 Posts
Ah. Good catch.

Thanks!

Perhaps this area has been messed with.
Maybe or like I said, tape may have fallen off. I wonder if someone tuned it as all those wires including 02 sensor need to be moved out of the way.
 

·
Premium Member
Joined
·
621 Posts
Discussion Starter · #5 ·
Maybe or like I said, tape may have fallen off. I wonder if someone tuned it as all those wires including 02 sensor need to be moved out of the way.
....or if the ECU had to be replaced 🤷🏽‍♀️

Doesn't feel any different than my first QV, so I don't think it's tuned.
 
1 - 5 of 5 Posts
Top