Alfa Romeo Giulia Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I just bought a 2017 awd giulia ti. I have had the car for about a week, and the car only has about 500 miles on it. Yesterday, I just noticed a chirping noise that is coming from the front of the car. It only begins to start at about 5mph. As speed increases, so does the rate of the chirping sound. Once, I am going about 35mph the chirping becomes so fast that it just becomes a constant sound that blends in with the engine noise. The noise isn't that loud. I only noticed it when I was driving with my windows down and the radio off. If the windows are closed and either the ac is running or the radio, I can't hear the noise. I am probably going to take the car back to the dealership in a couple of days to see if they can figure out what is wrong. I was wondering if anyone has had the same problem or knew what was probably wrong
 

·
Vendor
Joined
·
1,334 Posts
I just bought a 2017 awd giulia ti. I have had the car for about a week, and the car only has about 500 miles on it. Yesterday, I just noticed a chirping noise that is coming from the front of the car. It only begins to start at about 5mph. As speed increases, so does the rate of the chirping sound. Once, I am going about 35mph the chirping becomes so fast that it just becomes a constant sound that blends in with the engine noise. The noise isn't that loud. I only noticed it when I was driving with my windows down and the radio off. If the windows are closed and either the ac is running or the radio, I can't hear the noise. I am probably going to take the car back to the dealership in a couple of days to see if they can figure out what is wrong. I was wondering if anyone has had the same problem or knew what was probably wrong
Hi tja114,

Please don't hesitate to send us a PM with your VIN for further assistance during your dealership appointment!

Andrea
Alfa Romeo Social Care Specialist
 
1 - 2 of 2 Posts
Top