Alfa Romeo Giulia Forum banner
1 - 20 of 46 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
I am new to this forum having just taken delivery of a US-spec 2018 Giulia Ti Sport AWD. So far the car's handling and performance are as expected, and I haven't noticed any fit, finish or NVH issues. My only (relatively minor) complaint relates to an apparent glitch with the multimedia settings, specifically:

1. The clock time display defaults to 24H, which I have changed to 12H display format. However, after a seemingly random number of ignition on/off cycles, the setting reverts to 24H display
2. The radio Auto On setting includes a 'Recall Last' option. The manual doesn't explain its functionality but I assume it is intended to leave the radio in the same on/off state on vehicle start-up, as it was in when the ignition was last shut off. However, the radio always turns on when I start up the vehicle, even if was off when the ignition was shut off.

I discussed these issues with the dealer and specifically asked: a) have other owners raised them; b) have they received any communication from FCA regarding these or similar issues; and, c) is my infotainment system updated to the latest software version (the version I have installed is MV-051.008.004 / TV-051.008.004). The dealer stated that they have not heard about these issues from other owners, they have not received any communication from FCA regarding them, and FCA has not yet issued any software updates for the 2018 cars. The dealer also suggested that I try using the second key fob to see if the issues persist - they do.

So my questions for the forum are similar:

1. Have others experienced these issues?
2. Can anyone authoritatively confirm that my infotainment system software (MV-051.008.004 / TV-051.008.004) is the latest version?

Thanks, in advance.
 

·
Registered
2017 Ti Q2
Joined
·
213 Posts
I am new to this forum having just taken delivery of a US-spec 2018 Giulia Ti Sport AWD. So far the car's handling and performance are as expected, and I haven't noticed any fit, finish or NVH issues. My only (relatively minor) complaint relates to an apparent glitch with the multimedia settings, specifically:

1. The clock time display defaults to 24H, which I have changed to 12H display format. However, after a seemingly random number of ignition on/off cycles, the setting reverts to 24H display
2. The radio Auto On setting includes a 'Recall Last' option. The manual doesn't explain its functionality but I assume it is intended to leave the radio in the same on/off state on vehicle start-up, as it was in when the ignition was last shut off. However, the radio always turns on when I start up the vehicle, even if was off when the ignition was shut off.
.
1) Yes, my 2017 Ti clock has the same issue.
2) No, I don't have your "Recall Last" issue.


I have other issues with the radio immediately after starting up the car:
a) On start up, sometimes it takes two attempts to turn the radio on.
b) On start up, if the last radio station was a Sirus-XM station , and proceeding to the previous/next station, the radio always selects station 1.
 
  • Like
Reactions: Bull

·
Vendor
Joined
·
1,341 Posts
I am new to this forum having just taken delivery of a US-spec 2018 Giulia Ti Sport AWD. So far the car's handling and performance are as expected, and I haven't noticed any fit, finish or NVH issues. My only (relatively minor) complaint relates to an apparent glitch with the multimedia settings, specifically:

1. The clock time display defaults to 24H, which I have changed to 12H display format. However, after a seemingly random number of ignition on/off cycles, the setting reverts to 24H display
2. The radio Auto On setting includes a 'Recall Last' option. The manual doesn't explain its functionality but I assume it is intended to leave the radio in the same on/off state on vehicle start-up, as it was in when the ignition was last shut off. However, the radio always turns on when I start up the vehicle, even if was off when the ignition was shut off.

I discussed these issues with the dealer and specifically asked: a) have other owners raised them; b) have they received any communication from FCA regarding these or similar issues; and, c) is my infotainment system updated to the latest software version (the version I have installed is MV-051.008.004 / TV-051.008.004). The dealer stated that they have not heard about these issues from other owners, they have not received any communication from FCA regarding them, and FCA has not yet issued any software updates for the 2018 cars. The dealer also suggested that I try using the second key fob to see if the issues persist - they do.

So my questions for the forum are similar:

1. Have others experienced these issues?
2. Can anyone authoritatively confirm that my infotainment system software (MV-051.008.004 / TV-051.008.004) is the latest version?

Thanks, in advance.
Hi absincog,

Sorry to hear about this! Please send us a PM with your VIN so I can send concern along to the brand for further review.

Andrea
Alfa Romeo Social Care Specialist
 

·
Registered
Joined
·
658 Posts
b) On start up, if the last radio station was a Sirus-XM station , and proceeding to the previous/next station, the radio always selects station 1.
Haven’t checked whether this is only XM related but when I start the Giulia I have noticed that it doesn’t highlight the current favorite station playing in red. So the first push of the previous or next buttons on the wheel takes me to favorite #1 like you describe . As a result I have been making more use of pulling back on the control wheel to show details of the favorites and scroll to what I want. But it would be nice if this startup behavior was fixed.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #5 ·
AlfaRomeoCares - I tried to PM you the VIN but since my post count is less than 10, I cannot. Is there another way to provide the VIN directly to you, with out posting it publicly on the forum? Thanks.
 

·
Registered
Joined
·
2,988 Posts
Welcome to the forum absincog :)
Congrats on the new Giulia :grin2:

Your other post/thread got stuck in moderation. I approved it then saw that it was a duplicate and deleted it.
You'll need ten (10) posts before you can send a PM or post a link. It helps keep the trolls at bay, but hurts the rest of us who have legitimate business to take care of.

I wish I had some guidance for you. I would have suggested the dealer, but you've done that. AlfaCare has responded, so that's a good thing.

I'm wondering if the info system has a bad connection and looses power causing it to revert to the default setting.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #7 ·
Thanks, Racer Z. I was able to send the VIN to AlfaCare via visitor message. I will suggest the power loss / reboot hypothesis to the dealer. I had actually read about that as a potential cause somewhere in my research, though I have not experienced the infotainment system losing power or rebooting while I am driving the car. Maybe it occurs when the ignition is shut off...
 

·
Registered
Joined
·
202 Posts
I am observing both the 24H clock behavior and the radio auto-on behavior on my vehicle.
Luckily neither one one the two is bothering me too much.
 

·
Registered
Joined
·
23 Posts
I've noticed that if I shut the car off while a SiriusXM station is playing, on the next start up, more times than not , an FM station is playing.

I also have to have the system relink to my phone on occasion. I have to say, I still don't have a real grasp of the system yet, so some of my issues could be operator error.

Nothing worth a special trip to the dealer, but I'll mention next time in.
 

·
Vendor
Joined
·
1,341 Posts
AlfaRomeoCares - I tried to PM you the VIN but since my post count is less than 10, I cannot. Is there another way to provide the VIN directly to you, with out posting it publicly on the forum? Thanks.
Hi absincog,

I will send you a PM with an email address where you can send your information to, feel free to delete the visitor message you sent us if you'd like.

Andrea
Alfa Romeo Social Care Specialist
 

·
Registered
Joined
·
33 Posts
GX, havent had the phone reconnect issue on my new 18 QV yet, but I've definitely noticed the XM to FM upon restart thing.

At least that much is consistent...
 
  • Like
Reactions: gxmech

·
Registered
Joined
·
33 Posts
Absincog - BTW, I can't quite confirm you have the latest, but in my MY2018 QV, I have the exact same revision. Should some sticky thread here keep track of that for us for easy reference? If there is, google and forum search is not picking it up.

MV-051.008.004 / TV-051.008.004

My readout above.
 

·
Registered
Joined
·
51 Posts
I've noticed that if I shut the car off while a SiriusXM station is playing, on the next start up, more times than not , an FM station is playing.

I also have to have the system relink to my phone on occasion. I have to say, I still don't have a real grasp of the system yet, so some of my issues could be operator error.

Nothing worth a special trip to the dealer, but I'll mention next time in.
I have the same issues. I have to reconnect my phone on occasion, also I have not figured out how to save the current station as what I want to tune into when I start the car. On occasion it randomly tunes to FM, and sometimes AM. I thought it might have something to do with the seat settings so I saved my seat with an XM radio station on but that really made no difference.
 

·
Registered
Joined
·
6 Posts
Hi having the same problems with my system. See photo for version of software. Also pArk sent and forward collision warning does not work properly. Also check engine light comes on intermittently. Auto start stop doesn’t work when the check engine light comes on. Had the car for about a month a week at the having the car went to the dealer supposedly fix the issues but that was no help. Into another deal out last Saturday however I don’t have an appointment to February 3. My VIN is as follows: ZARFAECN7J7565808. Myself phone number is 561-635-1114 and my email address is [email protected]. I gave all this information for the benefit of Aalfa Care. Tried calling the 800 number today was on hold for 45 minutes no luck . This message may be replete with grammatical errors because I am voice to texting I have no energy to physically text this message because of the frustration caused from of this car’s problems. Appreciate anyone’s help. also I looked under the center consul key fob section I do have a micro USB unplugged it’s black .
 

·
Vendor
Joined
·
1,341 Posts
Hi having the same problems with my system. See photo for version of software. Also pArk sent and forward collision warning does not work properly. Also check engine light comes on intermittently. Auto start stop doesn’t work when the check engine light comes on. Had the car for about a month a week at the having the car went to the dealer supposedly fix the issues but that was no help. Into another deal out last Saturday however I don’t have an appointment to February 3. My VIN is as follows: . Myself phone number is 561-635-1114 and my email address is [email protected]. I gave all this information for the benefit of Aalfa Care. Tried calling the 800 number today was on hold for 45 minutes no luck . This message may be replete with grammatical errors because I am voice to texting I have no energy to physically text this message because of the frustration caused from of this car’s problems. Appreciate anyone’s help. also I looked under the center consul key fob section I do have a micro USB unplugged it’s black .
Hi kcyesq,

Sorry to hear about your concerns with your vehicle! If you require further assistance during your service appointment please don't hesitate to send us a PM with your VIN and let me know.

Andrea
Alfa Romeo Social Care Specialist
 

·
Registered
Joined
·
6 Posts
My vin is in my post. And I tried pm you but I can’t because I’m a new member. Please contact me my information is in my first post thank you so much
 

·
Registered
Joined
·
19 Posts
My clock was always reverting back to 24h format as well. I turned off the GPS time function and it has stopped reverting back to 24h format.
I believe I have a June or July 2017 build date and am unaware of which software version im on. Hope this helps.
 

·
Registered
Joined
·
630 Posts
The glitch I experienced today when the radio was in XM band, the steering wheel Forward Seek and Back Seek buttons stopped working and the volume knob left/right seek function stopped working also. The seek buttons and knob work fine in AM or FM, but as soon as I get to XM they stop working. My only recourse is to use the Rotary Pad to select favorites one at a time. So annoying. I restarted the car and there was no change. This just started happening. It worked correctly yesterday.
 

·
Vendor
Joined
·
1,341 Posts
The glitch I experienced today when the radio was in XM band, the steering wheel Forward Seek and Back Seek buttons stopped working and the volume knob left/right seek function stopped working also. The seek buttons and knob work fine in AM or FM, but as soon as I get to XM they stop working. My only recourse is to use the Rotary Pad to select favorites one at a time. So annoying. I restarted the car and there was no change. This just started happening. It worked correctly yesterday.
Hi freedomgli,

Are you thinking you'd like to have your Alfa Romeo dealer take a look? Feel welcome to send us a direct message if we can be of assistance or answer any questions.

Jasmine
Alfa Romeo Social Care Specialist
 
  • Like
Reactions: Racer Z
1 - 20 of 46 Posts
Top