Alfa Romeo Giulia Forum banner
1 - 20 of 55 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Just picked up my ‘18 Giulia three days ago. Before I left the dealership, I paired my phone (iPhone 7) and was able to send/receive calls and play music over Bluetooth. Today, I left work to get lunch and Bluetooth media connected and played without issue. However, I get back in to return to work and find my phone unable to connect.

I went into the Bluetooth settings and tried to remove my phone, however it still remains under the devices. Also, the option to add a new Bluetooth connection is grey-ed out. I have shut the car on and off a few times and made no difference. Issue is not on my phone side, as it still connects to my Fitbit and wireless headphones just fine.

Has any one else had this happen and found a fix?
 

·
Registered
Joined
·
1,307 Posts
Turn off bluetooth on your phone and then turn it back on. Don't try and remove the phone from the car settings. One time it just wouldn't work for my daily commute in the morning but it came back in the afternoon.

It's an Alfa
 

·
Registered
Joined
·
35 Posts
The pairing process, including download of contacts, can take a very long time. It has taken more than a day for me before. You may need to allow the pairing process to finalize before you can delete the phone. At least this strategy has worked for me in the past.
 

·
Registered
Joined
·
51 Posts
This has happened to me on multiple occasions (2017 model, and iPhone 7), I just disconnect from Bluetooth in my phone settings. Then click on Alfa Connect again in Bluetooth settings and it's fine.
 

·
Registered
Joined
·
48 Posts
I too am seeing this issue. When it happens, I also notice that I do not have the option to add a new Bluetooth device either. I believe the issue is on the Car's OS side vs. the iPhone.

For what it's worth, I am still on iOS 11.1.1. I might try updating my iOS to see if it helps.
 

·
Registered
Joined
·
25 Posts
FWIW:
I've had a MY18 Ti since 4 Dec (I don't recall the actual manufacture date, bought it off the lot). I've not noticed any specific BT connectivity problems with my Android phone (Pixel 2)-- reconnects without problem each time in probably ~30 seconds, though I wish it would happen a just little faster.

If I got out of the car listening to media on my phone (or through my phone), when I start up again it seems the radio starts playing something else (a recent FM station?) for a little bit until the phone connection is re-established. Maybe that's what you're seeing?
 

·
Registered
Joined
·
48 Posts
FWIW:
I've had a MY18 Ti since 4 Dec (I don't recall the actual manufacture date, bought it off the lot). I've not noticed any specific BT connectivity problems with my Android phone (Pixel 2)-- reconnects without problem each time in probably ~30 seconds, though I wish it would happen a just little faster.

If I got out of the car listening to media on my phone (or through my phone), when I start up again it seems the radio starts playing something else (a recent FM station?) for a little bit until the phone connection is re-established. Maybe that's what you're seeing?
I wish that’s what I was seeing. My commute is 45 mins each way. Phone hasn’t connected nor has the media from my iPhone since Monday. It’s a widespread issue apparently.
 

·
Registered
Joined
·
48 Posts
Any luck getting this figured out? I'm having the same problem.
I dropped mine off at the dealership yesterday. The issue is intermittent but infuriating.

I have 2 different iPhones, both on different iOS versions. When Bluetooth stops working on one, I can't switch to the other. I tried connecting them individually (only 1 phone connected at a time) and the problem is still present. I have noticed that when the BT will not connect, the option to delete/forget the device is there, but it won't work, and the option to add a new device is not available (greyed out). Also, going into the device and attempting to reconnect audio or phone connection does not help.

I tried restoring each phone - no luck.

I tried turning off BT and turning back on - no luck.

I tried clearing all network settings - no luck.

What worries me the most is that they called me today and left me a VM saying they ordered a new glovebox and trunk button for me, but made no issue about the BT connectivity issue :(
 

·
Registered
2020 gulia
Joined
·
156 Posts
My car was delivered this morning.
I tried connecting my samsung phone and I'm having the same issue. When it says choose your device there's nothing there to choose I tried talking to the sales person who brought me the car he insists I'm doing something wrong. Obviously he hasn't read the forms which I'm about to send him a link to! So basically everyone is telling me we can't use our Bluetooth in our cars, great welcome to day one with my new car.?
 

·
Registered
2020 gulia
Joined
·
156 Posts
This morning when I got into the car I thought let's check and see if the Bluetooth is working and to my surprise it was. I was also able to read and send text messages that was a surprise to my sales guy since he said the updates for that would not be available across the board to do that until July. About 1% are able to now use that feature. Well of course I didn't hold my breath because by the time I was onto my second errand and started the car it stopped connecting. At least this time it recognizes my phone. I thought this is not going to end well. I contacted Alfa Romeo corporate hopefully I will get an answer which I will share here.
 

·
Registered
‘19 Giulia Ti Sport Q4
Joined
·
3,887 Posts
This morning when I got into the car I thought let's check and see if the Bluetooth is working and to my surprise it was. I was also able to read and send text messages that was a surprise to my sales guy since he said the updates for that would not be available across the board to do that until July. About 1% are able to now use that feature. Well of course I didn't hold my breath because by the time I was onto my second errand and started the car it stopped connecting. At least this time it recognizes my phone. I thought this is not going to end well. I contacted Alfa Romeo corporate hopefully I will get an answer which I will share here.
Were you sending text messages using the in-car system, or connecting and sending using Android Auto?

With my iPhone, I can receive text messages on the in-car Infotainment system, but I cannot send replies or new SMS messages through that system. However, if I'm plugged in and running Apple CarPlay, I can both receive and send SMS text messages, so that's why I'm wondering how you are sending them.

Thanks.
 

·
Registered
Joined
·
48 Posts
Update:

Dealer claimed they could not replicate the issue. They said they tried a few times on a few days and it connected each time. However, when I went to pickup my car, the only 2 bluetooth devices shown were my 2 phones, so it would appear as though they either didn't really try OR they removed their device after testing. I have a hard time believing the latter as both my devices would not connect, and neither could be deleted still. Sadly, I could not afford to spend more time at the dealer, so I told them I will be contacting Alfa USA.
 

·
Registered
2020 gulia
Joined
·
156 Posts
My connection has been random it's getting better but it's not consistent. My dad suggested it was on Italian time and maybe the connection was coming through from Italy? Which I thought was pretty clever for him since he's 87 years old. My sales guy is supposed to come get the car tomorrow and see about having the dealer run a diagnostic and try to figure out what the problem is. I know of course it'll work when the car gets to the dealer. The question becomes how are we supposed to pair it with my phone if I'm not there? In the end I will have to go out there thank goodness I'm off tomorrow well at least I got a free car wash!
 

·
Vendor
Joined
·
1,334 Posts
My connection has been random it's getting better but it's not consistent. My dad suggested it was on Italian time and maybe the connection was coming through from Italy? Which I thought was pretty clever for him since he's 87 years old. My sales guy is supposed to come get the car tomorrow and see about having the dealer run a diagnostic and try to figure out what the problem is. I know of course it'll work when the car gets to the dealer. The question becomes how are we supposed to pair it with my phone if I'm not there? In the end I will have to go out there thank goodness I'm off tomorrow well at least I got a free car wash!
Hello sflboxter,
We understand how this could be frustrating and would like to offer our assistance while you are working with your dealer. Please feel free to send us a private message with your VIN and additional details.
Julie
Alfa Romeo Social Care Specialist
 

·
Registered
2020 gulia
Joined
·
156 Posts
Julie hi thank you for reaching out, way ahead of you already contacted Alfa Romeo USA on Tuesday. They have been in touch with the dealer and discussed from what I gathered a course of action. Unfortunately I have to wait until the 19th of the month that was the first available appointment. However my sales person is trying to move the appointment up because I'm traveling for business and the date does not work for me. So until then I will just be surprised every time I get in the car will it will it not connect?!!
 

·
Registered
Joined
·
1 Posts
Same bluetooth issue here, picked up my 2018 Giulia just over a week ago, Bluetooth gets into the same state, making it unusable. If I get a call while using android auto I get static as the phone rings, but the car won't answer without bluetooth... Frustrating as I commute 1 hour and can't use my phone if someone calls...

Love the car otherwise, but this is going to drive me nuts unless the issue gets fixed...
 

·
Registered
Joined
·
4 Posts
Blackberry connection

Having taken delivery of my Giulia Quadrifoglio I paired my Blackberry with no problem. All contacts synced, except ONE!! The one number I use most. I deleted the contact from my phone and re-entered, no luck. I un-paired the Blackberry and re-paired, no luck!!
I'd welcome any help.
 
1 - 20 of 55 Posts
Top