Alfa Romeo Giulia Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
226 Posts
Discussion Starter · #1 ·
Well I thought I'd pull a Racer Z and take my wife for an afternoon lunch. But 1/4 mile out from our house baby G started to vibrate and then died :(( Service Engine was the warning with CEL.. was able to start up and limp home but G wasn't happy and kept shaking.. Called the dealer's service rep as it was just in yesterday to check the oil temp gauge and do a NAV update.. Service rep told me to call Alfa Roadside Support.. Roadside told me not to drive G and they'd come pick her up, and now she goes in to see what's up.

3500 miles - only issue prior was stalling after refueling.. but the flash at 2k miles solved that. Also today a 2nd error code flashed "service headlights"..

Love driving the car and hope this is just temporary.. On a positive Alfa Premium Care proactively called me this evening and told me that they would cover any rental I wanted from the dealer (Alfa, Maser, and Fiat).. They said they'd check in Monday morning to make sure I got the rental I wanted while it's diagnosed.

Oh, and Alfa Premium confirmed that the temp gauge to the left of the tach is oil temp... My service rep yesterday insisted it was coolant.
 

Attachments

·
Registered
Joined
·
440 Posts
Bummer!

Good luck. Glad to hear Alfa is taking care of you.

.
 

·
Vendor
Joined
·
619 Posts
Glad to see AR stepping up.
 

·
Registered
Joined
·
2,988 Posts
Well I thought I'd pull a Racer Z and take my wife for an afternoon lunch.
Uhm, yes, I've done that.


But 1/4 mile out from our house baby G started to vibrate and then died :(( Service Engine was the warning with CEL.. was able to start up and limp home but G wasn't happy and kept shaking.. Called the dealer's service rep as it was just in yesterday to check the oil temp gauge and do a NAV update.. Service rep told me to call Alfa Roadside Support.. Roadside told me not to drive G and they'd come pick her up, and now she goes in to see what's up.

3500 miles - only issue prior was stalling after refueling.. but the flash at 2k miles solved that. Also today a 2nd error code flashed "service headlights"..

Love driving the car and hope this is just temporary.. On a positive Alfa Premium Care proactively called me this evening and told me that they would cover any rental I wanted from the dealer (Alfa, Maser, and Fiat).. They said they'd check in Monday morning to make sure I got the rental I wanted while it's diagnosed.

Oh, and Alfa Premium confirmed that the temp gauge to the left of the tach is oil temp... My service rep yesterday insisted it was coolant.
Uhm, yes, I've done that too. Just not in the G-car (yet). In my other Alfa, more than once I've waited on Alfa Care to show up.


So, did you ever get any lunch? Or did it turn into a dinner drive in the loaner car?
 

·
Registered
Joined
·
94 Posts
Well I thought I'd pull a Racer Z and take my wife for an afternoon lunch. But 1/4 mile out from our house baby G started to vibrate and then died :(( Service Engine was the warning with CEL.. was able to start up and limp home but G wasn't happy and kept shaking.. Called the dealer's service rep as it was just in yesterday to check the oil temp gauge and do a NAV update.. Service rep told me to call Alfa Roadside Support.. Roadside told me not to drive G and they'd come pick her up, and now she goes in to see what's up.

3500 miles - only issue prior was stalling after refueling.. but the flash at 2k miles solved that. Also today a 2nd error code flashed "service headlights"..

Love driving the car and hope this is just temporary.. On a positive Alfa Premium Care proactively called me this evening and told me that they would cover any rental I wanted from the dealer (Alfa, Maser, and Fiat).. They said they'd check in Monday morning to make sure I got the rental I wanted while it's diagnosed.

Oh, and Alfa Premium confirmed that the temp gauge to the left of the tach is oil temp... My service rep yesterday insisted it was coolant.
My car is at Ferrari Maserati and Alfa Romeo of Seattle for my amp replacement. It's been there for 2 weeks! They can't get the infotainment system to work at all. They are waiting for FCA to provide them with further info on how to get it repaired. At least they've got me in a Guilia Q4 for now. Their service department has been amazing with daily updates and dealing with my constant phone calls.
I'm just south of you in Tacoma. Maybe we will cross paths in the Alfas at some point. Hope all goes well for you!
 

·
Registered
Joined
·
5,016 Posts
Well I thought I'd pull a Racer Z and take my wife for an afternoon lunch. But 1/4 mile out from our house baby G started to vibrate and then died :(( Service Engine was the warning with CEL.. was able to start up and limp home but G wasn't happy and kept shaking.. Called the dealer's service rep as it was just in yesterday to check the oil temp gauge and do a NAV update.. Service rep told me to call Alfa Roadside Support.. Roadside told me not to drive G and they'd come pick her up, and now she goes in to see what's up.

3500 miles - only issue prior was stalling after refueling.. but the flash at 2k miles solved that. Also today a 2nd error code flashed "service headlights"..

Love driving the car and hope this is just temporary.. On a positive Alfa Premium Care proactively called me this evening and told me that they would cover any rental I wanted from the dealer (Alfa, Maser, and Fiat).. They said they'd check in Monday morning to make sure I got the rental I wanted while it's diagnosed.

Oh, and Alfa Premium confirmed that the temp gauge to the left of the tach is oil temp... My service rep yesterday insisted it was coolant.
Sorry to hear..but you may want to consider a new service dealer if their SA told you that and still insisted on it!
 
1 - 7 of 7 Posts
Top