Alfa Romeo Giulia Forum banner
1 - 20 of 41 Posts

·
Registered
Joined
·
179 Posts
Discussion Starter · #1 ·
Nothing in the manual to describe what or why? No light on the dash,etc to correlate. It happens within the first two minutes of driving after startup emanating from the dash area. WTF is it? Searched the manual, web...nothing.
 

·
Registered
Joined
·
1,506 Posts
parking sensor?
 
  • Like
Reactions: BGorilla

·
Vendor
Joined
·
1,328 Posts
Nothing in the manual to describe what or why? No light on the dash,etc to correlate. It happens within the first two minutes of driving after startup emanating from the dash area. WTF is it? Searched the manual, web...nothing.
Hi CJ_Xclr8,

Sorry to hear this! If you end up deciding to visit your local dealership for further diagnosis I'd be happy to offer assistance if needed. Just send us a PM with your VIN and let me know.

Andrea
Alfa Romeo Social Care Specialist
 

·
Registered
Joined
·
179 Posts
Discussion Starter · #6 · (Edited)
Good guess. OP- check that all your parking sensors are clean and unobstructed.
Definitely not the parking sensors. Here is a video. A little fuzzy on the dash display but as you can see there is no visual to match the audible.


Hi CJ_Xclr8,

Sorry to hear this! If you end up deciding to visit your local dealership for further diagnosis I'd be happy to offer assistance if needed. Just send us a PM with your VIN and let me know.

Andrea
Alfa Romeo Social Care Specialist
Thank you. Will let you know.
 

·
Registered
Joined
·
1,506 Posts
Almost sounds like a theft alarm.
 

·
Registered
Joined
·
118 Posts
It sounds like Galaga. That is bizarre. Does it happen at a specific speed or a set time from when the car was started?
 

·
Registered
2020 Alfa Romeo Giulia Sport Ti AWD
Joined
·
7,463 Posts

·
Registered
Joined
·
149 Posts
I have my "speeding alert" setting turned off. How about you? That's my first guess.
 

·
Registered
Joined
·
179 Posts
Discussion Starter · #12 ·
The dealer theorized it was the panic button on the remote being depressed while in my pocket. I disproved that theory. It occurs at different speeds but always within 2-5 min of driving after start.
 

·
Registered
Joined
·
1,186 Posts
Do you have any kind of tracker/LoJack/other non-factory electronics? I have forwarded your video to some contacts in Modena and they say they've never heard that.
 

·
Registered
Joined
·
179 Posts
Discussion Starter · #17 ·
Do you have any kind of tracker/LoJack/other non-factory electronics? I have forwarded your video to some contacts in Modena and they say they've never heard that.

No nothing added. The dealer can't figure it out either.
 

·
Registered
Joined
·
73 Posts
I have never ever heard a sound like that associated with an automobile of any make. I think someone is having some fun at your expense. Can't wait to find out what it is/was. Good luck...
 
1 - 20 of 41 Posts
Top