Alfa Romeo Giulia Forum banner

421 - 436 of 436 Posts

·
Registered
Joined
·
24 Posts
For those with the ENG or the RF...does the OEM Backup Camera operate properly when putting the vehicle in reverse (without having to press a button to switch from AA/ACP to OEM)?
Yes it switches straight to OEM Camera as soon as you select R ... then reverts back to Carplay once in D


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
24 Posts
I’m still waiting to buy (been an expensive month buying the car) but decided on RF.

Wary of the new iOS coming out and it not getting updated swiftly with the others - RF seem to have the best rep for quickly keeping the unit up to date and keeping in touch with the community, even if it’s a couple of quid more to buy.
There’s folk with RF who are already on iOS 14. As Carplay is iOS, the module just mimics the phone app. That’s the way it was explained in the whatsapp group


Sent from my iPhone using Tapatalk
 

·
Registered
2017 Vesuvio Grey Giulia Ti Q2
Joined
·
378 Posts
I updated the firmware all looks pretty much the same apart from new languages and volume control of the map unit.

All seems smooth so far
Thanks for going first :). How long did the update take? I would assume its fairly quick. I had to drive out of town so I didn't want do it right before I left but I will do it next week.
 

·
Registered
Joined
·
193 Posts
No idea to be honest think just volume of the kap unit.. haven't noticed any difference
I am only going to update if the wireless carplay is more reliable while streaming music, I will wait for someone else to report here. Mine is very stable so I wont update at this stage. Hopefully some of the users will keep us posted with their experiences.
 

·
Registered
Joined
·
49 Posts
Thanks for going first :). How long did the update take? I would assume its fairly quick. I had to drive out of town so I didn't want do it right before I left but I will do it next week.
]

Very easy just extract files to the root folder of a USB drive. Put the USB drive in car and select system update in the KAP unit.

Update finished in 2 mins.
 

·
Registered
Joined
·
49 Posts
I had black screen again today so I can confirm the update hasnt fixed this random issue.

I have had the black screen 3 times in 3-4 mths so its not a big deal.

Just switch car off, lock it come back 5-10 mins later and all back to normal.
 

·
Registered
2017 Vesuvio Grey Giulia Ti Q2
Joined
·
378 Posts
I had black screen again today so I can confirm the update hasnt fixed this random issue.

I have had the black screen 3 times in 3-4 mths so its not a big deal.

Just switch car off, lock it come back 5-10 mins later and all back to normal.
Darn! Thanks for the update. The annoyance with the black screen is when I don't have time to just chill for 8 minutes because I need to go somewhere then I have to drive with no screen and no backup camera. But for me it does happen infrequently. I can go for 3 weeks without a black screen and then get it twice in a day however .
 

·
Registered
Joined
·
49 Posts
Darn! Thanks for the update. The annoyance with the black screen is when I don't have time to just chill for 8 minutes because I need to go somewhere then I have to drive with no screen and no backup camera. But for me it does happen infrequently. I can go for 3 weeks without a black screen and then get it twice in a day however .
Yes its very strange ahh well apart from this small bug the unit works perfectly otherwise and couldn't be happier with it..
 

·
Registered
Joined
·
438 Posts
I have twice has my car battery run down to nothing so the car was effectively dead. This has only happened since I got my KAP unit. Does it start on in the background? Anyone else have ongoing drain even with the car off?
 

·
Registered
Joined
·
49 Posts
I have twice has my car battery run down to nothing so the car was effectively dead. This has only happened since I got my KAP unit. Does it start on in the background? Anyone else have ongoing drain even with the car off?
I went in once to see my car battery low.. but could be a coincidence as was a cold morning and hadn't driven the car much.. make sure you lock the car maybe stays in in background if the car isn't locked
 

·
Registered
2017 Vesuvio Grey Giulia Ti Q2
Joined
·
378 Posts
I have twice has my car battery run down to nothing so the car was effectively dead. This has only happened since I got my KAP unit. Does it start on in the background? Anyone else have ongoing drain even with the car off?
I've had my battery replaced since the KAP unit but I don't think KAP was the cause. The replacement was done under warranty by the dealership because the start stop was no longer working and the cause was low charge on the battery. Stop Start had stopped working well before I installed the KAP unit which leads me to believe it wasn't caused by KAP. Since the battery replacement on 6/19 my stop start has performed correctly and I haven't had any battery issues.
 

·
Registered
Joined
·
193 Posts
Good thought...I never lock my car in the garage...
Hi I have had the KAP unit installed end of April, driving the car rarely these days, i never lock the car in the garage, never had an issue with the battery and its winter here (0 deg Celsius to 15 during the day )
 
421 - 436 of 436 Posts
Top