Alfa Romeo Giulia Forum banner
1 - 20 of 22 Posts

· Registered
Joined
·
285 Posts
Discussion Starter · #1 ·
The car may be still too new, has anyone heard about possible upgrades from local reputable outlets for apple carplay systems compatible displays, changing the whole new head unit without affecting the car functionality? would this be a possibility
I don't think that we will ever have an upgrade path from AR.
 

· Registered
Joined
·
285 Posts
Discussion Starter · #5 ·
BREAKING NEWS :)
Zagames are testing the first trial install of aftermarket Apple Carplay unit on 2017 Giulia with Autofidelity in Moorabin.
The guys ftom Autofidelity are professionals, they installed reverse camera on my 17 Giulietta Veloce and I never have problem with it, i hope for the positive outcome for the AAC
Stay tuned for updates
who at zagame you spoke to?? I just asked yesterday???? there was no news...
 

· Registered
Joined
·
285 Posts
Discussion Starter · #27 ·
Well, install done at Autofidelity, tested out for few hours on the way back home. Working perfectly. Requires a new microphone installed. Integration works really well with the centre console buttons, siri works impeccably. Can swap back and forward to factory screen and apple carplay seamlessly. I will upload a short video sometime later tonight or tomorrow morning. Apple carplay functionality is full , not limited. Great news for all those that could not get Carplay on MY17's.
 

· Registered
Joined
·
285 Posts
Discussion Starter · #29 ·
Nice one, can't wait to see. Is the microphone part of the install?

What's the background to this, were you just fed up with the existing system?
Yes all part of the install, also another USB port in the centre console above the cup holder (I forgot to mention) This port has the carplay capability. At the end of the video shows the small mic installed barely see it top of windscreen. It uses the AUX for sound , does not interfere with the infotainment functions.
As promised a short video.
Download Attachment
Available until 24 May 2020
 

· Registered
Joined
·
285 Posts
Discussion Starter · #31 ·
you wouldn't know the mic is there, quite inconspicuous, its used for SIri which works great. Not sure if was going to create issues with build in mic, as original mic is used for all the normal car functions still.
 

· Registered
Joined
·
285 Posts
Discussion Starter · #37 ·
Hey George, did you ask if it's the KAP module that you have installed or different.
Also did you go through Zagame and how much it cost you?
Not sure, its more involved than self install which I believe KAP was meant to be? No Zagame, straight to the source.
Seems like the prices are fluctuating due to weak aussie dollar $1300-1400
 

· Registered
Joined
·
285 Posts
Discussion Starter · #47 ·
Not that i know off, but mine is going well. Had some issue with wireless carplay slight drops in audio while listening to spotify or music generally, corrected by workaround connected to car Bluetooth. I am on carplay screen while driving .If I need carplay navigation instructions audible i need to switch to AUX by simply pressing voice command on steering wheel and say" switch to auxiliary",
Cabled carrplay its no issue.
 

· Registered
Joined
·
285 Posts
Discussion Starter · #114 ·
Getting issues with Apple carplay not being able to hear people when making or receiving calls, any idea how to fix ?
Just delete Bluetooth profile from alfa system and phone, just use AA or AC wirelessly , should work flawlessly. Basically just use the new system for everything otherwise will change input automatically from AUX when you get a call through thats why you cant hear anything
 

· Registered
Joined
·
285 Posts
Discussion Starter · #161 ·
View attachment 135395 So I’ve installed mine. Moderate difficulty. I had a question. When using the wireless apple CarPlay, I connected through wifi, this disconnects me from my regular Wi-Fi. Is this the proper connection or is it just through Bluetooth? I’ve been using it hardwired for now so I don’t disconnect from my regular Wi-Fi.
While is using wireless carplay is using the wifi connection not Bluetooth, the Bluetooth connection its only getting used for initial handshake to pair the phone. I am a bit lost I am assuming that when you are driving away from home it's not using your wifi (home etc) so what's the deal, if you're in the garage i can see how this would happen but why would you use the apple carplay then...? I must ve missed something...
 
1 - 20 of 22 Posts
Top