Alfa Romeo Giulia Forum banner
1 - 15 of 15 Posts

·
Super Moderator
Joined
·
1,086 Posts
Thanks very much for posting the info.

Crossweight balance is fairly even LF+RR and RF+RR DIV into total car weight. It's not perfect but **** good for a non calibrated street car. Moving the tire inflator to one side or the other makes all the difference. Ha.

Post the factory alignment? Did they tweak it at all?

You know you want to post the dyno result as well ;)
 

·
Super Moderator
Joined
·
1,086 Posts
Also this is in All Season Tires add about 4lbs if you want to get technical lol.
The 50/50 weight balance is affected by not having a full tank of gas. Fill it up! LOL
 
  • Like
Reactions: that boy asad

·
Registered
Joined
·
418 Posts
The 50/50 weight balance is affected by not having a full tank of gas. Fill it up! LOL
That's spot on. Shipping weight on the vehicle shipping order was 3,735 and that was with a quarter or an eighth of a tank. (I believe the one we had come through was identical spec to yours.)
 

·
Registered
Joined
·
39 Posts
Did you run a dyno on yours already????
 

·
Registered
Joined
·
1,408 Posts
Discussion Starter · #8 ·
No dyno was done. An Attempt was made but failed. Big thanks to @[email protected] for the advice

Will post alignment specs in the suspension thread. Yes you can corner balance the car to bring in weights closer. My guess is the fact that the European car is 50/50 while an American much heavier version loss a little in the balance.
 

·
Super Moderator
Joined
·
1,086 Posts
So the dyno "race" mode was not effective because the 2 front wheels were stationary?

What is the workaround?

My thought would be to disconnect the ABS sensors from the rear wheels and see what happens.
 

·
Super Moderator
Joined
·
1,086 Posts
What symptom did the car exhibit when trying to run it? Cluster lit up like a christmas tree?
 

·
Registered
Joined
·
1,408 Posts
Discussion Starter · #12 ·
What symptom did the car exhibit when trying to run it? Cluster lit up like a christmas tree?

Car went into LIMP mode killed power by 70% by reducing valve body opening. It was a Christmas tree to say the least !
 

·
Super Moderator
Joined
·
1,086 Posts
Interesting. Quick battery reset brought it back to life or did it clear itself once all 4 wheels were seen rolling again?
 

·
Registered
Joined
·
7 Posts
For some reason couldn't see your photo that shows the weight. Do you have carbon seats on yours? Just picked up my QV 2 days ago.
 
1 - 15 of 15 Posts
Top