Alfa Romeo Giulia Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
153 Posts
Discussion Starter · #1 ·
I have a 17 Quad and yesterday during a rather fast drive, a fault light came up on the cluster indicating "active aerodynamics not available". I assume it is related to the active front splitter. I search for solution on this forum but there were none. The warning light stayed on until I shut the car off and now it is not showing. So here are my questions. Anyone experienced this and what is it? Since it is not showing now will the error be stored somewhere and the dealer able to pull it out to see what is going on?
 

·
Registered
Joined
·
5,124 Posts
is your splitter deployed even with the car off position??.does it look not flush to the body?..I think that a member here had an issue with some road debris that wedged itself in a spot so the splitter could not close fully and triggered the sensor..
 

·
Registered
Joined
·
153 Posts
Discussion Starter · #4 ·
is your splitter deployed even with the car off position??.does it look not flush to the body?..I think that a member here had an issue with some road debris that wedged itself in a spot so the splitter could not close fully and triggered the sensor..
I checked and it appear to be flush with the body. I am taking it to dealer today to fix a blinking odometer and will have them take a look at it. Will report what they find. Thank you for the reply.
 

·
Registered
Joined
·
38 Posts
Had this happen last weekend. It had a piece of paper lodged in between and the splitter did not fully retract. I cleared out the paper and when I drove back home, the fault light was out.
 

·
Registered
2020 Alfa Romeo Giulia Sport Ti AWD
Joined
·
7,754 Posts
Active aerodynamics fault light

Maybe it was the missing 'o'? :wink2:
 
1 - 7 of 7 Posts
Top