Alfa Romeo Giulia Forum banner
1 - 13 of 13 Posts

· Registered
2018 Giulia QV
Joined
·
20 Posts
Discussion Starter · #1 ·
Recently picked up a 2018 Giulia QV w/ ~16k miles and after a couple days of care-free and joyous driving around town; the limp mode (limited to N-drive mode, 25mph, 4th gear, etc.) deal happened after getting off the freeway, and my dash lit up like a Christmas tree (service AST, dampers, electronic throttle control, power steering...). Got the car on a flatbed and took it to the dealer, and has been there for a couple days now with no updates on what happened or why. Not sounding too promising but based on my youtube/forum research, might just be a battery issue and the codes need clearing? I'd assume the Alfa tech would've recognized this by now if it were that easy of a fix...

Any comments/recommendations are welcome. Just want to try and get to the bottom of this soon! Finally found my dream car with the options/color I wanted and am hoping I didn't accidentally purchase a dud QV.

-CW
 

· Registered
Joined
·
217 Posts
Recently picked up a 2018 Giulia QV w/ ~16k miles and after a couple days of care-free and joyous driving around town; the limp mode (limited to N-drive mode, 25mph, 4th gear, etc.) deal happened after getting off the freeway, and my dash lit up like a Christmas tree (service AST, dampers, electronic throttle control, power steering...). Got the car on a flatbed and took it to the dealer, and has been there for a couple days now with no updates on what happened or why. Not sounding too promising but based on my youtube/forum research, might just be a battery issue and the codes need clearing? I'd assume the Alfa tech would've recognized this by now if it were that easy of a fix...

Any comments/recommendations are welcome. Just want to try and get to the bottom of this soon! Finally found my dream car with the options/color I wanted and am hoping I didn't accidentally purchase a dud QV.

-CW
Could be a lot of reasons the tech hasn't responded yet especially if you are not sure your car has even gotten looked at yet. I wouldn't weigh the problem based on that.

All I will say is that it seems as though so many owners have an electrical battery issue right after getting the car. I had mine for 3 weeks. Got a battery tender installed and few days later my battery was dead and the dash was like a Christmas tree, Charged the battery with an actual battery charger, put back on tender. Never an issue since.

I just wonder if letting these cars sit makes the battery all funky even if they are new or slightly used.

Keep us posted.
 

· Registered
Joined
·
4,439 Posts
I'm sure it's a Dream Car and you got that one right. Why did you flatbed it to the dealership?. You'll need to get used to the random CELs with the respective default limp mode happening sometimes. The majority of the times, the CELs can be cleared with a 4 stops/stars of the engine in a row procedure. If not, you can drive the car with the "Christmas tree" showing on the dash and in limp mode to the dealership for them to clear the CELs and erase the error codes. I am not surprised the dealership has no clue on what is going on, and I am almost positive that it is a bad battery. There is always the remote possibility that there is something really wrong but, thinking that the dealership is going to diagnose it and fix it is too optimistic. Ask them to test and fully re-charge the battery, if they do not want to change the battery form a new one. Buy a battery charger and plug it a couple of times per month, when you have a chance. Hope everything will be fine and you will get your Dream Car back soon.
 

· Registered
2018 Giulia QV
Joined
·
20 Posts
Discussion Starter · #4 ·
I just got a response from the Alfa tech and they say they have found out what is going on. The battery/charging is fine, but the PCM has an internal fault which has been unable to get cleared (on module #1?) causing the repeat limp/dash lights after start, and the engineer has ordered a new one which will get in ~2 days. He said I should be back behind the wheel on Friday...
 

· Registered
2018 Giulia QV
Joined
·
203 Posts
Glad to see they seemed to have found the issue.

But as another data point, I had the Christmas tree light problem as well a couple of weeks ago with my early 2018 QV. I was passing an 18 wheeler on a 2 lane road going about 50 to 70 in N mode and it lit up during acceleration. Got pretty much the same error as the OP. After a few starts, they all cleared. I looked at the codes with MES and several of them I couldn't even find when I Googled them. I'm pretty sure it was my battery which I replaced. With the code descriptions, it looked like a short, mass communication failure. I happened to have bought one already and hadn't got around installing it. The battery was original and had noticed the auto stop/start was not usually working (I forget to turn it off some times). I had checked the voltage and it was around 12.2 when it should be more like 12.6. Plus it is about 4.5 years old. Not had a problem since, but it has only been a couple of weeks and it only happened that one time. Time will tell. BTW, I saved the error codes in case anyone is interested to know what they were. Just let me know.
 

· Registered
2019 QV Rosso Comp
Joined
·
1,410 Posts
I'm sure it's a Dream Car and you got that one right.
I 100% agree that this is a dream car but it is hilarious to see these threads where, like clockwork, the third post is @Giuliano reminding us this is a dream car.
 

· Registered
Joined
·
4,439 Posts
I 100% agree that this is a dream car but it is hilarious to see these threads where, like clockwork, the third post is @Giuliano reminding us this is a dream car.
And, people still don't get it. I have no problems to keep spreading the truth, in a post #3 of the threads !!!!!
 

· Registered
2018 Giulia QV
Joined
·
20 Posts
Discussion Starter · #8 ·
Update - New PCM installed and faults/lights still coming on even after tech drove the car multiple times over the weekend with no issues. Alfa tech believes at this point it may be the pedal.. as it's not reading any voltage when gas pedal is pressed. Pretty terrible news considering they said the car was clear for pickup today...
 

· Registered
Joined
·
4,439 Posts
Update - New PCM installed and faults/lights still coming on even after tech drove the car multiple times over the weekend with no issues. Alfa tech believes at this point it may be the pedal.. as it's not reading any voltage when gas pedal is pressed. Pretty terrible news considering they said the car was clear for pickup today...
Hope that you can find a good Alfa Romeo dealership with technicians who know something about these cars. There are great technicians and good dealerships around but, not many, unfortunately. Hang in there. Sooner or later they will figure it out. The good news, you will have your car with many brand new parts on it, for free.
 

· Registered
2018 Giulia QV
Joined
·
20 Posts
Discussion Starter · #11 ·
In case anyone is still following this thread.... Still no QV. Hope and patience levels are miniscule, and correspondence from the dealer regarding any repair updates is dreadful. I have gone to pickup the vehicle three different times now after being told "we're good to go/it is fixed" and each time all of the lights are still on and car is still limping upon pickup. Nothing back from my case that was opened with Alfa Premium care specialist dude. After this experience, not sure if my love from the brand still remains.
 

· Registered
2018 Misano Giulia QV + 2017 Macan Turbo w/ PP
Joined
·
60 Posts
In case anyone is still following this thread.... Still no QV. Hope and patience levels are miniscule, and correspondence from the dealer regarding any repair updates is dreadful. I have gone to pickup the vehicle three different times now after being told "we're good to go/it is fixed" and each time all of the lights are still on and car is still limping upon pickup. Nothing back from my case that was opened with Alfa Premium care specialist dude. After this experience, not sure if my love from the brand still remains.
Hang in there. 🙏🏼
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top