Alfa Romeo Giulia Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I recently got a CPO 2017 Giulia Ti Sport its been less than a month and i started to notice a couple of Issues with the Car, I'm writing here to see if anyone is facing similar issues with the car.

1. The car Jerks/jumps at 10 Mph in all three drive modes. ( This issue started after i drove my car in the rain one evening )
2. Same day I was driving the car in the rain and the water went inside my Headlamps and my turn signal lights and daytime lights stopped working.

Has anyone come across these issues ?

Jay
 

·
Vendor
Joined
·
1,188 Posts
I recently got a CPO 2017 Giulia Ti Sport its been less than a month and i started to notice a couple of Issues with the Car, I'm writing here to see if anyone is facing similar issues with the car.

1. The car Jerks/jumps at 10 Mph in all three drive modes. ( This issue started after i drove my car in the rain one evening )
2. Same day I was driving the car in the rain and the water went inside my Headlamps and my turn signal lights and daytime lights stopped working.

Has anyone come across these issues ?

Jay
Hi, I'm sorry to hear this. Please let me know if you plan on visiting a dealership for this concern. I would be happy to open a case for you.

Alison
AlfaRomeoCares
 

·
Registered
Joined
·
19 Posts
I also have a 2017 Giulia TI. I have not experienced any these issues, but am following the thread. Hope you can get it resolved.
 

·
Registered
2017 Vesuvio Grey Giulia Ti Q2
Joined
·
394 Posts
2. Same day I was driving the car in the rain and the water went inside my Headlamps and my turn signal lights and daytime lights stopped working.
The water in the headlights is an issue at times with 2017s. One of mine failed within the first month. Its a production issue with the way they are sealed that was resolved in the 2018s. They should replace it under warranty hopefully.
 
  • Like
Reactions: Ajax240k

·
Registered
Joined
·
6,284 Posts
The water in the headlights is an issue at times with 2017s. One of mine failed within the first month. Its a production issue with the way they are sealed that was resolved in the 2018s. They should replace it under warranty hopefully.
Not entirely. I see some corrosion (no obvious moiisture) inside of my right headlamp in my MY2018 Giulia. The backside of the headlights is not fully waterproof and the wheel well is supposed to deflect all of the high pressure water away from the back of the headlights. Note that there is an access panel in the wheel well for the purpose of changing the light bulb in the headlight and omission or incorrect installation of same has caused the failure of some forum members' headlights.

Didn't the CPO Giulia come with some kind of warranty?
 
  • Like
Reactions: MorganB

·
Registered
Joined
·
2 Posts
Discussion Starter #6
Hey Guys,

They replaced my Headlight, However there was a bigger issue that.... I'm posting here hoping it will help anyone facing with the same problem

after examining the dealer replaced the Engine Mounts and I was told Transfer case assy( AWD doesn't work) needs to be changed. I brought the car out from the dealer as they confirmed its safe to drive. However since then i am seeing a lot of Issues

1. my passenger seat doesn't move
2. automatic Brake system does not work
3. ride is really bumpy
4.there a big cranky sound when you drive the car
5. Acceleration LAG

I was not expecting these many issues with a CPO car its very disappointing over these i was trying to reach out to the dealer and there is no response.
 

·
Registered
Joined
·
2,879 Posts
Nothing about having AWD not working in an AWD car sounds safe to me.
 

·
Registered
Joined
·
78 Posts
Geez dude. What dealer did that CPO? Engine mounts and AWD transfer case? Was this car in an accident? It sounds like there are some serious mechanical/electrical issues there. Maybe water got in somewhere else and really did a number on everything.
 
1 - 8 of 8 Posts
Top