Alfa Romeo Giulia Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
I'm partway on a drive to Wisconsin from houston, TX and at one point moved the electric seat forward to put some luggage behind the seat. Now it won't move back, in fact none of the drivers seat buttons work at all. Very difficult to drive with seat far forward. Passenger seat controls work fine, and both side seat heaters work fine. Can anyone help me remotely troubleshoot? I can't find anything that indicates a particular fuse in the owner's manual. Will be awful to drive another 1500 miles like this.

Thoughts?
 

·
Registered
Joined
·
1,307 Posts
So, you have turned off the car, let it sit for a few minutes, and then turned it back on, yes? Sorry if I am asking a dumb question
 

·
Registered
2018 Q4 with Fiamenghi Ti exhaust, Race Mod, and Tecnico wheels.
Joined
·
8,194 Posts
Silly question, but have you removed the luggage from behind the seat?

There is the infamous "courtesy seat back" feature that has the potential to crush stuff on the rear floor like luggage or the rear passenger's feet. I am wondering if there might be a sensor to prevent an ugly incident.
 

·
Registered
Joined
·
771 Posts
Did you try disconnecting the battery negative cable, letting it sit for a little, then reconnecting it? (Just read the manual on replacing the battery and no warnings about any special procedures necessary).
 

·
Registered
2017 Ti Q2
Joined
·
213 Posts
It may be a silly question but did you check to see if the power plug under the seat somehow become unplugged?
I had a similar problem with the passenger seat. I jiggled the wires underneath the seat, and the problem went away.
 
1 - 8 of 8 Posts
Top