Alfa Romeo Giulia Forum banner

641 - 660 of 737 Posts

·
Registered
Joined
·
1,305 Posts
mid damper is best for launch. Tire is everything. If you’re running corsa you will always struggle with traction. Toyo r888r or ET streets will launch better. Strangely my bald toyo hooked better than the brand new corsa I just threw on two weeks ag
Thanks. I wasn’t sure about the dampers. I’m using all season AS 3+’s. right now until the Corsa’s go back on. They make great winter tires where you’re not looking for real deep snow performance but just want good wet cold performance. They have not so great dry ultimate performance though so that’s why I’m happy with a 3.9 0-60 time on them...

Bald tires with no tread are better than almost anything though in dry traction short of slicks unless you get them wet. I actually like the feel of the corsa’s and I have a set that’s nearly done that I’m going to try to use up in a few weeks lol.
 

·
Registered
Joined
·
2,107 Posts
The corsas get real sticky once you get them good and hot. The problem is that's pretty impossible to do on the street. You might try underinflating quite a bit. Will cause the heat to build faster.
 

·
Registered
Joined
·
1,305 Posts
Yeah I noticed on the track the first few laps the Corsa’s were meh but as they got hotter and hotter they became like glue. Maybe a brake stand for a few seconds before launch to heat them up each time.
 

·
Registered
Joined
·
353 Posts
Your 60ft of low 1.9x shows the launch was fine for rwd. The cars just not making tuned power for you. Could be da, could be iats, fuel quality.
 

·
Registered
‘19 Giulia Ti Sport Q4
Joined
·
3,530 Posts
Discussion Starter #648
2019 ti sport MPP Sprint drop in filter madness go pedal. Seems I started off great but finished a bit poor. I thought these cars it's supposed to be the other way? Thoughts or advice? Thanks.
You cut off the rollout time on the bottom of the 0-60 run; can you repost?

Launch looks good, but what kind of car do you have? You really should list that in your sig or somewhere visible. And how did you launch? Did you floor it or brake boost?

1/4 mile reveals, probably, that you lifted before the end, so I’m thinking you’d have been in a decent range otherwise. Given that, you just need to work on nailing the 0-60 launch.

EDIT: looking closer, you started to trail off around 40mph on the 60 run; did you keep it buried, because if not there might be something going on.
 

·
Registered
Joined
·
54 Posts
You cut off the rollout time on the bottom of the 0-60 run; can you repost?

Launch looks good, but what kind of car do you have? You really should list that in your sig or somewhere visible. And how did you launch? Did you floor it or brake boost?

1/4 mile reveals, probably, that you lifted before the end, so I’m thinking you’d have been in a decent range otherwise. Given that, you just need to work on nailing the 0-60 launch.

EDIT: looking closer, you started to trail off around 40mph on the 60 run; did you keep it buried, because if not there might be something going on.
 

Attachments

·
Registered
Joined
·
54 Posts
You cut off the rollout time on the bottom of the 0-60 run; can you repost?

Launch looks good, but what kind of car do you have? You really should list that in your sig or somewhere visible. And how did you launch? Did you floor it or brake boost?

1/4 mile reveals, probably, that you lifted before the end, so I’m thinking you’d have been in a decent range otherwise. Given that, you just need to work on nailing the 0-60 launch.

EDIT: looking closer, you started to trail off around 40mph on the 60 run; did you keep it buried, because if not there might be something going on.
I have a 2019 ti sport AWD giulia with MPP recently inatalled, Sprint drop in filter and madness GO pedal...I held the break down till about 2400 rpm
 

·
Registered
‘19 Giulia Ti Sport Q4
Joined
·
3,530 Posts
Discussion Starter #652
When did you put on the MPP? Enough miles for adaptation? Also, I always try to be aggressive on the throttle (e.g. do some WOT runs) before making timed runs so that the trans “knows” what I want and is performing in “sport” mode.

Also, did you have GoPedal in Sport mode?

I wouldn’t worry at this point, as there are many variables; I bet you will shave .3sec off that 4.8sec run pretty soon!
 

·
Registered
Joined
·
54 Posts
When did you put on the MPP? Enough miles for adaptation? Also, I always try to be aggressive on the throttle (e.g. do some WOT runs) before making timed runs so that the trans “knows” what I want and is performing in “sport” mode.

Also, did you have GoPedal in Sport mode?

I wouldn’t worry at this point, as there are many variables; I bet you will shave .3sec off that 4.8sec run pretty soon!
Ya I probably have about 250 miles on the MPP, I have the older Bluetooth go pedal and yes had it in sport. I also have the TDI tune I was using and will put it back on to see what that one produces out of curiosity. I was just concerned after looking at everyone else's time like you said I was doing well till after 30/40mph and then it fell off which again I thought was weird be wise I thought this is where these cars start to Excel...
 

·
Registered
Joined
·
1,682 Posts
Here's my 1/8
1/8 mile looks pretty good compared to other times I’ve seen. I haven’t seen anyone in a 2.0 hit 90mph yet on 1/8. That’s usually the somewhat cutoff or target mph in 1/8 to get into 12s on 1/4 mile. Just practice like others have said. If your on street many factors come into play. Just one pothole or bump can drastically change entire runs and time. Wind. Temps. DA. Etc
 

·
Registered
Joined
·
180 Posts
You would be best served by letting the TCM handle the gear changes..I guarantee it has a better idea of when to shift than anyone on here.....not even professional drag racers do it themselves anymore..
my car seems to hit the rev limiter and get lower times if manual is not used :(
 

·
Registered
Joined
·
180 Posts
So at what Rpm do you switch gears? Also, what improvements have you seen by shifting manually as far as times?
done mostly on feel since I drive the car manual 75% of the time. First gear I click up at like 3500 since it doesn’t actually happen until ~5k rpm. I shoot for that timing where it kicks into the next gear.

I've only done a couple passes. But I couldn't get under 5s in auto. In manual, I pulled a verified 4.79s and an unverified 4.61. gonna try some more... Will post back results.
 

·
Registered
Joined
·
353 Posts
This was stock just with go pedal. With MPP i did 4.8 with 1ft roll. It's consistently .3 faster with MPP. Is this normal gain to expect? 1/8 I'm seeing an average of .25 better than stock
Depends on the density altitude. They needto be comparable. In negative da i do 4.74 to 60 and 13.3 at 104mph in the quarter bone stock. But that's great conditions
 

·
Registered
Joined
·
54 Posts
Depends on the density altitude. They needto be comparable. In negative da i do 4.74 to 60 and 13.3 at 104mph in the quarter bone stock. But that's great conditions
I did the runs today about an hour apart and all in negative da so is my car broken, my tune, or me? 1/4 mile trap with tune is 2mph better than stock...something isn't adding up?
 
641 - 660 of 737 Posts
Top