Alfa Romeo Giulia Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
321 Posts
hey simey, great find i posted one that the guy had a grin from ear to ear. p.s how has it been with your QV did you try race mode yet. or did you get car ceramic coated yet? last time i checked car was on its way to states waiting for my father in law to get me name of ship so i can track ship.(ex- captain) for large ships in Italy has inside tract on captains there ships and cargo.
 

·
Registered
Joined
·
47 Posts
Notice how she launches the Alfa to get maximum acceleration —*brake & accelerator simultaneously and then releases the brake. No sign of limp mode, just an aggressive start.
Maybe it's an US-only "feature"?
 

·
Registered
Joined
·
641 Posts
Discussion Starter · #4 ·
hey simey, great find i posted one that the guy had a grin from ear to ear. p.s how has it been with your QV did you try race mode yet. or did you get car ceramic coated yet? last time i checked car was on its way to states waiting for my father in law to get me name of ship so i can track ship.(ex- captain) for large ships in Italy has inside tract on captains there ships and cargo.
Sal, that grin is what I have on every time I drive the Quad. It's funny you ask if I've tried race mode. Thought I would work up to it. Day one I did so and now I have it on 80% of the time. The sound is just so amazing. Uses up a LOT of gas though when in automatic as the engine maintains around 4,000 revs all the time. I received my exhaust flap controller late last week and am having it installed on Wednesday. I will be able to turn on that race mode sound in any drive mode. Should pay for itself in gas savings alone lol.

Ceramic coating finished just over a week ago and looks fab. Not allowed to wash the car for two to three weeks to ensure proper curing. Pic below.
 

Attachments

·
Registered
Joined
·
641 Posts
Discussion Starter · #5 ·
Notice how she launches the Alfa to get maximum acceleration ?*brake & accelerator simultaneously and then releases the brake. No sign of limp mode, just an aggressive start.
Maybe it's an US-only "feature"?
I read about that in some reviews. One was a British review so should work everywhere. From what I've read, the limp mode issue only seems to happen with trail braking when at speed, not from a standing start. I'm going to play around with launching when I get the chance and will report back.
 

·
Registered
Joined
·
437 Posts
I read about that in some reviews. One was a British review so should work everywhere. From what I've read, the limp mode issue only seems to happen with trail braking when at speed, not from a standing start. I'm going to play around with launching when I get the chance and will report back.
x2, I'm pretty sure that issue was only an issue at speed, and never from a stationary launch. The QV has Line Lock mode.

Turn Car in Race mode
Left Foot Brake
Right Foot Gas
Let go of Brake
 

·
Registered
Joined
·
1,963 Posts
I thought that "brake line lock" was used to engage the front brakes only to hold the car in place so one can spin the rear tires to heat them up so that they grip better on launch. When modulated properly, it would also help to put down a really long rear tire signature.
 

·
Supporting Vendor
Joined
·
691 Posts
I thought that "brake line lock" was used to engage the front brakes only to hold the car in place so one can spin the rear tires to heat them up so that they grip better on launch. When modulated properly, it would also help to put down a really long rear tire signature.
I'm not sure it's technically a line locker; I've never seen any official documentation that describes it as that. I think the torque may just be overpowering the rear brakes and allowing wheel spin. Whatever the technical details it's definitely a lot of fun.
 

·
Registered
Joined
·
321 Posts
Sal, that grin is what I have on every time I drive the Quad. It's funny you ask if I've tried race mode. Thought I would work up to it. Day one I did so and now I have it on 80% of the time. The sound is just so amazing. Uses up a LOT of gas though when in automatic as the engine maintains around 4,000 revs all the time. I received my exhaust flap controller late last week and am having it installed on Wednesday. I will be able to turn on that race mode sound in any drive mode. Should pay for itself in gas savings alone lol.

Ceramic coating finished just over a week ago and looks fab. Not allowed to wash the car for two to three weeks to ensure proper curing. Pic below.
looks great are you going to clear bra it as well or do you think its over kill I'm thinking of doing both.
 

·
Registered
Joined
·
134 Posts
Hey Simey,

"Ceramic coating finished just over a week ago and looks fab. Not allowed to wash the car for two to three weeks to ensure proper curing. Pic below."

Which product did you use? Optimum from Detail King, Carbon Flex C9 from Chemical Guys, or other? And did you do it yourself or have someone do it for you? (ballpark price??).
As for Clear Bra, I would definitely do that also - From what I have read, I dont think Ceramic coating will protect against rock chips as well as a Clear Bra.
Thanks in advance!
 

·
Registered
Joined
·
641 Posts
Discussion Starter · #12 ·
Hey Simey,

"Ceramic coating finished just over a week ago and looks fab. Not allowed to wash the car for two to three weeks to ensure proper curing. Pic below."

Which product did you use? Optimum from Detail King, Carbon Flex C9 from Chemical Guys, or other? And did you do it yourself or have someone do it for you? (ballpark price??).
As for Clear Bra, I would definitely do that also - From what I have read, I dont think Ceramic coating will protect against rock chips as well as a Clear Bra.
Thanks in advance!
Hey Vailoce,

I used CeramicPro C9 and had it professionally done. I chose what they call the Silver package which has a 5 year guarantee. Cost was $1,500 plus tax. Not inexpensive but I believe a worthwhile investment. You are correct that it doesn't really protect against chips but definitely against scratches. Like the clear bra idea and will consider that too.

My next update though is having the Forza exhaust controller installed tomorrow. It will allow me to turn on race mode exhaust without actually having to go into race mode (which is what I've been doing 80% of the time).
 

·
Registered
Joined
·
3,600 Posts
Notice how she launches the Alfa to get maximum acceleration —*brake & accelerator simultaneously and then releases the brake. No sign of limp mode, just an aggressive start.
Maybe it's an US-only "feature"?
Ah, no, like the posts above, line lock or launch mode. The car can tell when you are moving or at a complete stop. Ever since throttle by wire and F1 transmission cars, the computers have been sophisticated enough to know when what sensors are in what position and programmed accordingly. There are times when you can not shift into gear on an F1 transmission. Like trying to shift into first when rolling out of neutral from a higher gear or when the hydraulic pump fails on the F1 robot controller. I am pretty sure, like many on the forum, that the big limp mode failure was due to pressing both pedals while rolling and a software fault that was corrected in the first update. There may still be a combination that has slipped though the cracks but it is a software issue and not a design flaw in the car.
 

·
Registered
Joined
·
47 Posts
Ah, no, like the posts above, line lock or launch mode. The car can tell when you are moving or at a complete stop. Ever since throttle by wire and F1 transmission cars, the computers have been sophisticated enough to know when what sensors are in what position and programmed accordingly. There are times when you can not shift into gear on an F1 transmission. Like trying to shift into first when rolling out of neutral from a higher gear or when the hydraulic pump fails on the F1 robot controller. I am pretty sure, like many on the forum, that the big limp mode failure was due to pressing both pedals while rolling and a software fault that was corrected in the first update. There may still be a combination that has slipped though the cracks but it is a software issue and not a design flaw in the car.
Thanks :) I haven't tested this yet, hoping to have a chance very, very soon...
 

·
Registered
Joined
·
641 Posts
Discussion Starter · #16 ·
So I had the opportunity to try launch mode today. 5:30 am this morning on my way to my regular golf game (yes the bag does fit in the trunk if you remove the driver). On a nice straight and quiet road, stopped the car, left foot on brake, right on go pedal and in Dynamic. Pressed accelerator and held the brake against the car trying to go. Revs went to about 2,000 and of course it felt like the car really wanted to go....so I let it. Minor wheel spin and a great launch. Tried it again, same thing....launched beautifully as the turbos had already spooled up nicely.

Feels like you don't want to try and hold it for more than a second or two so a little practice is a good thing.

Anyone else had the experience? If we are going to remain true to the Q's 3.8 0-60 then we have to know how to launch, right?
 

·
Registered
Joined
·
25 Posts
So I had the opportunity to try launch mode today. 5:30 am this morning on my way to my regular golf game (yes the bag does fit in the trunk if you remove the driver). On a nice straight and quiet road, stopped the car, left foot on brake, right on go pedal and in Dynamic. Pressed accelerator and held the brake against the car trying to go. Revs went to about 2,000 and of course it felt like the car really wanted to go....so I let it. Minor wheel spin and a great launch. Tried it again, same thing....launched beautifully as the turbos had already spooled up nicely.

Feels like you don't want to try and hold it for more than a second or two so a little practice is a good thing.

Anyone else had the experience? If we are going to remain true to the Q's 3.8 0-60 then we have to know how to launch, right?
Did you press the pedal all the way down after holding the break pedal with the left foot? Did the revs held themselves at 2000?
 
1 - 18 of 18 Posts
Top